Non-interactive install of package fails

Bug #1022718 reported by Jon Topper on 2012-07-09
24
This bug affects 3 people
Affects Status Importance Assigned to Milestone
389-ds-base (Debian)
Fix Released
Unknown
389-ds-base (Ubuntu)
Undecided
Unassigned
Precise
High
Timo Aaltonen

Bug Description

[Impact]

non-interactive installations of 389-ds-base fail

[Test Case]

try to install the package noninteractively

[Regression Potential]

none, the bug is caused by old packaging leftovers that should be removed

--

I'm using the Quantal version of this package, back-ported (myself) to a Precise system, however the same bug is present on Precise.

I'm attempting to install this package using Puppet, which uses the equivalent of the following command to do so:

  DEBIAN_FRONTEND=noninteractive APT_LISTBUGS_FRONTEND=none APT_LISTCHANGES_FRONTEND=none /usr/bin/apt-get -q -y -o DPkg::Options::=--force-confold install 389-ds-base

This results in the following error:

dpkg: error processing 389-ds-base (--configure):
 subprocess installed post-installation script returned error exit status 30
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 389-ds-base
E: Sub-process /usr/bin/dpkg returned an error code (1)

When run under DEBCONF_DEBUG=developer, I get

debconf (developer): frontend started
debconf (developer): frontend running, package name is 389-ds-base
debconf (developer): starting /var/lib/dpkg/info/389-ds-base.config configure
debconf (developer): <-- INPUT high 389-ds-base/setup
debconf (developer): --> 30 question skipped
dpkg: error processing 389-ds-base (--configure):
 subprocess installed post-installation script returned error exit status 30
Processing triggers for libc-bin ...
ldconfig deferred processing now taking place
Errors were encountered while processing:
 389-ds-base
E: Sub-process /usr/bin/dpkg returned an error code (1)

As far as I can tell, the problem exists because the debconf key is specified as high priority, even though all it does is display a note, making this a packaging issue.

On further googling, this looks to be related to http://<email address hidden>/msg1042641.html so may already be fixed upstream.

Changed in 389-ds-base (Debian):
status: Unknown → New
Jeremy Bicha (jbicha) wrote :

This bug was fixed in the package 389-ds-base - 1.2.11.7-3

---------------
389-ds-base (1.2.11.7-3) unstable; urgency=low

  * 389-ds-base.config: Removed, the debconf template is no more.
    (Closes: #680351)
  * control: Remove duplicate 'the' from the 389-ds description.

 -- Timo Aaltonen <email address hidden> Wed, 11 Jul 2012 11:59:36 +0300

Changed in 389-ds-base (Ubuntu):
status: New → Fix Released
Changed in 389-ds-base (Debian):
status: New → Fix Released
Chet Burgess (cfb-n) wrote :

The fix for this does not appear to be available in Precise running the latest packages.

It looks like Precise is still using 1.2.10.4-0ubuntu3 which I have confirmed still has the question in 389-ds-base.config.

Please back-port this to Precise for all of us that need to use LTS for production systems.

Timo Aaltonen (tjaalton) wrote :

right, I'll update the package with other backported fixes as well

Changed in 389-ds-base (Ubuntu Precise):
assignee: nobody → Timo Aaltonen (tjaalton)
importance: Undecided → High
status: New → Triaged
Timo Aaltonen (tjaalton) on 2013-02-08
description: updated
Changed in 389-ds-base (Ubuntu Precise):
status: Triaged → In Progress

Hello Jon, or anyone else affected,

Accepted 389-ds-base into precise-proposed. The package will build now and be available at http://launchpad.net/ubuntu/+source/389-ds-base/1.2.10.4-0ubuntu3.1 in a few hours, and then in the -proposed repository.

Please help us by testing this new package. See https://wiki.ubuntu.com/Testing/EnableProposed for documentation how to enable and use -proposed. Your feedback will aid us getting this update out to other Ubuntu users.

If this package fixes the bug for you, please add a comment to this bug, mentioning the version of the package you tested, and change the tag from verification-needed to verification-done. If it does not fix the bug for you, please add a comment stating that, and change the tag to verification-failed. In either case, details of your testing will help us make a better decision.

Further information regarding the verification process can be found at https://wiki.ubuntu.com/QATeam/PerformingSRUVerification . Thank you in advance!

Changed in 389-ds-base (Ubuntu Precise):
status: In Progress → Fix Committed
tags: added: verification-needed
Timo Aaltonen (tjaalton) on 2013-03-12
tags: added: verification-done
removed: verification-needed

The verification of this Stable Release Update has completed successfully and the package has now been released to -updates. Subsequently, the Ubuntu Stable Release Updates Team is being unsubscribed and will not receive messages about this bug report. In the event that you encounter a regression using the package from -updates please report a new bug using ubuntu-bug and tag the bug report regression-update so we can easily find any regresssions.

Launchpad Janitor (janitor) wrote :

This bug was fixed in the package 389-ds-base - 1.2.10.4-0ubuntu3.1

---------------
389-ds-base (1.2.10.4-0ubuntu3.1) precise; urgency=low

  * 389-ds-base.config: Removed, there is no debconf template.
    (LP: #1022718)
  * dirsrv.init: Fix stop() to remove the pidfile only when the process
    is finished. (LP: #1097523)
 -- Timo Aaltonen <email address hidden> Sat, 09 Feb 2013 00:02:58 +0200

Changed in 389-ds-base (Ubuntu Precise):
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.