FFe: Sync 0ad 0.0.24b-1 (universe) from Debian experimental (main)

Bug #1918179 reported by Oibaf on 2021-03-08
12
This bug affects 2 people
Affects Status Importance Assigned to Milestone
0ad (Ubuntu)
Wishlist
Logan Rosen
0ad-data (Ubuntu)
Wishlist
Logan Rosen

Bug Description

Please sync 0ad 0.0.24b-1 (universe) from Debian experimental (main)

Explanation of FeatureFreeze exception:

New release with new features fixing several bugs, also needed to play online with other users who have updated.

Notable it fixes building on arm64 and properly works on armhf: https://bugs.debian.org/cgi-bin/bugreport.cgi?bug=975379

Game release notes:
https://play0ad.com/new-release-0-a-d-alpha-24-xsayarsa/

Backported and succesfully tested in my PPA:
https://launchpad.net/~oibaf/+archive/ubuntu/graphics-drivers/+packages

== Note: make sure to also sync 0ad-data package. ==

Changelog entries since current hirsute version 0.0.23.1-5:

0ad (0.0.24b-1) experimental; urgency=medium

  [ Phil Morrell ]
  * New upstream release.
  * Drop upstreamed patches.
  * Update build-deps. (Closes: #936101, #975379)

  [ Ludovic Rousseau ]
  * version 0.0.24b
  * d/copyright: remove unused entry
    lintian: unused-file-paragraph-in-dep5-copyright paragraph at line 72
  * d/copyright: remove unused entry
    lintian: unused-file-paragraph-in-dep5-copyright paragraph at line 22
  * use embedded nvtt since version 2.1.0 is not yet in unstable
  * Fix "New upstream release 0.0.24" (Closes: #983408)

 -- Ludovic Rousseau <email address hidden> Sun, 07 Mar 2021 10:53:17 +0100

Oibaf (oibaf) on 2021-03-08
description: updated
description: updated
Revision history for this message
Stefano Rivera (stefanor) wrote :

Sure, they are leaf packages. FFe Approved.

Changed in 0ad (Ubuntu):
status: New → Confirmed
Changed in 0ad-data (Ubuntu):
status: New → Confirmed
Mathew Hodson (mhodson) on 2021-03-08
Changed in 0ad (Ubuntu):
importance: Undecided → Wishlist
Changed in 0ad-data (Ubuntu):
importance: Undecided → Wishlist
Logan Rosen (logan) on 2021-03-11
Changed in 0ad-data (Ubuntu):
assignee: nobody → Logan Rosen (logan)
status: Confirmed → In Progress
Revision history for this message
Logan Rosen (logan) wrote :

This bug was fixed in the package 0ad-data - 0.0.24b-1
Sponsored for Oibaf (oibaf)

---------------
0ad-data (0.0.24b-1) experimental; urgency=medium

  * New upstream release.
  * d/copyright: replace tabs by spaces
    lintian: tab-in-license-text debian/copyright (starting at line 606)
  * d/copyright: remove unused licences for hwdetect.js & qbot
    lintian: unused-file-paragraph-in-dep5-copyright paragraph at line 35
  * d/control: add a missing Rules-Requires-Root: no
    lintian: silent-on-rules-requiring-root
  * d/rules: remove trailing-whitespace
    lintian: trailing-whitespace debian/rules (line 4)
  * d/control: use debhelper version 13
    lintian: package-uses-deprecated-debhelper-compat-version 9

 -- Ludovic Rousseau <email address hidden> Sun, 07 Mar 2021 10:27:19 +0100

Changed in 0ad-data (Ubuntu):
status: In Progress → Fix Released
Logan Rosen (logan) on 2021-03-11
Changed in 0ad (Ubuntu):
assignee: nobody → Logan Rosen (logan)
status: Confirmed → In Progress
Revision history for this message
Logan Rosen (logan) wrote :

I'm seeing the following error when I try to build 0ad 0.0.24b-1 locally in a hirsute pbuilder:

error: failed to parse manifest at `/build/0ad-0.0.24b/libraries/source/spidermonkey/mozjs-78.6.0/Cargo.toml`

Caused by:
  dependency (nix) specification is ambiguous. Only one of `branch`, `tag` or `rev` is allowed.
make[5]: *** [/build/0ad-0.0.24b/libraries/source/spidermonkey/mozjs-78.6.0/config/makefiles/rust.mk:299: force-cargo-library-build] Error 101

This causes the build to fail. It looks like we'll need to pull in this patch: https://github.com/0ad/0ad/commit/087a277e66c0456c2d6fdb7403d032ad09cbd18b

Revision history for this message
Logan Rosen (logan) wrote :

Hmm, after applying that patch a different error appears:

/usr/bin/ld: /build/0ad-0.0.24b/libraries/source/spidermonkey/mozjs-78.6.0/build-debug/js/src/build/../RegExp.o: in function `MOZ_ReportAssertionFailure':
/usr/include/x86_64-linux-gnu/bits/stdio2.h:105: undefined reference to `stderr'
/usr/bin/ld: /build/0ad-0.0.24b/libraries/source/spidermonkey/mozjs-78.6.0/build-debug/js/src/build/../RegExp.o: relocation R_X86_64_PC32 against undefined hidden symbol `stderr' can not be used when making a shared object
/usr/bin/ld: final link failed: bad value
collect2: error: ld returned 1 exit status
make[5]: *** [/build/0ad-0.0.24b/libraries/source/spidermonkey/mozjs-78.6.0/config/rules.mk:606: libmozjs78-ps-debug.so] Error 1

Not quite sure what's happening here, but we can't sync 0ad in this state (although I unfortunately already synced 0ad-data).

Changed in 0ad (Ubuntu):
status: In Progress → Incomplete
Revision history for this message
Oibaf (oibaf) wrote :

Strange, it built fine in my PPA...

Revision history for this message
Gianfranco Costamagna (costamagnagianfranco) wrote :

cargo version changed in the meanwhile...

Revision history for this message
Sebastien Bacher (seb128) wrote :

Unsubscribing sponsors until the issue is sorted out, please suscribe them again then

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers