scanner doesn't work with ubuntu 7.04

Bug #94226 reported by Patrick Joly on 2007-03-20
14
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Pascal De Vuyst

Bug Description

Binary package hint: libsane

I've upgrade from ubuntu 6.10 to 7.04.
Before that, my scanner, an Epson 1670, was working perfectly through snapscan.
Now, the scanner blocks on every 2nd page I scan.
The lamp is turning off quickly after the first scan. In 6.10 the lamp was lighting every time.
When I start the 2nd scan, I can hear a strange sound and I obtain an I/O error dialog box.
I tried to scan with a chroot to a 32bits Edgy Eft (I've a 64bits system) and get the same problem.

Thanks for help

ProblemType: Bug
Architecture: amd64
Date: Tue Mar 20 21:23:10 2007
DistroRelease: Ubuntu 7.04
Uname: Linux asterix 2.6.20-11-generic #2 SMP Thu Mar 15 03:43:56 UTC 2007 x86_64 GNU/Linux

vonHalenbach (lustik) wrote :

Thank you for your bugreport!
Is the scanner an usb, scsi or parallel scanner?
Can you make a output file of dmesg, lsmod and lsusb?

regards
Stefan

Changed in sane-backends:
status: Unconfirmed → Needs Info
Patrick Joly (joly) wrote :

It's an usb scanner.
I've attached the result of lsmod, lsusb and dmesg.

Thanks
Patrick

melinux (melinux) wrote :

I've got the same bug on the same scanner, it seems to be a kernel bug 2.6.20 :(
http://bugzilla.kernel.org/show_bug.cgi?id=8231

Hans Elfberg (hans-elfberg) wrote :

I've got similar problem, but on a different scanner. I've had my Epson Perfection 1270 USB scanner working since Breezy. Nor was Edgy any problem, but in Feisty it didn't work properly anymore. If I use xane through gimp I will be able to make a preview, but when I press the scan button I will hear the abnormal sound, I think Patrick is talking about, from the scanner and receive a dialog with the following message: "Failed to start scanner: Error during device I/O".

Using scanimage has the following problem:
hans@tm290-feisty:~$ scanimage -L
device `snapscan:libusb:002:006' is a EPSON EPSON Scanner flatbed scanner
hans@tm290-feisty:~$ scanimage -d snapscan:libusb:002:006 -x 50 -y 50 --format=tiff > test.tiff
[snapscan] Scanner warming up - waiting 9 seconds.
[snapscan] Scanner warming up - waiting 35 seconds.
scanimage: sane_start: Error during device I/O

However, scanimage does not make the scanner produce any abnormal noise.

This problem may well be the bug in the kernel as melinux suggests, I think, but I'm not sure.

I've also found some suggestions that unloading ppdev or ehci_hcd might be a work around, but that doesn't work around my problem.

Hans Elfberg (hans-elfberg) wrote :

I just tried to copy the kernel and its modules from my Edgy Eft installation, and with that kernel I can use xane (but not scanimage) to scan. This confirms that the bug is in the kernel, I suppose.

Ted Treadwell (ttread) wrote :

I am seeing the same problem on the Epson 1670. This scanner worked beautifully for a long time on an Edgy AMD64 system, now it fails on Feisty 32-bit.

Corey K (nitts99-1) wrote :

I have the same issue on Feisty--preview acquisition works perfectly, then I try to scan, get weird, shortlived noise, and pop-up failure.

If there are any logs or anything I can send, please let me know.

Thanks,
Nitts

ianc (ian-criddle) wrote :

I have the same problem (Perfection 2580).

The kernel bug referenced above is marked as resolved - if this is the cause of the problem will the fix make it into Feisty soon?

Thanks

Ian

Launchpad Janitor (janitor) wrote :

[Expired for sane-backends (Ubuntu) because there has been no activity for 60 days.]

Ted Treadwell (ttread) wrote :

Restoring status to confirmed because this problem definitely still exists in current Feisty.

Changed in sane-backends:
status: Invalid → Confirmed
MaxHeadroom (s-wag) wrote :

well same Problem
Fehler: Error during device I/O
but with a Brother MFC-215C
root@PC:~# scanimage -L
device `brother2:bus2;dev1' is a Brother MFC-215C USB scanner

used informations on Brother Web-Side also SANE, could not work with scanner on ubuntu 7

Patrick, does this still happen in Ubuntu 7.10?

Changed in sane-backends:
assignee: nobody → pascal-devuyst
status: Confirmed → Incomplete
melinux (melinux) wrote :

I'm very pleased to work again with my scanner in gutsy (ubuntu 7.10). The problem has been solved in the new version.

MaxHeadroom (s-wag) wrote :

After upgrading from 7.04 to 7.10 I made the following changes for the Brother MFC-215C (Scanner):

Generaly I installed the:
    * LPR Printer Driver
    * Sane Scanner Driver

see and start with http://solutions.brother.com/linux/sol/printer/linux/lpr_drivers.html

for this device (Brother MFC-215C) you must get the brscan2 device driver for a MFC-210C from the brother home page:
http://solutions.brother.com/linux/sol/printer/linux/sane_drivers.html
install ist with the Debian routine

the intallation description of sane scanner driver:
http://solutions.brother.com/linux/sol/printer/linux/sane_install.html
can I add with:

A) Modify the /etc/fstab file
 "none" could also be "usbfs" in the fstab, also if missing, add the following Line (# means comment-line)

===============
# scanner
usbfs /proc/bus/usb usbfs auto,devmode=0666 0 0
===============

B) detect your scanner in a terminal-window and sudo with the command "sane-find-scanner", this will follow:

   # sane-find-scanner will now attempt to detect your scanner. If the
   # result is different from what you expected, first make sure your
   # scanner is powered up and properly connected to your computer.

   # No SCSI scanners found. If you expected something different, make sure that
   # you have loaded a kernel SCSI driver for your SCSI adapter.

 <b> found USB scanner (vendor=0x04f9, product=0x0193) at libusb:001:002</b>
   # Your USB scanner was (probably) detected. It may or may not be supported by
   # SANE. Try scanimage -L and read the backend's manpage.

   # Not checking for parallel port scanners.

   # Most Scanners connected to the parallel port or other proprietary ports
   # can't be detected by this program.

C) modifiy 45-libsane.ruls (MODE=664 instade of 666 will work)

   <For Ubuntu6.06 or later Users>
   1.Open the file "/etc/udev/rules.d/45-libsane.rules" with an editor as root (start gedit and open the file).
   2.Add the following description to the file as below (if you have a Brother MFC-215C, else
      replace idVendor and idProduct by the value of scane-find-scanner - tip: search the other two brother
      descriptions and put the lines after them):

   =================
   # Brother MFC 215c
   SYSFS{idVendor}=="04f9", SYSFS{idProduct}=="0193", MODE="664", GROUP="scanner"
   =================

D) Restart the OS.

Inspiration from:
http://solutions.brother.com/linux/sol/printer/linux/linux_faq.html#20
thanks a lot!

Marking 'Fix Released' then, feel free to reopen if you still have the problem in Gutsy.

Changed in sane-backends:
status: Incomplete → Fix Released

@MaxHeadroom
The problem with Brother MFC-215C has been reported as seperate bug #155254.
Please look at the other bug report to see if there is any missing information that you can provide. Any further discussion regarding that bug should occur in the other report. Feel free to continue to report any other bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers