FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall

Bug #879377 reported by Baditaflorin on 2011-10-21
84
This bug affects 17 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When trying to add a new network printer via Control Center Printers dialog, the following error is dispalyed:
"FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall"

This occurs when in GNOME session. It does not occur when in Unity session. This appears to be a bug due to a patch made for Fedora, but now affecting also other distros. See #7.

Reported in ubuntu 11.10 and 12.04

Timothy Mayoh (timothy-m) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately, we cannot work on this bug because your description didn't include enough information. You may find it helpful to read "How to report bugs effectively" http://www.chiark.greenend.org.uk/~sgtatham/bugs.html. We'd be grateful if you would then provide a more complete description of the problem.

We have instructions on debugging some types of problems at http://wiki.ubuntu.com/DebuggingProcedures

At a minimum, we need:
1. the specific steps or actions you took that caused you to encounter the problem,
2. the behavior you expected, and
3. the behavior you actually encountered (in as much detail as possible).

Thanks!
Timothy

Changed in ubuntu:
status: New → Incomplete
Baditaflorin (baditaflorin) wrote :

Activities > Printers . I Unlock and i go to add new printer and it shows FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall.

Changed in ubuntu:
status: Incomplete → New
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
j de lima (jdelima307-ziggo) wrote :

FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall.

Changed in ubuntu:
status: Confirmed → Invalid
VA3NAZ (va3naz) wrote :

I am encountering the same problem. While using Ubuntu 12.04, I was able to install the network printer using Samba and it worked all the time. Last month I upgraded to Ubuntu 12.1. The upgrade went without any hitch. Last week I wanted to print a document and it would not print. It was being held in queue. So I opened Sytem settings and clicked on Printer. It showed there was no printer installed. I am using HP Officejet 4500-g510 g-m printer attached to a Windows XP computer. So I tried to add the network printer and it gave me "FirewallD is not running. Network printer detection needs services mdns, Ipp, Ipp-client and Samba-client enabled on firewall".

Safir

Ozgur Kucuktekin (ozgurktekin) wrote :

FirewallD is not running. Network printer detection needs services mdns, ipp, ipp-client and samba-client enabled on firewall.

Ubuntu Gnome-Remix 13.04

Omk (ossi-viljakainen) wrote :

I have this bug as well.

I am running 12.04 and installed gnome-session-fallback package. I encountered this bug when I was logged in to GNOME session and trying to install a new JetDirect network printer via Control Center. After some study, I found which discussed the issue, and offered a workaround to install it via CUPS admin (http://localhost:631/). That worked fine. But still, the same error comes whenever I tried to install the printer in Control Center. The cause is a Fedora Gnome patch http://ubuntuforums.org/showthread.php?t=1828557&page=3

" I found a post on Linux Questions that points to a Fedora page and also found a related patch for Gnome or Gnome Control Center, I'm too tired to read through the whole thing but it looks relevant.

    Edit: Went back and read the beginning of the patch, and yeah,it's a Gnome patch and that's where this issue started. The way it looks to me is that FirewallD is Fedora specific, and if that's the case, I'm not sure why they thought adding a Fedora-specific requirement to a Desktop Environment used by numerous other distros would be a good idea, but obviously it is something that needs to be addressed. Sure FirewallD could be ported to Ubuntu and other distros, but that doesn't really address the issue of requiring a specific piece of software to be installed and running in order to perform a certain and non-related function.

    Edit2: I wanted to add that you can still add the printer through the control panel in Unity, but the Gnome version will require FirewallD to add it. "

After reading this, I logged into Unity desktop and there this error does not appear in Printers dialog in Control Center, and the printer gets installed without problems.

Omk (ossi-viljakainen) on 2013-06-21
description: updated
description: updated
description: updated
Omk (ossi-viljakainen) wrote :

Converting this back to bug:

This IS a bug that occurs when trying to add network printer in to GNOME session. It does not occur when in Unity session. This appears to be a bug caused by a patch made for Fedora, but the same code inherited to other distros as well. See #7.

Reported in ubuntu 11.10 and 12.04

Art Edwards (edwardsah3-3) wrote :

I just started having the same problem. I am running 12.04 on two machines, and they both have the same problem. Interestingly, this only happened within the last few days. The printer had been discovered, and working. It then acted as if it were disconnected. This appears to be a fairly simple fix, and the problem is, what, two years old? Why hasn't this problem been assigned?

Cerin (chrisspen) on 2014-09-23
Changed in ubuntu:
status: Invalid → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers