amdcccle crashes in 11.10 beta when trying to enable dual monitors

Bug #858025 reported by Britt Yazel
This bug affects 9 people
Affects Status Importance Assigned to Milestone

Bug Description

I am trying to enable dual monitors in ubuntu 11.10 beta 2 x64, but I cannot do so with the fglrx drivers enabled. From the system settings>display settings it gives me the error "required virtual size does not fit available size: requested=(3840,1080), minimum=(320, 200), maximum=(1920,1920)" when I try to take it off of "mirror" mode. It did not give me this error before using the system settings to enable dual monitors with the open sourced drivers, but it was so glitchy I thought I might try the fglrx drivers.

Also, when I try to enable dual monitors in the ammcccle panel it allows me to get my settings set up perfectly, and it displays the proper screen identifiers, but whenever I press 'apply' the amdcccle shuts down, and when I push 'ok' it does the same. Both ways it doesn't save my settings and I am stuck on mirror mode.

I am running a Sapphire Radeon HD 6950 with dual acer 23" 1920x1080 resolution monitors.

Please help me!

Revision history for this message
Britt Yazel (brittyboi) wrote :

was able to solve the issue by adding a subsection to my xorg.conf file. In the screen section I added "Virtual 3840 1080 ", which is the combined total of both of my desktops.

This is my xorg.conf file:

Section "ServerLayout"
 Identifier "aticonfig Layout"
 Screen 0 "aticonfig-Screen[0]-0" 0 0

Section "Module"
 Load "glx"

Section "Monitor"
 Identifier "aticonfig-Monitor[0]-0"
 Option "VendorName" "ATI Proprietary Driver"
 Option "ModelName" "Generic Autodetecting Monitor"
 Option "DPMS" "true"

Section "Device"
 Identifier "aticonfig-Device[0]-0"
 Driver "fglrx"
 Option "UseFastTLS" "1"
 BusID "PCI:1:0:0"

Section "Screen"
 Identifier "aticonfig-Screen[0]-0"
 Device "aticonfig-Device[0]-0"
 Monitor "aticonfig-Monitor[0]-0"
 DefaultDepth 24
 SubSection "Display"
  Viewport 0 0
  Depth 24
  Virtual 3840 1080

I hope this helps, and there should definitely be a way for ubuntu to either figure out the virtual size for itself, rather than me having to add it in, when it is such a simple calculation

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
svaens (svaens) wrote :

I hadn't run the updates until this morning, and it was working fine until then.
Unfortunately I ran both general updates (which included an update to xorg) and the fglrx drivers)
at the same time.
Well, more precisely, I tried to install the fglrx drivers (the post-release version) and that failed.
So, I just rebooted. I had the problem then already.
Then I installed (successfully) the older fglrx on offer, that worked, but didn't fix my problem.

Revision history for this message
svaens (svaens) wrote :

Ok, it does kinda seem like it was the amd graphics driver that did it,
even though ubuntu said it wasn't activated. It must have messed with the configurations, which was enough to cause the problem.

And then installing it successfully didn't fix things, as it was the configurations which are the problem maybe?

In any case, having successfully installed the proprietary driver, I was then able to successfully uninstall it (one can't uninstall what isn't installed right?)

That fixed my dual screen problem.

However, in uninstalling that, it seems to have turned off compiz, which I assume is the cause of my fancy new panel not appearing.
I had to create a shell file just to open bash, so that I could open a browser, so I could make this complaint!

Revision history for this message
svaens (svaens) wrote :

turns out, installing (or more likely un-installing) fglrx caused further problems, by
breaking dependencies and removing libgl.

I ended up in fixing it (reverting to normal state) by following the instructions posted here:

Revision history for this message
ortermagic (rogerwilby) wrote :

@Britt Yazel ...thanks very much for posting your xorg.conf file rewrite. I have been searching for a solution for two days, I have the same ati radeon sapphire graphics card as you, all I had to do was C&P your work into my own xorg.conf file.
It works !
good job mate.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers