ARM version not supporting V6 RaspPi

Reported by rec9140 on 2011-09-12
266
This bug affects 54 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

The ARM arch version needs to support V6 of the ARM arch to fully support the Raspberry Pi intiative so that the most user friendly Linux can be distributed with the device on SD cards from the start.

Please get in touch with Raspberry Pi at raspberrypi.org and get the issues for V6 support resolved. Supporting just eh Beagleboard at $150 v. the Raspberry Pi @ $35 is not in line with the Ubuntu goals.

Spcifically the ARM1176JZ-F on the Broadcom SoC BCM2835

Oliver Grawert (ogra) wrote :

all of the ubuntu archive is built for cortex-a8 and beyond with all optimization features the v7 architecture offers (minus NEON which we forbid to be build-time enabled by default due to teh fact that we support non NEON armv7 devices) this includes features like thumb2 i.e. vfpv3-d16, softfp and armv7-a ... with the next release we will also start move to hardfloat by default

while dropping v5/v6 support was a move that hurts, it was a requirement to get the best optimization out of the v7 arch.
if we would in parallel want to support v6 and older alongside with v7 that would mean to have a full binary archive in parallel (17000 source packages) for this arch. additionally to not slow down general operations that would need dedicated build machines and a team of say 3-5 persons full time that take over maintenance for the packages, builds and archive (more people if you actually want to develop images for a target board).

the situation you ask to resolve is pretty much like demanding i386 support for all intel packages in favor of dropping things like MMX or co-processor support or other very basic optimization that only entered this arch in 486 or pentium times. if we would do that on intel ubuntu would crawl there ...

canonical invests a lot into having the arm images and the port available, but ubuntu is not an embedded distro, its focus is on building desktop and server images and the current defaults for the arm port are focused on HW that can run these setups (dual core 1GHz, at least 1G ram etc).

if raspberry (or anyone else) would reliably commit to invest into the above resources (buildds, a few fulltime people etc) to cover the costs for such a port (and for its ongoing maintenance) i dont think this would be refused though. canonical whatsoever will very likely go on to cover only v7 and beyond.

note that, while i'm a canonical employee in the ubuntu arm team, the above is my personal opinion and view of the situation, i'm not speaking for the company here and would personally appreciate a v6 port but the resources have to come from somewhere for this.

i know that linaro has a plan (but thats still in its infancy) to provide an easy way to maintain your own archive rebuild locally for such cases where people want un-optimized binaries for older arm versions, it might make sense to contact them about the status of this project.

i will close this bug as invalid as we are unlikely to resolve it without external resources (people, hardware, money etc), in case there are solutions for these points, feel free to re-open it.

Changed in ubuntu:
status: New → Invalid
rec9140 (rec9140) wrote :

I am going to VEHEMENTLY AND VIOLENTLY DISAGREE with this position.

There was a CONSCIOUS DECSION to BREAK good ARM (v6) support in favor of the Beagleboards etc..

Bad decision, period.

This should be about getting the ARM version on the MOST devices out there, and that means V6 support.

It was there up til Karmic, then it was pulled. This is a bug, the compilations need to be made for V6 and above, not the latest and greatest and slickest and for ONE DEVICE, Beagleboards.

Raspberry Pi is presenting a HUGE OPPORTUNITY for Canonical/Ubuntu to get into areas where it can make the most traction, and its GOING TO PASS YOU BYE! Compiling this for V6+ has benefits all the way around, and with the Raspberry Pi device, again, a HUGE OPPORTUNITY is at hand, and going to pass Canonical/Ubuntu bye.

Having a device like the Raspberry Pi seems to fit with everything that Canonical/Ubuntu is (or maybe that should be was) trying to achieve... getting Linux into the hands of students, developing areas, etc.. $35 board v. $150 board, thats a huge difference.

The Raspberry Pi could be the "gateway device" for many to move on to using larger full blown versions like Kubuntu on more advanced hardware.

 HUGE OPPORTUNITY is about to pass Canonical/Ubuntu bye!

Andrea Grandi (andreagrandi) wrote :

@rec9140: there's no need to use violence :)

I agree with both points of view.

I also would like to be able to use Ubuntu on the RaspberryPi board and I'm quite sad I won't able to do it. I'll use Debian instead of Ubuntu and this is ok too, with the difference that Debian has not Unity/Unity-2D in their repositories and it will be hard to do my tests.

I can understand the Canonical point of view too: they're committed to create and maintain a good Desktop and Server product, Ubuntu is not intended as embedded distribution, so if they had to take a decision and sacrifice something they have simply choosen the most obvious one.

All we can do is trying to contact Linaro directly and ask them if they have any intention to port Ubuntu also on ARM v6 CPU.

SpeedyGonsales (stem) wrote :

I'm Ubuntu user and I understand that it is desktop distribution. As I used both "old school" Debian and Ubuntu, I know that having "only" Debian on RaspberryPi is actually not so big difference, apt-get is here for both and Debian repo is not so bad (Ubuntu Unity sucks and I'll not miss it). I could miss some Ubuntu ppa, but almost any more experienced user or user with need for more than editing files sooner or later got to use "configure, make, make install" and git/hg/svn.

But rec9140 has a point, what can you say against: "Having a device like the Raspberry Pi seems to fit with everything that Canonical/Ubuntu is trying to achieve"?

That could be reason enough to make armel packages v6 compatible, and to invest stuff needed for that. I'm not the person who will answer to that question, user ogra who closed this bug is not that person also, as that is strategic decision.

Tod Thomson (todthomson) wrote :

With Ubuntu TV [http://www.ubuntu.com/tv] and they fact that XBMC has been shown to work on the Raspberry Pi, it would seem smart to have an ARM v6 port of Ubuntu with a correspondingly cheap board that could be integrated into TVs running Ubuntu TV...

Just my 2c :)

Changed in ubuntu:
status: Invalid → Confirmed
status: Confirmed → Invalid
Changed in ubuntu:
status: Invalid → Confirmed
Matteo Rapone (nedanfor) wrote :

Please don't change the status without a good reason.

Changed in ubuntu:
status: Confirmed → Invalid
rec9140 (rec9140) wrote :

By conservative estimates, 100,000+ people tried to order 10,000 Raspberry Pi's!

So this is still the boat that canoncial/ubuntu wants to miss? ? ? Really? ? ?

That 100K is probably on the low side based on most on the true numbers. Thats 100K+ potential converts to the path of Linux... which right now are headed to Debian.

Karmic had the ability to work on this, revert back to the Karmic build process. TI/OMAP Beagleboards are not the only ARM game in town!

Lets be less specific in the hardware and support the devices that make sense, and Raspberry Pi, has proven that it MAKES SENSE by a factor of 10x.

Back and forth on valid, invalid, valid, invalid. This is a valid bug, and it needs action, now.

Due to the process of the way the Pi boards are being delivered you probably have 2 months to resolve this and have an image ready for an SD card. This image needs to get to Farnell, and RS so they can put it into the bundles.

What could be better for Raspberry PI and canoncial/ubuntu than users purchasing a bundle, putting an SD card in and getting a KUbuntu, or XFCE, or LXDE desktop. What could be easier for new users to use synaptic and get the tools & software they need be it programming or just general desktop...

This is the chance to meet that 200 million users goal.

Have they sold 100K in total of the Beagleboards? Let alone in ONE DAY ( or at least tried to!?!)? No.

Loïc Minier (lool) wrote :

Does someone know whether there are plans for an ARMv7 Raspberry Pi?

Shahar Or (mightyiam) wrote :

Dear friends,

Oliver said in comment #1
"if raspberry (or anyone else) would reliably commit to invest into the above resources (buildds, a few fulltime people etc) to cover the costs for such a port (and for its ongoing maintenance) i dont think this would be refused though. canonical whatsoever will very likely go on to cover only v7 and beyond."

As always, Canonical's approach is "patches are welcome".

I would prefer Ubuntu rather than Debian on a Raspberry Pi but it wouldn't matter that much, really, because I would not use a Pi for a Desktop.

Thanks and Blessings,
Shahar

rec9140 (rec9140) wrote :

""if raspberry (or anyone else) would reliably commit to invest into the above resources (buildds, a few fulltime people etc) to cover the costs for such a port (and for its ongoing maintenance) i dont think this would be refused though. canonical whatsoever will very likely go on to cover only v7 and beyond"

This position is not the position to take. Builds should be about supporting the widest used products on the market. There has to be a better way to build the ARM version that can support RPi, OMAP, and the other ARM boards like these on the market. This NO NO NO NO, ARM V7 only attitude is not productive.

There have not been 100K Beagleboards, Pandaboards or any other OMAP boards sold in total since their development. The 100K+ in a DAY for the RPi. Thats by conservative estimates. Its probably closer to 200-250K.

Its not a matter of whether YOU would use it for a desktop... There are PLENTY who would IF it was available and this could benefit Canoncial AND Linux AND Raspberry PI. I wouldn't use it for a desktop for me, but it does fit in to a project very nicely. Its about ease of use and showing how polished not only the RPi is, but Linux and specifically the *buntu(s).

How much easier is it to get software on *bunutu(s) versus Debian? For some its as simple as opening synaptic and picking, or maybe adding a PPA and then adding the software. On Debian your going to run users straight in to the compile wall. Not what you want to do for most users.

 Its really truly sad to see that this is going to slip through canoncials hand.

Why the build change after Karmic? ? ? ? ? ? ? ? ? If the build process had remained the same this would not be an issue, download the image and go...So what was the reason for changing after the Karmic release to this V7+ uber alles policy? ?

As for a V7 RPi, doubtful. They have secured special availability of the SoC they chose, and would have to redesign the board for any change in the SoC and at this point thats not likely to happen. Unless there is a pin for pin replacement for the current SoC with V7 support. Possible, but unlikely.

Arnd Bergmann (arnd-arndb) wrote :

There are two separate issues to consider here:

1. User space packages: The discussion so far has centered around this one. Anyone can rebuild the Ubuntu packages and recreate an ARMv5/v6 based distro out of them. There appear to be a number of parties that are interested in this, mostly for v5, and the multiarch support should make this much easier to support in the long run. I would highly doubt that Canonical is interested in this, mostly because the specs of any ARMv5/v6 device are simply not enough to run a desktop distro, with less than 512MB of RAM. Linaro is also not likely to help out there because all the members are focused on their ARMv7 based products now. This could change of course if Broadcom or someone else with a lot of ARMv6 devices was joining Linaro.

2. Kernel support: Any device that is getting supported by a general purpose distro needs kernel support. From all I can tell, Broadcom are almost violently opposed to working with the community, so this is not happening any time soon. The bcm2708 platform code does not seem to be all that bad and I guess someone with enough time on their hands can do the work to clean that up by themselves. Reverse-engineering and rewriting the Videocore stuff is a completely different thing though, so any distro would be limited to the things that run on the ARM11 core and none of the video acceleration that make the hardware platform mildly interesting to users.

Oliver Grawert (ogra) wrote :

The reason for not switching to v7 in jaunty already was that it took more than one release to sort out all issues and build failures for a clean v7 build with all planned optimizations that were agreed with ARM to end up in ubuntu.
The ubuntu arm port would have been v7 from day one if that would have been possible, but as it happened, jaunty was just a plain rebuild of debians armel, for karmic the switch to v6 (and a lot of other bits like thumb2) was made, v5 was never a target architecture for ubuntu.
These bits were discussed at the various UDS's, feel free to search blueprints.launchpad.net for the related blueprints.

Dave Vree (hdave) wrote :

Very disappointed to see this....was really looking forward to running Ubuntu on a Pi for my kids to introduce them to Linux and programming. What a bummer.

acornblue (acornblue) wrote :

Yay for Ubuntu
Yay for Lubuntu
Yay for Raspian
And lets not forget that all are based on Debian :)

4core i5 desktop running ubuntu (occasionally booting into SL to play games :)
2 Centrino Duo laptops running lubuntu
2 RPi 256/512 running Raspian

1 stoked user

impedator (krzysztof-strug) wrote :

2nd stoked user

I love Ubuntu!

I'm using it on most of my company servers and at home...

lately I have bougth RastberryPI.... and have found that I can not run my favorite system on new platform...

Still waiting for solution...

CrazyAlex25 (crazyalex25) wrote :

Does someone know whether there are plans for an ARMv7 Raspberry Pi?

Sam Cook (sfcnzl-6) wrote :

If RaspBerry Pi users want Ubuntu They will need to find the resources for porting. Otherwise the alternative is the Beagleboard Black, which does have Ubuntu and only cost a few extra dollars.

CSRedRat (csredrat) wrote :

Loking for new Raspberry Pi on ARMv7 :) Ubuntu good luck ;)

rec9140 (rec9140) wrote :

Had to comment here since the link proffered doesn't accept comments or contact with out registration or donation....

Love that this is finally getting some traction.... A question though....

Is this going to be a ARM HF or HARDWARE FLOATING POINT BUILD? ala http://www.linuxsystems.it/raspbian-wheezy-armhf-raspberry-pi-minimal-image/

There really is no point in doing soft float as it is a huge performance issue, and would not work in my particular use case as the various packages require hardware floating to do the encoding of audio etc..

I would suggest a HARDWARE FLOAT version along with Kubuntu as the default base with KDE as KDE offers a traditional desktop that many of the users will be far more familiar with than throwing them in to something else.

Again, love that this is moving forward!

Alan Bell (alanbell) wrote :

Hard float is the plan. We intend to build every package that builds, so that would include KDE. I have no idea what will end up on the SD card, and what point we get a desktop running, the initial target is booting to a command line, like Ubuntu Server. My ideal result would be an SD card that boots to the OEM setup wizard then the Unity desktop, but if KDE works too then a Kubuntuish card would be brilliant as well, running oem-config-kde

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers