[needs-packaging] Please package oxygen-gtk3

Reported by sumski on 2011-08-13
110
This bug affects 20 people
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Philip Muškovac

Bug Description

As Oneiric will port most of the GUI to GTK3 , i ask if oxygen-gtk3 can be
packaged for more consistent look within KDE session. Thanks!

 affects kubuntu/gtk3-engines-oxygen
 importance wishlist

RedSingularity (redsingularity) wrote :

Assigning to unity as it is the default window manager. The team will move it if they feel necessary.
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

affects: ubuntu → unity (Ubuntu)
tags: added: needs-packaging
Omer Akram (om26er) wrote :

please do understand every bug is not a bug in Unity.

affects: unity (Ubuntu) → ubuntu
Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Please package oxygen-gtk3
+ [needs-packaging] Please package oxygen-gtk3
Changed in ubuntu:
importance: Undecided → Wishlist
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed

Could we get some feedback - won't do it, too unstable , we are working hard on it , etc? Thanks

R Lane (rick-essom) wrote :

I have the same bug installing nightly build (September 27, 2011). Cheese and Synaptic preferences dialog box, and others. It looks like this in my install, too.
http://www.dodaj.rs/?3p/XO/NioDUSf/snapshot1.jpg

As a temporary workaround, I've used the instructions on the page below to get pretty GTK3 applications:

http://kubuntuforums.net/forums/index.php?topic=3118994.0

Mathias Dietrich (theghost) wrote :

Dear Kubuntu Developers

the first stable oxygen-gtk3 package is released. Is it possible to get it into Oneiric ? At least through the Backport's PPA ?
http://hugo-kde.blogspot.com/2012/01/oxygen-gtk3-10-is-out.html

Philip Muškovac (yofel) wrote :

I'll try to get this done for precise.

Changed in ubuntu:
assignee: nobody → Philip Muškovac (yofel)
status: Confirmed → In Progress
Mathias Dietrich (theghost) wrote :

For everyone who wants oxygen-gtk3 in Kubuntu 11.10, it's now in the Backports PPA, thanks to Philip.

To get it to work you need to have the PPA and then:

1. sudo apt-get install gtk3-engines-oxygen
2. Go to /home/USER/.config/
3. Create a folder "gtk-3.0" (without "")
4. Cd created gtk-3.0 folder and create a file: "settings.ini" (without "")
5. Open the file and paste the 2 lines:

[Settings]
gtk-theme-name = oxygen-gtk

6. Open a gtk3 app, it should now look as an oxygen app.

Serhiy Zahoriya (xintx-ua) wrote :

Thanks, TheGhost, it works.

sh code:

sudo apt-get install gtk3-engines-oxygen
mkdir ~/.config/gtk-3.0
echo -e "[Settings]\ngtk-theme-name = oxygen-gtk" > ~/.config/gtk-3.0/settings.ini

Philip Muškovac (yofel) wrote :

It's in the archive since a few days ago.

Changed in ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers