virt-manager disk bus changement doing error when VM is starting

Bug #816464 reported by Ian Labbé on 2011-07-26
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Sorry if i have entered bad informations for the name, title and location, it is my first bug report.

First of all, i have builded my machine with virt-manager. I've chosen (QEMU/KVM) hypervisor connection with the 'Local install media (ISO image or CDROM)' for the installation boot option at the first step of the installer. At next step, 2/5, i've chosen to 'Use CDROM or DVD' as my installation media. At step 3/5, i've took 512 MB of RAM and 1 CPU. At step 4/5, i've chosen to 'Enable storage for this virtual machine', and 'Create a '8.0GB' disk image on the computer's hard drive' followed by the 'Allocate entire disk now' option. At last step, i've chosen to bridge my network card with br0 interface, to fix an MAC address and choose 'KVM' virt type with the 'X86_64' architecture. Once my virtual machine is created with my installed operating system on (VM is down for the next operations, but is able to start), i have a disk labeled SOGO.img that represent my hard drive. I've copied this file to a second one, SOGO2.img in the same directory. Once the copying is finished, i choose SOGO in my VM choice (in virt-manager) and i open the VM, for going into the virtual hardware details. I can see my first HD, SOGO.img with 'default' cache mode, raw 'storage format' and 'Virtio' disk bus. Readonly and Shareable isn't checked.

Now will come the bug.

1. I click on the 'Add Hardware' button.
2. I choose to 'Select managed or other existing storage' and i take my SOGO2.img disk.
3. After that, i choose 'IDE' Device type, 'default' Cache mode with no storage specified (it will put automatically raw storage format).
4. I click on the 'Finish' button.
5. Now i can start my VM, but inside the VM, i remember that i need virtio bus, no i shutdown the VM.
6. I return to my details (IDE Disk 1 (SOGO2)), and i change Disk to virtio and i have an error :
<error>
Error starting domain: operation failed: failed to retrieve chardev info in qemu with 'info chardev'

Error starting domain: operation failed: failed to retrieve chardev info in qemu with 'info chardev'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/asyncjob.py", line 45, in cb_wrapper
    callback(asyncjob, *args, **kwargs)
  File "/usr/share/virt-manager/virtManager/engine.py", line 956, in asyncfunc
    vm.startup()
  File "/usr/share/virt-manager/virtManager/domain.py", line 1048, in startup
    self._backend.create()
  File "/usr/lib/python2.7/dist-packages/libvirt.py", line 330, in create
    if ret == -1: raise libvirtError ('virDomainCreate() failed', dom=self)
libvirtError: operation failed: failed to retrieve chardev info in qemu with 'info chardev'
</error>

I need to remove the drive and create one with virtio disk bus for be able to start the machine. I can't change IDE to virtio in the details once the disk is done.

My virt-manager is doing a connection to a machine on the network and both machine use natty.

Sorry, i didn't have the time to test the bug on a RedHat based machine.

Ian Labbé (ilabbe) wrote :

Oupsss, sorry for the first line, it is in my old message that i didn't send.... XD

Changed in ubuntu:
status: New → Confirmed
clubber (fkramer) wrote :

Maybe this is trivial news, but i experienced the same problem. I played a bit around even trying to create a entirely new VM with virtio device from scratch (not changing the bustype). This didn't work eighter.
So i tried to do it directly using the "virt-install" command. Unfortunately this fails with exactly the same error.

ERROR operation failed: failed to retrieve chardev info in qemu with 'info chardev'

Using virt-manager 0.9 with Ubuntu 11.10 I have the same problem. If I select 'virtio' for the bus and save I get a python error. So I can'y use my vm's with virt manager because they all use virtio, and I can't find any way to set that.
(I can't find any way in the gui to edit the UUID either, but that is an unrelated issue)

Here is the error I get from virt-manager 0.9 gui every time I try to select 'Virtio'. Selecting 'Default' or 'IDE' does not display any error. After this error the virtio setting is reverted.

------------
[Sun, 29 Jan 2012 13:26:08 virt-manager 2536] DEBUG (error:80) dialog message: Error changing VM con
figuration: 'NoneType' object has no attribute 'xpathEval' : Error changing VM configuration: 'NoneT
ype' object has no attribute 'xpathEval'

Traceback (most recent call last):
  File "/usr/share/virt-manager/virtManager/details.py", line 2317, in _change_config_helper
    func(*args)
  File "/usr/share/virt-manager/virtManager/domain.py", line 574, in define_disk_bus
    return self._redefine_device(change, devobj)
  File "/usr/share/virt-manager/virtManager/domain.py", line 307, in _redefine_device
    return cb(dev)
  File "/usr/share/virt-manager/virtManager/domain.py", line 570, in change
    editdev.address.clear()
  File "/usr/lib/pymodules/python2.7/virtinst/VirtualDevice.py", line 173, in clear
    self._remove_child_xpath("./address")
  File "/usr/lib/pymodules/python2.7/virtinst/XMLBuilderDomain.py", line 458, in _remove_child_xpath
    _remove_xpath_node(self._xml_ctx, xpath, dofree=False)
  File "/usr/lib/pymodules/python2.7/virtinst/XMLBuilderDomain.py", line 186, in _remove_xpath_node
    node = _get_xpath_node(ctx, curxpath)
  File "/usr/lib/pymodules/python2.7/virtinst/XMLBuilderDomain.py", line 71, in _get_xpath_node
    node = ctx.xpathEval(xpath)
AttributeError: 'NoneType' object has no attribute 'xpathEval'

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers