Multi part LVM layout: system fails to boot due to missing volumes

Bug #801494 reported by James Page on 2011-06-24
14
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
High
Unassigned
Oneiric
High
Unassigned
Precise
High
Unassigned

Bug Description

ISO Image: oneiric-server-amd64.iso
Date: 20110624

Installation completes successfully; however system then fails to boot due to missing LVM volumes.

This installation was done using cobbler (preseed attached with secret stuff removed).

Missing volumes included tmp and home; var, usr, swap + root all appeared to be OK.

Dropping into the manual recovery option:

 * lvs returns a list of all volumes correctly
 * lvscan showed all volumes - home marked as inactive
 * Entries present in /dev/mapper for volumes that work; but not for tmp and home

James Page (james-page) wrote :
Dave Walker (davewalker) on 2011-06-24
tags: added: server-ors
Dave Walker (davewalker) on 2011-07-07
tags: added: server-o-rs
removed: server-ors

This issue needs to be reproduced to determine if it is a local issue, or a larger problem that hasn't been identified.

Dave Walker (davewalker) wrote :

@JamesPage, have you been able to reproduce this with a more current daily image?

Thanks.

Dave Walker (davewalker) on 2011-07-18
Changed in ubuntu:
milestone: none → oneiric-alpha-3
James Page (james-page) wrote :

Still broken.

I tried to grab some log information - it would appear that more LVM's where detected but I got a whole load of udevd Read-only file system errors which blatted everything useful

Attempting to get a login....

James Page (james-page) wrote :

I can't get a grab of this but it looks odd

 * All filesystems look like they are mounted
 * however they all have a size of 322M
 * And they don't contain any content - i.e. /usr is empty

Changed in ubuntu:
milestone: oneiric-alpha-3 → ubuntu-11.10-beta-1
Clint Byrum (clint-fewbar) wrote :

Working on confirming and triaging...

Changed in ubuntu:
assignee: nobody → Clint Byrum (clint-fewbar)
status: New → In Progress
importance: Undecided → High
Clint Byrum (clint-fewbar) wrote :

Could not reproduce using the exact preseed file and 20110825 iso. There's been a lot of changes since then, its possible this was just a mid-transition problem.

Changed in ubuntu:
status: In Progress → Invalid
James Page (james-page) wrote :

I still get this issue - might be related to bug 818177

Changed in ubuntu:
status: Invalid → New
assignee: Clint Byrum (clint-fewbar) → nobody
milestone: ubuntu-11.10-beta-1 → ubuntu-11.10
Dave Walker (davewalker) wrote :

Marking incomplete, as clarification of it being a duplicate of bug 818177 needs to be determined.

Thanks.

Changed in ubuntu:
status: New → Incomplete
James Page (james-page) wrote :

I've not been able to re-produce this bug on either oneiric or precise.

Marking Invalid.

Evan C (inthemix360) on 2011-12-20
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Bug attachments