Randomly docklets do not load

Bug #779752 reported by Justin
88
This bug affects 18 people
Affects Status Importance Assigned to Milestone
Docky
Low
Unassigned
MATE Desktop
New
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

I have some docklets added, but randomly some do not load. Log give similar msg

[Warn 08:03:21.409] [DockController] "RecentDocuments" seems to have been abandoned... disabling.

But no more warning come with -d. Plus it isn't reproducible on request, but happens every other day.

System:

gnome-extra/docky-2.1.2
Gentoo Linux
x11-base/xorg-server-1.10.1.901
gnome-2.32.*
dev-lang/mono-2.10.2

[Info 08:03:03.073] Docky version: 2.1.2 Release
[Info 08:03:03.088] Kernel version: 2.6.38.4
[Info 08:03:03.089] CLR version: 2.0.50727.1433
[Error 08:03:03.559] [SystemService] Network Manager is not available.
[Info 08:03:03.651] [ThemeService] Setting theme: HUD
[Info 08:03:05.211] [DockServices] Dock services initialized.
[Info 08:03:14.778] [PluginManager] Loaded "Recent Documents".
[Info 08:03:14.779] [PluginManager] Loaded "Workspace Switcher".
[Warn 08:03:21.409] [DockController] "RecentDocuments" seems to have been abandoned... disabling.
[Info 08:03:21.416] [PluginManager] Unloaded "Recent Documents".
[Info 08:03:21.531] [Helper] Starting zeitgeist_journal.py
[Info 08:03:21.554] [Helper] Starting zeitgeist_menus.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/banshee_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/deluge_badge.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/emesene_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/gajim_badge.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/gtg_menus.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/hamster_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/liferea_badge.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/mpd_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/open_terminal_here.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/pidgin_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/pithos_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/rhythmbox_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/skype_control.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/tomboy_menus.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/transmission_badge.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/tsclient_menus.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/workrave_helper.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/zeitgeist_journal.py
[Info 08:03:21.557] [HelperService] Helper added: /usr/share/dockmanager/scripts/zeitgeist_menus.py
[Info 08:03:21.599] [DrawingService] Could not find 'banshee', using fallback of 'extension'.
[Info 08:03:22.021] [DrawingService] Could not find 'deluge', using fallback of 'extension'.
[Info 08:03:22.027] [DrawingService] Could not find 'emesene', using fallback of 'extension'.
[Info 08:03:22.156] [DrawingService] Could not find 'liferea', using fallback of 'extension'.
[Warn 08:03:22.299] [DrawingService] Error loading icon from file '/usr/share/pithos/media/icon.svg': Failed to open file '/usr/share/pi
thos/media/icon.svg': No such file or directory
[Info 08:03:22.301] [DrawingService] Could not find '/usr/share/pithos/media/icon.svg', using fallback of 'extension'.
[Info 08:03:22.307] [DrawingService] Could not find 'tomboy', using fallback of 'extension'.
[Info 08:03:22.310] [DrawingService] Could not find 'transmission', using fallback of 'extension'.
[Info 08:03:22.315] [DrawingService] Could not find 'tsclient', using fallback of 'extension'.
[Warn 08:03:22.318] [DrawingService] Error loading icon from file '/usr/share/pixmaps/workrave/workrave.xpm': Failed to open file '/usr/
share/pixmaps/workrave/workrave.xpm': No such file or directory
[Info 08:03:22.427] [DrawingService] Could not find '/usr/share/pixmaps/workrave/workrave.xpm', using fallback of 'extension'.

Revision history for this message
metchebe (metchebe) wrote :

This also happens to me using 2.1.3 from the stable PPA on a new Ubuntu Natty install. This did not happen with version 2.0.14 from the stable PPA, which I used until a couple of days ago on Ubuntu Lucid.

Robert Dyer (psybers)
Changed in docky:
importance: Undecided → Low
Revision history for this message
Justin (jlec) wrote :

The nasty problem is, that there is a huge timedelay

[Info 08:03:14.778] [PluginManager] Loaded "Recent Documents".
[Info 08:03:14.779] [PluginManager] Loaded "Workspace Switcher".
[Warn 08:03:21.409] [DockController] "RecentDocuments" seems to have been abandoned... disabling.
[Info 08:03:21.416] [PluginManager] Unloaded "Recent Documents".

5minutes in this case, which makes docky unusable in this time.

Revision history for this message
Robert Dyer (psybers) wrote :

Quit Docky. Then run:

rm -Rf ~/.local/share/docky/plugins

Maybe that will help?

Revision history for this message
Justin (jlec) wrote :

No it doesn't. :(

Any chance to get a better debuggin?

Revision history for this message
metchebe (metchebe) wrote :

In my case Docky is usable, but just starts without docklets. I would like to add that I was using the trash and mounter plugins. Furthermore, the gconf key that holds the docklets to load resets to blank, so they have to be added again in the configuration. I do not have to restart Docky to be able to add them again.

Revision history for this message
Wolter Hellmund (wolterh) wrote :

I am experiencing the exact same behavior that metchebe described.

Robert Dyer (psybers)
Changed in docky:
status: New → Confirmed
Revision history for this message
metchebe (metchebe) wrote :

I switched to the development PPA and I have the same problem with version 2.2.0 r1808 on my Ubuntu Natty 64-bit install.

From xsession-errors:

[Info 11:19:38.110] [PluginManager] Loaded "Trash".
[Info 11:19:38.147] [PluginManager] Loaded "Mounter".
[Warn 11:19:38.173] [DockController] "Trash" seems to have been abandoned... disabling.
[Info 11:19:38.202] [PluginManager] Unloaded "Trash".
[Warn 11:19:38.202] [DockController] "Mounter" seems to have been abandoned... disabling.
[Info 11:19:38.537] [PluginManager] Unloaded "Mounter".

Revision history for this message
Jeff (jdorenbush) wrote :

I have the same problem. I'm receiving the same messages in my .xsession-errors log file.

The 2 Docklets that disappear after rebooting for me are "Clippy" and "Trash".

Revision history for this message
metchebe (metchebe) wrote :

Forgive me if this is not the appropriate place to ask this, but is this bug being investigated?

I have been using Do/Docky for years, but unfortunately this bug has become annoying to the point that it has made me stop using Docky altogether.

Best regards.

Revision history for this message
Robert Dyer (psybers) wrote :

Yes, but unfortunately none of the devs can reproduce this. So it is hard to fix!

Revision history for this message
Robert Dyer (psybers) wrote :

Is everyone on a 64bit Natty install? If you are not, please speak up.

Revision history for this message
Jeff (jdorenbush) wrote :

I'm on a 64bit install of 11.04. I haven't been experiencing the problem lately. Being that it is "random" I can imagine it'll be difficult to reproduce. I'll try and monitor when it happens and when it doesn't to try and narrow down what might be causing it.

Revision history for this message
metchebe (metchebe) wrote :

The bug seems to be related with a slow startup of my Gnome session when I have Docky start when I log in. I can pretty much predict that the docklets will not load if the session is sluggish to start.

I am currently testing starting Docky manually after Gnome loads completely, and the docklets have been loading correctly.

Revision history for this message
metchebe (metchebe) wrote :

For a week I have been starting Docky after my Gnome session finishes loading, and it has loaded all docklets every time.

I can confirm that, at least for me, it seems to be related to automatic startup. Maybe others can confirm the same behavior?

Revision history for this message
Justin (jlec) wrote :

Same here. manual startup is always fine, whereas the automatic randomly fails.

Revision history for this message
Song Cai (billy-leocs) wrote :

Confirm. Docklets disappear every time I restart (not randomly). Using Debian testing (wheezy) and Docky 2.2.0 bzr r1816.

Revision history for this message
Wolter Hellmund (wolterh) wrote :

For me it does seem to be random. I guess I will have to rewrite the docky startup script so it always saves output

Revision history for this message
Wolter Hellmund (wolterh) wrote :

Oh well, "seems to have been abandoned" seems to be the most detailed output one can get. Bump

Revision history for this message
Robert Dyer (psybers) wrote :

Not so much abandoned, we (the devs) just cant reproduce it. So we aren't sure how to fix it.

Revision history for this message
Jean-Alexandre Anglès d'Auriac (jagw40k) wrote :

I have the problem, and I just want to mention something that can be of use to other suffering from the bug and maybe even to the dev' trying to fix it : if the dock doesn't load the docklet on startup, the gconf key /apps/docky-2/Docky/Interface/DockPreferences/Dock1/Plugins is still set to the right values until you close it. If you close it using killall docky, it does stay to the right value, and therefore you just need to launch Docky again to get back to your normal configuration. If you do close Docky by the menu, however, the key is reseted to nothing.

Revision history for this message
metchebe (metchebe) wrote :

I update to Ubuntu 12.04 64-bit and this still happens with Docky 2.1.4-1 from the universe repository.

Revision history for this message
Robert Dyer (psybers) wrote :

This definitely seems to be a 64bit bug. But the devs are all on 32bit!

Revision history for this message
Jean-Alexandre Anglès d'Auriac (jagw40k) wrote :

It's not a 64 bit bug, I have it on my 32 bit ArchLinux.

Revision history for this message
lumbricus (lumbricus) wrote :

I think this problem occurs only if docky is loaded automatically after login. I just started it several times and it turned up with all docklets everytime. Maybe gconf is not fully loaded or so, when docky starts?

Revision history for this message
Pete Mendoza (harvestpc) wrote :

Same problem here. 64bit Mint Debian with XFCE. Docklets disappear EVERY time I log out and back in. However, if I add the docklets back, and restart Docky in the same session, the docklets remain. They only disappear after restarting a session so I have to confirm with the others that it happens when Docky is loaded automatically. SURELY one of the devs can reproduce this. It seems that the devs are pretending this problem doesn't exist but so many of us are able to reproduce this across different distros and desktop environments on both 64bit and 32bit systems... Are we imagining it? Mass delusion?

Revision history for this message
Patricio Santiago Marrone (cebollo3-l) wrote :

Same issue here. I administer a computer lab with 11 PCs (mostly Intel i5 and a couple of i7s. They were updated today to Xubuntu 12.04 64 bits with docky, installed from the Ubuntu repositories, and every computer starts with the docklets loading incorrectly (not showing at all) or correctly in what appears to be a random fashion.
I confirm what Pete Mendoza said: The docklets load just fine after doing a 'killall docky; docky;' but the problem persists after rebooting.
I'll try to get the logs if the problem persists.

no longer affects: ubuntu
Revision history for this message
Patricio Santiago Marrone (cebollo3-l) wrote :

Since this smells like race conditions to me (fails randomly, fails when loads too early, etc) I change the atostart command from 'docky' to 'sh -c "sleep 10; docky"' to give it some delay before it starts. All computers in the lab now booted a flawless docky. I think this shows that docky is being initialized before some of the components it needs, perhaps?
Note: In my case, I first tried sleep 5, but some computers still didn't load correctly. I increased it so that it got excecuted after the desktop was initialized.

Revision history for this message
Amit Bhalerao (amit-adb) wrote :

On ubuntu 12.04 (32-bit OS on a 64-bit machine), I have similar experience with Docky.
When I boot up my laptop and log in for the first time, docklets may or may not appear with docky.
When they aren't there, I just "log out and log back in" and the docklets appear.

Hurin (auxcri)
Changed in solusos:
status: New → Fix Released
no longer affects: solusos
Revision history for this message
Hurin (auxcri) wrote :

I am using an nVidia 8800 GTS card, Linuxming KDE 14 and having the same issue with Docky. In a virtual machine it is not reproducible.

Can someone please verify if experiencing this bug with nVidia cards?

Why is this bug set to low priority if it is still going on since so long?

What debugs can help clarify what the root cause is?

I see there are some switches related to nVidia cards:

user@computer ~/.kde/Autostart $ docky --help
[Info 19:36:43.933] Docky version: 2.1.4 Release
[Info 19:36:43.944] Kernel version: 3.5.0.17
[Info 19:36:43.945] CLR version: 4.0.30319.1
usage: docky [options]

  -p, --disable-polling Disable cursor polling (for testing)
  -m, --max-size=VALUE Maximum window dimension (min 500)
  -d, --debug Enable debug logging
  -n, --netbook Netbook mode
      --nv, --nvidia Nvidia mode (for Nvidia cards that lag after a
                               while). Equivalent to '-b 10'.
  -b, --buffer-time=VALUE Maximum time (in minutes) to keep buffers
  -h, -?, --help Show this help list

I have tries modifying the autostart command to <docky --nvidia> and <docky -b 120> to no avail.

Revision history for this message
Hurin (auxcri) wrote :

sh -c "sleep 10 && docky" works like a charm as stated previously. What componente could be causing this issue?

Revision history for this message
Ari Torres (kuvanito) wrote :

this bug still exit today April/08/2015 every now and then when I boot to Ubuntu Mate 15.04 with Docky my Trash Icon is missing,I must add it manually but like I said every now and then when I boot is gone!
Have no idea but mainly happens after an update

Revision history for this message
Ari Torres (kuvanito) wrote :

Here is my Docky debug:
ari@ari:~$ docky -d
[Info 11:59:51.562] Docky version: 2.2.0 Release
[Info 11:59:51.570] Kernel version: 3.19.0.12
[Info 11:59:51.572] CLR version: 4.0.30319.17020
[Debug 11:59:51.810] [UserArgs] BufferTime = 0
[Debug 11:59:51.810] [UserArgs] MaxSize = 2147483647
[Debug 11:59:51.810] [UserArgs] NetbookMode = False
[Debug 11:59:51.810] [UserArgs] NoPollCursor = False
[Error 11:59:51.830] [SystemService] Could not initialize power manager dbus: 'org.freedesktop.DBus.Error.UnknownMethod: Method "Get" with signature "ss" on interface "org.freedesktop.UPower" doesn't exist
'
[Info 11:59:51.832] [SystemService] at Docky.Services.SystemService+IUPowerProxy.Get (System.String interface, System.String propname) [0x00000] in <filename unknown>:0
  at Docky.Services.SystemService.HandleUPowerChanged () [0x00000] in <filename unknown>:0
  at Docky.Services.SystemService.InitializeBattery () [0x00000] in <filename unknown>:0
[Info 11:59:51.852] [ThemeService] Setting theme: Classic
[Debug 11:59:51.858] [DesktopItemService] Loading remap file '/usr/share/docky/remaps.ini'.
[Debug 11:59:51.864] [DesktopItemService] Remapping 'Picasa3.exe' to 'picasa'.
[Debug 11:59:51.864] [DesktopItemService] Remapping 'nbexec' to 'netbeans'.
[Debug 11:59:51.864] [DesktopItemService] Remapping 'deja-dup-preferences' to 'deja-dup'.
[Debug 11:59:51.864] [DesktopItemService] Remapping 'VirtualBox' to 'virtualbox'.
[Warn 11:59:51.865] [DesktopItemService] Could not find remap file '/home/ari/.local/share/docky/remaps.ini'!
[Debug 11:59:51.866] [DesktopItemService] Loading desktop item cache '/home/ari/.cache/docky/docky.desktop.en_US.UTF-8.cache'.
[Info 11:59:51.999] [DockServices] Dock services initialized.
[Error 11:59:52.004] [DBusManager] Bus Name 'org.gnome.Docky' is already owned
[Fatal 11:59:52.004] Another Docky instance was detected - exiting.
ari@ari:~$

Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
Davide Olianas (ubuntupk) wrote :

I can reproduce this bug on Debian 8.5 in a Virtualbox machine; Docky is 2.2.0. The bug presents itself with Cinnamon as the DE but not with XFCE.

Revision history for this message
rugk (48509946-3) wrote :

I can also confirm this bug. Randomly the docklets disappear.

I am currently testing the "sleep 10" workaround.

Revision history for this message
Rahn Stavar (rahnstavar) wrote :

Can confirm this bug on Ubuntu 16.04. Only happens 50% of the time and only when automatically started at boot.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers