I can't drag windows to second monitor

Bug #777500 reported by AwarenesS on 2011-05-04
10
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Fresh install ubuntu 11.04

I can't drag windows to second monitor as I used to in 10.04. Usually, I launched programs in first monitor, then, moved them to second monitor.

Now when I drag the apps to edge, I can only see the "maximize to half screen"

I use last nvidia proprietary driver. This new behavior happens with unity, gnome-classic and kde.

my card is a nvidia 8400GS

Any further detail needed can be provided upon request... :)

=============== XRANDR =============== =============== ===============
$ xrandr
xrandr: Failed to get size of gamma for output default
Screen 0: minimum 320 x 240, current 1280 x 1024, maximum 1280 x 1024
default connected 1280x1024+0+0 0mm x 0mm
   1280x1024 50.0* 51.0
   1280x960 52.0
   1152x864 53.0 54.0 55.0 56.0
   1024x768 57.0 58.0 59.0
   960x600 60.0
   960x540 61.0
   840x525 62.0 63.0 64.0 65.0
   832x624 66.0
   800x600 67.0 68.0 69.0 70.0
   720x450 71.0
   700x525 72.0 73.0
   680x384 74.0 75.0
   640x480 76.0 77.0 78.0 79.0
   512x384 80.0 81.0
   400x300 82.0
   320x240 83.0 84.0

=============== XORG.CONF =============== =============== ===============
$ cat /etc/X11/xorg.conf
# nvidia-settings: X configuration file generated by nvidia-settings
# nvidia-settings: version 270.29 (buildd@roseapple) Fri Feb 25 14:43:24 UTC 2011

Section "ServerLayout"
    Identifier "Layout0"
    Screen 0 "Screen0" 0 0
    Screen 1 "Screen1" RightOf "Screen0"
    InputDevice "Keyboard0" "CoreKeyboard"
    InputDevice "Mouse0" "CorePointer"
    Option "Xinerama" "0"
EndSection

Section "Files"
EndSection

Section "InputDevice"

    # generated from default
    Identifier "Mouse0"
    Driver "mouse"
    Option "Protocol" "auto"
    Option "Device" "/dev/psaux"
    Option "Emulate3Buttons" "no"
    Option "ZAxisMapping" "4 5"
EndSection

Section "InputDevice"

    # generated from default
    Identifier "Keyboard0"
    Driver "kbd"
EndSection

Section "Monitor"

    # HorizSync source: edid, VertRefresh source: edid
    Identifier "Monitor0"
    VendorName "Unknown"
    ModelName "LG Electronics M1910A"
    HorizSync 30.0 - 83.0
    VertRefresh 56.0 - 75.0
    Option "DPMS"
EndSection

Section "Monitor"
    Identifier "Monitor1"
    VendorName "Unknown"
    ModelName "DELL 1908FP"
    HorizSync 31.0 - 83.0
    VertRefresh 56.0 - 76.0
EndSection

Section "Device"
    Identifier "Device0"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8400 GS"
    BusID "PCI:2:0:0"
    Screen 0
EndSection

Section "Device"
    Identifier "Device1"
    Driver "nvidia"
    VendorName "NVIDIA Corporation"
    BoardName "GeForce 8400 GS"
    BusID "PCI:2:0:0"
    Screen 1
EndSection

Section "Screen"
    Identifier "Screen0"
    Device "Device0"
    Monitor "Monitor0"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "CRT: nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

Section "Screen"
    Identifier "Screen1"
    Device "Device1"
    Monitor "Monitor1"
    DefaultDepth 24
    Option "TwinView" "0"
    Option "metamodes" "DFP: nvidia-auto-select +0+0"
    SubSection "Display"
        Depth 24
    EndSubSection
EndSection

IKT (ikt) on 2011-05-06
affects: ubuntu → unity (Ubuntu)
Revision history for this message
Omer Akram (om26er) wrote :

as the reporter described this happens with KDE as well.

affects: unity → null
affects: unity (Ubuntu) → ubuntu
Revision history for this message
Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
isatis39871 (isatis39871) wrote :

Similar problem using ubuntu 10.04 freshly updated on samsung 9 series (intel video card) and a samsung monitor.

I attached a video that illustrate the problem.

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers