Many apps are missing their tray icons in Natty/Unity

Bug #773307 reported by andrey_campbell on 2011-04-29
128
This bug affects 28 people
Affects Status Importance Assigned to Milestone
skype
New
Undecided
Unassigned
Ubuntu
Wishlist
Unassigned

Bug Description

The tray icons for many apps (especially QT apps) are missing!

Important apps that become unusable after being minimized to tray - due to having no tray icon:

* Pidgin
* KeePass
* JungleDisk

UPDATE:

I was able to fix it by setting the systray-whitelist to ['all'] as described here:

http://www.webupd8.org/2011/04/how-to-re-enable-notification-area.html

I'm not setting this as invalid, as I'd like to have an answer from a developer. Is this acceptable? How can this be considered acceptable if it renders many popular applications unusable? It seems the user has to go through an arcane interface just to make some very popular applications like Pidgin usable?

summary: - All QT apps are missing their tray icons in Natty/Unity
+ Many apps are missing their tray icons in Natty/Unity
description: updated
Chrs (chris-widdows) wrote :

I have the same problem, but setting the whitelist doesn't work for me. It was never a problem on 10.10. I agree with the inconvenience this causes. A workaround is fine, a proper fix preferred. I am running Ubuntu 11.04 Classic, 64bit.

Yes, the fix is only for Ubuntu when using Unity - so it won't work in Classic mode where Unity is not employed. I cannot say anything about your problem as I haven't spent much time in Classic mode.

RazrFalcon (razrfalcon) wrote :

I have the same bug. All Qt tray icons are invisible.

Sebastien Bacher (seb128) wrote :

thank you for your bug report, could you open different bugs against unity for each application which you have an issue on?

Changed in ubuntu:
importance: Undecided → Wishlist
status: New → Invalid

Well, since it's based on a whitelist, *all* apps will lack a tray icon (except the few in the whitelist, and except for the even fewer ones implementing the new "indicator" thing which will appear in the indicator area to the right).

Aksuk Vladimir (avqse) on 2011-05-03
Changed in ubuntu:
status: Invalid → Incomplete
status: Incomplete → New
Mike Waters (mikewatersaz) wrote :

A workaround for classic would be appreciated!

Had this happen upgrading from Ubuntu 10.10 to 11.04 non-Unity 2D GNOME shell. My problem was Skype was no longer in the tray. Upstream Skype bug may be found at: https://jira.skype.com/browse/SCL-739

Changed in ubuntu:
status: New → Confirmed
Gabriel (misc-evotex) wrote :

Hi all, I also have this. I am a 10.10 -> 11.04 upgrader, using the classic desktop.

Nicolas Diogo (nicolasdiogo) wrote :

similar story with docky

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers