http://www.ubuntu.com/desktop/get-ubuntu/windows-installer offers lucid wubi.exe and claims it's the most recent version

Bug #762833 reported by Charlie Hogg on 2011-04-16
16
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
ubuntu-website-content
Undecided
Matthew Nuzum
Ubuntu
Undecided
Unassigned

Bug Description

I am new to ubuntu and thought I'd try it out. I am installing it alongside windows xp media centre edition 32 bit on an acer aspire laptop using the download here:

http://www.ubuntu.com/desktop/get-ubuntu/windows-installer

When I download and run the install, the installation fails just as it gets to completion. The error says to check a log file in the local settings folder. This log file finishes with the lines shown below.

I think the installation should be able to find everything from the web download and install. What am I doing wrong?

Thanks,
Charlie

04-16 15:19 INFO saplog: Checking block bindings..
04-16 15:19 INFO saplog: Key verified successfully.
04-16 15:19 DEBUG CommonBackend: metalink md5sums:
69abb55c440b87c749752539041c0159 natty-desktop-amd64+mac.metalink
e3dbbc725db3ff8c01de63afebcd08a0 natty-desktop-amd64.metalink
d58d54d338a713a1815ded7b561c0c15 natty-desktop-i386.metalink
ededa7488e0b028f5db3e9150501acaa natty-desktop-powerpc.metalink

04-16 15:19 ERROR CommonBackend: The md5 of the metalink does match
04-16 15:19 ERROR CommonBackend: Cannot authenticate the metalink file, it might be corrupt
Traceback (most recent call last):
  File "\lib\wubi\backends\common\backend.py", line 367, in get_metalink
  File "\lib\wubi\backends\common\downloader.py", line 79, in download
  File "\lib\urlgrabber\grabber.py", line 927, in urlgrab
  File "\lib\urlgrabber\grabber.py", line 845, in _retry
  File "\lib\urlgrabber\grabber.py", line 913, in retryfunc
  File "\lib\urlgrabber\grabber.py", line 1001, in __init__
  File "\lib\urlgrabber\grabber.py", line 1072, in _do_open
  File "\lib\urlgrabber\grabber.py", line 1182, in _make_request
URLGrabError: [Errno 14] HTTP Error 404: Not Found
04-16 15:19 DEBUG TaskList: ### Finished get_metalink
04-16 15:19 DEBUG TaskList: New task download
04-16 15:19 DEBUG TaskList: ### Running download...
04-16 15:19 DEBUG btdownloader: downloading http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso.torrent > D:\ubuntu\install\lucid-desktop-amd64.iso
04-16 15:19 ERROR TaskList: problem getting response info - HTTP Error 404: Not Found
Traceback (most recent call last):
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\btdownloader.py", line 79, in download
  File "\lib\bittorrent\download.py", line 129, in download
  File "\lib\wubi\backends\common\btdownloader.py", line 70, in error_callback
DownloadError: problem getting response info - HTTP Error 404: Not Found
04-16 15:19 ERROR TaskList: Non fatal error problem getting response info - HTTP Error 404: Not Found in task download
04-16 15:19 DEBUG TaskList: ### Finished download
04-16 15:19 DEBUG TaskList: New task download
04-16 15:19 DEBUG TaskList: ### Running download...
04-16 15:19 DEBUG downloader: downloading http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso > D:\ubuntu\install\lucid-desktop-amd64.iso
04-16 15:19 DEBUG downloader: Download start filename=D:\ubuntu\install\lucid-desktop-amd64.iso, url=http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso, basename=lucid-desktop-amd64.iso, length=721129472, text=None
04-16 15:53 DEBUG TaskList: ### Finished download
04-16 15:53 DEBUG downloader: download finished (read 721129472 bytes)
04-16 15:53 DEBUG TaskList: New task check_iso
04-16 15:53 DEBUG TaskList: ### Running check_iso...
04-16 15:53 DEBUG CommonBackend: Checking D:\ubuntu\install\lucid-desktop-amd64.iso
04-16 15:53 DEBUG Distro: checking Ubuntu ISO D:\ubuntu\install\lucid-desktop-amd64.iso
04-16 15:53 DEBUG WindowsBackend: extracting .disk\info from D:\ubuntu\install\lucid-desktop-amd64.iso
04-16 15:53 DEBUG Distro: parsing info from str=Ubuntu 10.04.2 LTS "Lucid Lynx" - Release amd64 (20110211.1)
04-16 15:53 DEBUG Distro: parsed info={'name': 'Ubuntu', 'subversion': 'Release', 'version': '10.04.2', 'build': '20110211.1', 'codename': 'Lucid Lynx', 'arch': 'amd64'}
04-16 15:53 DEBUG Distro: wrong version: 10.04.2 != 10.04.1
04-16 15:53 DEBUG TaskList: ### Finished check_iso
04-16 15:53 ERROR TaskList: Could not retrieve the required installation files
Traceback (most recent call last):€€
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 498, in get_iso
Exception: Could not retrieve the required installation files
04-16 15:53 DEBUG TaskList: # Cancelling tasklist
04-16 15:53 ERROR root: Could not retrieve the required installation files
Traceback (most recent call last):
  File "\lib\wubi\application.py", line 56, in run
  File "\lib\wubi\application.py", line 130, in select_task
  File "\lib\wubi\application.py", line 156, in run_installer
  File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
  File "\lib\wubi\backends\common\backend.py", line 498, in get_iso
Exception: Could not retrieve the required installation files
04-16 15:53 DEBUG TaskList: # Finished tasklist

Fabio Marconi (fabiomarconi) wrote :

HTTP Error 404: Not Found
Probably the server was down, can you please run again the installer?
Thanks
Fabio

Changed in ubuntu:
status: New → Incomplete
bcbc (bcbc) wrote :

Someone has updated the version of Wubi.exe on http://www.ubuntu.com/desktop/get-ubuntu/windows-installer to the old wubi 10.04.1 - and this update must have been very recent. Prior to this it was downloading 10.10 wubi.exe.

Thsi version of wubi.exe (10.04.1) does not work at all anymore since the release of 10.04.2 (there is a separate bug 722955 that the wubi.exe on http://releases.ubuntu.com/lucid/ is the incorrect version).

Changed in ubuntu:
status: Incomplete → Confirmed
Changed in ubuntu-website-content:
status: New → Confirmed
Changed in ubuntu:
status: Confirmed → Invalid
Changed in wubi:
status: New → Confirmed
bcbc (bcbc) on 2011-04-16
summary: - wubi fails to install all the files properly.
+ Incorrect version of wubi.exe on http://www.ubuntu.com/desktop/get-
+ ubuntu/windows-installer

FYI for users running into this problem:
The wubi.exe for 10.10 Maverick Meerkat can be obtained at http://releases.ubuntu.com/maverick/wubi.exe
The wubi.exe for 10.04 Lucid Lynx can only be obtained at http://people.canonical.com/~evand/wubi/lucid/wubi-r191.exe

You can also get wubi.exe by downloading the desktop CD ISO and burning it to CD - in this case the wubi.exe always matches the release you downloaded.

Charlie Hogg (chogg) wrote :
Ellen Arnold (ellenjanearnold) wrote :

Is it okay to close this bug now?

Download full text (6.0 KiB)

I don't know if the version has been updated. I got it from another source as suggested. That worked fine, so close it as far as I'm concerned.

Charlie

-----Original Message-----
From: <email address hidden> [mailto:<email address hidden>] On Behalf Of Ellen Arnold
Sent: 19 April 2011 16:08
To: <email address hidden>
Subject: [Bug 762833] Re: Incorrect version of wubi.exe on http://www.ubuntu.com/desktop/get-ubuntu/windows-installer

Is it okay to close this bug now?

--
You received this bug notification because you are a direct subscriber of the bug.
https://bugs.launchpad.net/bugs/762833

Title:
  Incorrect version of wubi.exe on http://www.ubuntu.com/desktop/get-
  ubuntu/windows-installer

Status in Ubuntu Website Content:
  Confirmed
Status in Wubi, Windows Ubuntu Installer:
  Confirmed
Status in Ubuntu:
  Invalid

Bug description:
  I am new to ubuntu and thought I'd try it out. I am installing it
  alongside windows xp media centre edition 32 bit on an acer aspire
  laptop using the download here:

  http://www.ubuntu.com/desktop/get-ubuntu/windows-installer

  When I download and run the install, the installation fails just as it
  gets to completion. The error says to check a log file in the local
  settings folder. This log file finishes with the lines shown below.

  I think the installation should be able to find everything from the
  web download and install. What am I doing wrong?

  Thanks,
  Charlie

  04-16 15:19 INFO saplog: Checking block bindings..
  04-16 15:19 INFO saplog: Key verified successfully.
  04-16 15:19 DEBUG CommonBackend: metalink md5sums:
  69abb55c440b87c749752539041c0159 natty-desktop-amd64+mac.metalink
  e3dbbc725db3ff8c01de63afebcd08a0 natty-desktop-amd64.metalink
  d58d54d338a713a1815ded7b561c0c15 natty-desktop-i386.metalink
  ededa7488e0b028f5db3e9150501acaa natty-desktop-powerpc.metalink

  04-16 15:19 ERROR CommonBackend: The md5 of the metalink does match
  04-16 15:19 ERROR CommonBackend: Cannot authenticate the metalink file, it might be corrupt
  Traceback (most recent call last):
    File "\lib\wubi\backends\common\backend.py", line 367, in get_metalink
    File "\lib\wubi\backends\common\downloader.py", line 79, in download
    File "\lib\urlgrabber\grabber.py", line 927, in urlgrab
    File "\lib\urlgrabber\grabber.py", line 845, in _retry
    File "\lib\urlgrabber\grabber.py", line 913, in retryfunc
    File "\lib\urlgrabber\grabber.py", line 1001, in __init__
    File "\lib\urlgrabber\grabber.py", line 1072, in _do_open
    File "\lib\urlgrabber\grabber.py", line 1182, in _make_request
  URLGrabError: [Errno 14] HTTP Error 404: Not Found
  04-16 15:19 DEBUG TaskList: ### Finished get_metalink
  04-16 15:19 DEBUG TaskList: New task download
  04-16 15:19 DEBUG TaskList: ### Running download...
  04-16 15:19 DEBUG btdownloader: downloading http://cdimage.ubuntu.com/lucid/daily-live/20110211.1/lucid-desktop-amd64.iso.torrent > D:\ubuntu\install\lucid-desktop-amd64.iso
  04-16 15:19 ERROR TaskList: problem getting response info - HTTP Error 404: Not Found
  Traceback (most recent call last):
    File "\lib\wubi\backends\common\tasklist.py", line 197, in __call__
    File "\lib\wubi...

Read more...

No. It needs to be fixed.

The wrong version of wubi.exe (10.04.1) is on
http://releases.ubuntu.com/lucid/ and the same version is now on
http://www.ubuntu.com/desktop/get-ubuntu/windows-installer and this one is
the one most people download.

The main one ( http://www.ubuntu.com/desktop/get-ubuntu/windows-installer ) was
set at Maverick Meerkat 10.10 up until late last week. This was changed
without notice (and nowhere on the page does it state the release that will
be downloaded.)
Since that time, everyone running it will find it downloads the 10.04.2
Desktop ISO (700MB download) and then rejects it with: 10.04.2 != 10.04.1

We've been seeing a number of these on ubuntuforums.org already. It is quite
urgent (and a simple fix) to:
1) replace it with a working version for either 10.04.2 or 10.10
2) state on the page which release it is so users know what they are
installing

On Tue, Apr 19, 2011 at 8:07 AM, Ellen Arnold <email address hidden>wrote:

> Is it okay to close this bug now?
>
>

This bug is still there and has kept me busy all day. Perhaps potential users of WUBI can be informed of this bug or rerouted to the maverick site on the two most popular sites.

bcbc (bcbc) wrote :

The webpage does actually say that it's the latest version of Ubuntu:
"Click the big orange button to download the latest version of Ubuntu. This Windows installer (Wubi) will help you to run Ubuntu within your current system."

So the change to point at lucid from maverick doesn't appear to be correct either.

Colin Watson (cjwatson) wrote :

Let's separate this into two pieces:

  1) The website directs you to lucid wubi.exe, saying that that's the most recent version of Ubuntu.
  2) The lucid wubi.exe is from 10.04.1 and therefore now broken.

The second of those is bug 722955, and should be handled there (I will do so). However, the first bug remains, and can only be solved by the www.ubuntu.com maintainers (who don't include me).

Colin Watson (cjwatson) wrote :

I have now fixed bug 722955. As mentioned in comment 10, this still leaves the perplexing question of why the website is claiming that 10.04 is the most recent version of Ubuntu, especially in something aimed at Windows users.

Furthermore, I find it a bit surprising that the web team didn't come and ask the cdimage/release team about the fact that the number one link offered for our flagship product no longer worked after a change they made, and that I had to find out about this by happening to read a comment on IRC in my free time. They at least should have known who could deal with it!

summary: - Incorrect version of wubi.exe on http://www.ubuntu.com/desktop/get-
- ubuntu/windows-installer
+ http://www.ubuntu.com/desktop/get-ubuntu/windows-installer offers lucid
+ wubi.exe and claims it's the most recent version
Matthew Nuzum (newz) on 2011-04-21
Changed in ubuntu-website-content:
status: Confirmed → In Progress
Colin Watson (cjwatson) wrote :

(Although I gather that this was a relatively recent change, so hopefully the web team simply hadn't got round to it yet - but it seems to me that this is the sort of website change that should be tested.)

Matthew Nuzum (newz) wrote :

The code to deal with this is right, somewhere in there is a hidden redirect that I'm trying to pin down. The site is frozen until release day so we can't actually publish the change until Natty launches.

Changed in ubuntu-website-content:
assignee: nobody → Matthew Nuzum (newz)
Matthew Nuzum (newz) wrote :

The change to ubuntu.com to direct users to the proper wubi.exe will go live on Thursday.

Changed in ubuntu-website-content:
status: In Progress → Fix Committed

On Thursday, the latest Ubuntu release will of course become 11.04.
Will you be directing users to the natty wubi.exe, or will you be
directing them to the maverick wubi.exe with more accurate text? It
would be useful for the cdimage team to be aware of this. Thanks.

jweaver28 (jweaver28) wrote :

It's afternoon on 4/28 in the US and though I downloaded wubi.exe, I can't find an authenticated md5 hash. My amd64 version of Natty, though, checksummed just fine. FYI, googling wubi.exe and checksum brought links to a few bug reports like this, but googling the hash I made today, 39f805cae8be546747c492935ce0fcdd produced nothing. I'm worried because i got a corrupted version of xbmc in January (contained a trojan bootloader) and googling also brought links to http://malc0de.com/database/index.php?&search=RU&CC=on&page=3 which apparantly indicates russian malware was on a wubi.exe file on 4/24/11.

bcbc (bcbc) wrote :

The wubi.exe I downloaded from
http://ubuntu.com/desktop/get-ubuntu/windows-installer just now is signed
by Canonical UK Ltd. and is revision 211 for release 11.04.

I'm not aware of the hash for this being published, but then I've never
looked for it either. The md5 checksum I get
is 39F805CAE8BE546747C492935CE0FCDD so that matches what you have.

On Thu, Apr 28, 2011 at 11:18 AM, jweaver28 <email address hidden>wrote:

> It's afternoon on 4/28 in the US and though I downloaded wubi.exe, I
> can't find an authenticated md5 hash. My amd64 version of Natty, though,
> checksummed just fine. FYI, googling wubi.exe and checksum brought links
> to a few bug reports like this, but googling the hash I made today,
> 39f805cae8be546747c492935ce0fcdd produced nothing.

Matthew Nuzum (newz) on 2011-06-08
Changed in ubuntu-website-content:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers