Keyboard layout Jumps periodicly back to us Keyboard Layout

Bug #762111 reported by robin.nightingale on 2011-04-15
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I installed Ubuntu 11.04 with German Keyboard Layout.
But after every reboot it starts with the us keyboard Layout but in the main Panell it shows that the German Layout is activated.
After switching in the panel from german to us and back to german i get back german keyboard layout for a while.
But after a while it always jumps back into us layout.

the commands
sudo dpkg-reconfigure keyboard-configuration
and
sudo apt-get install localepurg didnt helped

Here the Output of $ locale

pirate@ship:~$ locale
LANG=de_DE.UTF-8
LANGUAGE=de_DE:en
LC_CTYPE="de_DE.UTF-8"
LC_NUMERIC="de_DE.UTF-8"
LC_TIME="de_DE.UTF-8"
LC_COLLATE="de_DE.UTF-8"
LC_MONETARY="de_DE.UTF-8"
LC_MESSAGES="de_DE.UTF-8"
LC_PAPER="de_DE.UTF-8"
LC_NAME="de_DE.UTF-8"
LC_ADDRESS="de_DE.UTF-8"
LC_TELEPHONE="de_DE.UTF-8"
LC_MEASUREMENT="de_DE.UTF-8"
LC_IDENTIFICATION="de_DE.UTF-8"
LC_ALL=

It says german while i still have us layout

ProblemType: Bug
DistroRelease: Ubuntu 11.04
Package: xorg 1:7.6+4ubuntu3
ProcVersionSignature: Ubuntu 2.6.38-8.42-generic 2.6.38.2
Uname: Linux 2.6.38-8-generic x86_64
NonfreeKernelModules: wl
Architecture: amd64
DRM.card0.DVI.D.1:
 status: disconnected
 enabled: disabled
 dpms: Off
 modes:
 edid-base64:
DRM.card0.LVDS.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1280x800
 edid-base64: AP///////wAGEF6cAAAAAAkQAQOAHRN4CmUhn1hVhyopUFQAAAABAQEBAQEBAQEBAQEBAQEBvBsAoFAgFzAwIDYAHrIQAAAYAAAAAQAGECAAAAAAAAAAAAogAAAA/gBOMTMzSTEtTDAxCiAgAAAA/ABDb2xvciBMQ0QKICAgAGE=
DRM.card0.VGA.1:
 status: connected
 enabled: enabled
 dpms: On
 modes: 1024x768 1024x768 1024x768 1024x768 800x600 800x600 800x600 640x480 640x480 640x480 720x400
 edid-base64: AP///////wBCkxUm/GEFAA4OAQMIHhdkKEAFnFdSkiYcUFStzgABAQEBAQEBAQEBAQEBAQEBwx4AIEEAIDAQYBMAMOQQAAAeAAAA/AA1ODIKICAgICAgICAgAAAA/QA8Sx48CAAAAAAAAAAAAAAA/gBGSFpKNDMwMzUyNzY0ABo=
Date: Fri Apr 15 21:16:26 2011
DistUpgraded: Fresh install
DistroCodename: natty
DistroVariant: ubuntu
DkmsStatus: bcmwl, 5.100.82.38+bdcom, 2.6.38-8-generic, x86_64: installed
GraphicsCard:
 Intel Corporation Mobile GM965/GL960 Integrated Graphics Controller (primary) [8086:2a02] (rev 03) (prog-if 00 [VGA controller])
   Subsystem: Apple Computer Inc. Device [106b:00a1]
   Subsystem: Apple Computer Inc. Device [106b:00a1]
InstallationMedia: Ubuntu 11.04 "Natty Narwhal" - Beta amd64+mac (20110410)
MachineType: Apple Inc. MacBook3,1
ProcEnviron:
 LANGUAGE=de_DE:en
 LANG=de_DE.UTF-8
 SHELL=/bin/bash
ProcKernelCmdLine: BOOT_IMAGE=/vmlinuz-2.6.38-8-generic root=/dev/mapper/ubuntu-root ro quiet splash vt.handoff=7
SourcePackage: xorg
Symptom: display
UpgradeStatus: No upgrade log present (probably fresh install)
dmi.bios.date: 03/05/08
dmi.bios.vendor: Apple Inc.
dmi.bios.version: MB31.88Z.008E.B02.0803051832
dmi.board.asset.tag: Base Board Asset Tag
dmi.board.name: Mac-F22788C8
dmi.board.vendor: Apple Inc.
dmi.board.version: PVT
dmi.chassis.asset.tag: Asset Tag#
dmi.chassis.type: 2
dmi.chassis.vendor: Apple Inc.
dmi.chassis.version: Mac-F22788C8
dmi.modalias: dmi:bvnAppleInc.:bvrMB31.88Z.008E.B02.0803051832:bd03/05/08:svnAppleInc.:pnMacBook3,1:pvr1.0:rvnAppleInc.:rnMac-F22788C8:rvrPVT:cvnAppleInc.:ct2:cvrMac-F22788C8:
dmi.product.name: MacBook3,1
dmi.product.version: 1.0
dmi.sys.vendor: Apple Inc.
version.compiz: compiz 1:0.9.4+bzr20110411-0ubuntu2
version.ia32-libs: ia32-libs 20090808ubuntu12
version.libdrm2: libdrm2 2.4.23-1ubuntu6
version.libgl1-mesa-dri: libgl1-mesa-dri 7.10.2-0ubuntu1
version.libgl1-mesa-dri-experimental: libgl1-mesa-dri-experimental N/A
version.libgl1-mesa-glx: libgl1-mesa-glx 7.10.2-0ubuntu1
version.xserver-xorg: xserver-xorg 1:7.6+4ubuntu3
version.xserver-xorg-video-ati: xserver-xorg-video-ati 1:6.14.0-0ubuntu4
version.xserver-xorg-video-intel: xserver-xorg-video-intel 2:2.14.0-4ubuntu7
version.xserver-xorg-video-nouveau: xserver-xorg-video-nouveau 1:0.0.16+git20110107+b795ca6e-0ubuntu7

John Eccleston (john-stasz) wrote :

I also have a similar issue.

During installation of Ubuntu 11.04 (release) I went through the keyboard selection process, where by you press keys on the keyboard and answer yes/no to other keys being present and the installer correctly identified that I have a UK keyboard.

On booting into Ubuntu the top panel shows the USA keyboard, and lists the GBr keyboard as an option. As Robin noted I can get back to the GBr keyboard by clicking between the layouts.

When I go to the Control Centre > Hardware > Keyboard. I can remove the USA keyboard layout from the Layout tab and the USA option disappears from the top panel.

However on reboot the USA keyboard is listed as the active layout and it appears again in the list of layouts in Control Centre > Hardware > Keyboard

John Eccleston (john-stasz) wrote :

Additional information:

The keyboard layout appears to revert back to USA during a session. Seems to be when switching to a new application instance.

Alex Forbes (alexforbes) wrote :

I switched from a USA to UK keyboard and had this problem but I think I have solved it.

First ensure that under "System Settings > Keyboard > Layouts" that "Separate layout for each window" is unchecked, then remove the USA keyboard and apply system-wide.

The other thing that was causing it to reappear for me was the login screen - ensure that the correct keyboard layout is selected when you log on.

John Eccleston (john-stasz) wrote :

Hi Alex, thanks for the suggestion, unfortunately this has no effect. My layout still has both GB and US keyboard layouts, the notification bar still states GB when US is actually in effect and after specifying GB explicitly the layout jumps back to US randomly.

Fabio Marconi (fabiomarconi) wrote :

Hello
Are you having again this problem with the latest release Oneiric Ocelot ?
Thanks
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: New → Incomplete
John Eccleston (john-stasz) wrote :

Hi Fabio.

I have upgraded to Oneiric in the past week and I can confirm that this issue appears to be fixed.

Thanks

John

Fabio Marconi (fabiomarconi) wrote :

Ok John
Thanks for the reply
I close this report
Fabio
---
Ubuntu Bug Squad volunteer triager
http://wiki.ubuntu.com/BugSquad

Changed in ubuntu:
status: Incomplete → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers