installation fails due to tty error

Bug #75135 reported by Arne Baier on 2006-12-09
18
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

The message I get during startup of ubuntu 7.04 alpha feisty fawn live CD is:

"BusyBox v1.1.3 (Debian 1:1.1.3-3ubuntu2) Built-in shell (ash)

Enter 'help' for a list of built-in commands

/bin/sh: can't access tty; job control turned off

(initramfs)"

Same installation CD works fine in a VM.

Toni Helenius (toni-helenius) wrote :

I got the same here. The alternative CD tells that it doesn't find CD-ROM drive. As did all the Egdy releases I tried. I hoped that the new kernel version in Feisty would fix this but no. Still no luck installing Kubuntu after hardware upgrade. Even if I tried to modify BIOS or try the boot flags as described in the forums and wiki.

I'm using Intel Core Duo with Intel DG965WH and Nec 18x Optriac DVD-R drive.

I tried Feisty's alternative & desktop 64-bit CDs.

John Vivirito (gnomefreak) wrote :

Changed package bug was reported on.

Henrik Nilsen Omma (henrik) wrote :

Where exactly is this happening, during the boot process? After the first boot menu (gfxboot)?

John, I doubt this is a ubiquity bug. Kernel or udev perhaps.

Changed in ubiquity:
status: Unconfirmed → Needs Info
Arne Baier (baier) wrote :

After "Loading Linux kernel" the first ubuntu logo appears and some progress bar moves right and left. And after it has hit the right border for the 3rd time maybe, suddenly the message appears.

Toni Helenius (toni-helenius) wrote :

Arne, have you tried the alternative CD/DVD? It'll probably tell you that it wont find your CD/DVD drive.
I suspect that this problem is related to ICH8 or JMICRON (the newer chipsets for Core Duos...).

Arne Baier (baier) wrote :

Nope, haven't tried it, yet. Buuut....this is some good old piece of hardware running an XP 2200+ at 1800 MHz. Maybe I should mention that the good old Mr. Edgy ran beautifully on this machine.

Toni Helenius (toni-helenius) wrote :

My problem is definitely this "Installer Freezes on Not Finding IDE CD/DVD-ROM Drive" described in: https://wiki.ubuntu.com/Core_2_Duo_Support

And I just wonder why even the new Feisty stops at this bug :´(

Vassilis Pandis (pandisv) wrote :

I used to have this problem with the livecd as well but current daily lives boot just fine. You might want to see if your problem was fixed as well.

Toni Helenius (toni-helenius) wrote :

Kubuntu AMD64 Herd #2 Desktop CD works, but the installer crashes on the partitioning phase. The QParted works just fine standalone. The alternate CD as usual fails to find the DVD-drive on my Core 2 Duo system and thus fails to install. Unfortunately I have no means (except for paper and pen) to give the Desktop CD crash report.

However I don't know were the Herd #2 officially released version since http://www.kubuntu.org isn't updated to reflect the current situation...

I am getting the same error while attempting to install Xubuntu 6.10 on a Sony Viao (PCG-SR33K).

Do you suppose the BusyBox FAQ regarding this error is relevant?
http://www.busybox.net/FAQ.html#job_control

According to this, it would seem that the installer is loading the BusyBox shell on /device/console rather than tty1 or ttyS0. The resolution either requires that the installer select tty1 or ttyS0 as an alternative, or noctty be set to 0 in drivers/char/tty_io.c.

I downloaded Feisty beta 2 (both kubuntu-7.04-beta-desktop-i386 AND Feisty 386) and can't hardly get past the boot gfx before I get dumped to a command line with the error "can't access tty; Job control turned off"

I tried burning the Kubuntu disk a 2nd time using DAO at only 8x. Same error and running Test CD also fails with the same error. I googled quite a bit and found no solution yet. I don't have anything extra plugged into USB ports, etc.

My hardware is ASUS M2V-MX mobo
AMD 64 3000+
1 Gig DDR2 800
Biostar Nvidia 6300gt PCIe
via KM800 chipset

FYI, I'm already running Mepis 6.5 RC3 (based on Dapper) and also Edgy on this same box, so the problem is specific to the Feisty. I'm not trying to upgrade to feisty - just install to another partition.

Enrico Sardi (enricoss) wrote :

Hi all!

I have the same problem with a Core duo 2 and an Asus p5b-e . I tried Feisty 7.04 beta (herd5)

Bye

Enrico

ddoxey (dylan-doxey) wrote :

I had a success installing Xubuntu on my Vaio SR33K using the 6.10 Alternate ISO.
I selected the text mode installation and the procedure was flawless.

Matt (matt-lennig) wrote :

I installed Feisty Alternate daily build for i386 of 10 April 2007 on software RAID1 using the installer to create the RAID. At the end of the install, the installer ejected the disk and rebooted the system. It booted fine! However, when I rebooted again, I got the error Can't access tty; job control turned off.

My hardware configuration is as follows:
motherboard: Abit AB9Pro
memory: 4GB
hard drives: six 500GB Western Digital SATA drives
CDROM: Lite-On SATA CDROM

Any help would be greatly appreciated.

DanielPhillips (dwp-rushpost) wrote :

I installed Feisty final today and got this error on my Dell 8500 Inspiron Laptop. I verified the md5 sum and verified the CD.

Wilb (ubuntu-wilb) wrote :

Also having exactly the same problems with Feisty Final - it crashes out to a busybox prompt, erroring that it can't find a plethora of paths. Looking through the logs, it fails to mount /root/cdrom and gets in a pickle from then onwards. I've tried booting with break=mount and mounting manually, which I can do, but I think its already missed running some important scripts by then as ctrl d doesn't fire it off again. Definitely not a media problem as it works fine on another machine....

Shane (duairc) wrote :

Yeah, I'm getting this problem too. The same CD worked fine on my AMD computer. The computer is some Phillips desktop with an Pentium 4.

pitufo (pa-pitufo-pa) wrote :

Got the tty error on a final feisty's cd, hardware is :

 Bi pIII motherboard with 2 pIII 866
 2 x 256mo sdr pc-133
 1 x IDE HDD
 1 x IDE DVD drive

a debian woody installed without issue.

I'm also having this issue with Feisty Final. The CD boots and installs flawlessly in numerous other machines, except on the following:

IBM eServer xSeries 232 (Type 8668-27X)
Dual P3 1.13
1GB ECC PC133
6 x 18.2 GB u160 SCSI on an integrated Adaptec controller (hotswap backplane)
IDE DVD-ROM (only IDE device in the system)

Additionally, this machine had no issues booting an Edgy live CD, as that's what is currently loaded & running flawlessly on one of the drives...

Martin Garton (martingarton) wrote :

I'm getting the same problem on my athlon64 machine, and a friend is also seeing this on a dell desktop. Both these machines install edgy without any problems.

I'm willing to help if there is anything I can do to diagnose this?

ninefofo (ninefofo) wrote :

Same error:

Intel SRSH4 Quad Xeon
4GB Ram
5 x 37GB U320
Slim IDE CDROM

My path to success:

I'm having this problem with an old-ish Dell Optiplex SX260.

To get around this, I booted from the standard Feisty live CD. At the boot menu I chose the option (the 3rd one?) that says to an install with an updated driver CD. When I was prompted to put in the driver CD, I just left the Feisty live CD in and hit enter. Then I was prompted for the Ubuntu live CD, and once again (with the live CD still in the drive) I just hit enter. This procedure got me to the live CD's Gnome desktop.

The first time I clicked on the "Install" icon on the desktop, the manual partition editor hung on me. I killed it from the command-line, and repeated the process. This second time I had no problem with partitioning. I've completed the install, and booted the newly installed Feisty from the hard drive, and everything seems to work fine!

Endolith (endolith) wrote :

I get the exact same error on a Dell Optiplex GX260, except with "Debian 1:1.1.3-3ubuntu3"

(ubuntu-7.04-desktop-i386)

Christian Convey's method got me into GNOME.

Holly (hzheng-selfstudy) wrote :

The same problem. Ask for help. Thanks.

Dell Desktop Inspiron
Intel Core2 Duo processor E6550
DDR2 SDRAM
Serial ATA II Hard Drive
Microsoft Windows Vista Home Premium Edition
Integrated NIC card
128MB NVIDIA GeForce 8300GS
Internal PCI 802.11g wireless network

Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers