Please remove several kde3 packages (source and binary)

Bug #727386 reported by Felix Geyer on 2011-03-01
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Jonathan Riddell

Bug Description

Please remove these kde3 packages from the archive:

abakus
ggz-kde-client
ggz-kde-games
guarddog
guidedog
kasablanca
kbarcode
kdbg
kdirstat
kdissert
keep
kitty
kkbswitch
klamav
klibido
klogic
kmobiletools
kmyfirewall
knutclient
kpicosim
kprof
kptc
kredentials
ksniffer
ksociograma
kst
kstreamripper
ktechlab
ktimetrace
kxstitch
labplot
noteedit
piklab
qalculate-kde
score-reading-trainer
swscanner
skim
taskjuggler

kanjisaver: bug #727334
kdetv: bug #322470

Felix Geyer (debfx) on 2011-03-01
Changed in ubuntu:
assignee: nobody → Jonathan Riddell (jr)
importance: Undecided → Wishlist
status: New → Confirmed
description: updated
Felix Geyer (debfx) on 2011-03-12
description: updated
Jonathan Riddell (jr) on 2011-03-15
Changed in ubuntu:
status: Confirmed → Fix Released
Daniel Holbert (dholbert) wrote :

> Please remove these kde3 packages from the archive:

Any reason for these removals, and any suggested alternative way to obtain the removed packages?

Personally, I find kdirstat to be a super-useful part of my toolchain, and I'm bummed that I can't apt-get install it on Natty.

Daniel Holbert (dholbert) wrote :

(To answer one of my own questions, RE alternative ways to obtain these packages: I just visited the Ubuntu Maverick package page for i386 kdirstat ( https://launchpad.net/ubuntu/maverick/i386/kdirstat ), clicked on the 'version' link, downloaded the .deb from there, and then opened that deb in Ubuntu Software Center. It installed just fine)

Felix Geyer (debfx) wrote :

filelight might be an alternative for kdirstat.

We've removed these packages because they depend on the unmaintained kde3 libs which we want to remove soon.

doweller (do-weller) wrote :

Are missing packages from kde3 also the reason why ksociograma has been removed? I know no other package or program which allows the easy creation of sociogramms for school teachers.

Do you? Or: Is there a chance of "getting it back"?

doweller (do-weller) wrote :

After googling for an hour I wasn't able to find an alternative for ksociograma. Teachers love this tool - so I simple went ahead and had a shot at installing it in Natty:

I installed ksociograma - the Maverick package - in Natty without running into any problems. Unity "does not like it": After starting it, it maximises itself and one cannot use the menu. There seems to be no way to minimise the window by clicking / double-clicking into the panel or trying to "pull" it out of it with the mouse. But after selecting 'Administrator' or 'Studenten' on the start screen only once, the menu shows up and one can change the size of the window and one gets the menu back. This problem also comes up when students enter their data: One has to close the data-entry window with Alt F4 because the menu is not there.

I tried to use
/bin/sh -c 'APPMENU_DISPLAY_BOTH=1 /usr/bin/ksociograma'
as a workaround to make the program start with the menu showing right away - but that didn't help. Maybe I'm just a iota off the right track with this ...

This could IMHO mean two things: 1. it could be relatively easy to put ksociograma back into the repository because 2. it nicely installs (though doesn't run) in Natty because no kde3 libraries / packages seem to be needed.

Felix Geyer (debfx) wrote :

I'm sorry to hear that there are no alternatives but ksociograma (or any application using kde3 libs) is not coming back.
You would have to find someone who is willing to maintain and port it to KDE4.

> [...] because no kde3 libraries / packages seem to be needed.
That's not true, it depends on kdelibs4c2a (aka kde3 libs).

doweller (do-weller) wrote :

You are right. What a pitty. I have written to the maintainer of the program and hope that he will be able to do something about that.

Seth (bugs-sehe) wrote :

This has officially advanced from the usual "Who-moved-my-cheese" into the realm of "who-stole-my-cheese".

I can't believe we have to sit here and watch Windows users have all the fun with WinDirStat (which is a port of kdirstat), but Linux users can't have it anymore?! Gawk. Nervous grin. Laughing fit. Crying.

What _is_ that. Way to kill you're own babies, KDE.

PS. numerous entries from the list of removal requests seems like proper 'cleanup' by the way, so it is not all nonsense, but there is no app that comes close to kdirstat in navigability or speed; e.g. the colouring by filetype is awesom

LostInBrittany (lostinbrittany) wrote :

kxstitch is now based on KDE 4 (according to maintainer, http://sourceforge.net/apps/mediawiki/kxstitch/index.php?title=Main_Page#Latest_Information).

Could it be reintegrated to repositories, please ?

Thanks in advance !

I just found out that kdirstat is gone in Ubuntu Natty and discovered this bug. All I have to say is bravo for putting users first.

As an engineer myself, I understand the need to "move forward" and get rid of cruft, but on the flip side, there's also the need to keep users happy.

Perhaps some sort of note to the newsgroups about this change would have been helpful. Perhaps someone would have stepped up and update the tool. My 2c.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers