New Source Package: libgrip

Bug #715830 reported by Cody Russell
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
libgrip
High
Unassigned
Ubuntu
Wishlist
Unassigned

Bug Description

Feature Freeze Exception:

libgrip is a new package that provides uTouch gesture support for GTK+ 2.x applications. A Python bindings package is also provided. With this library, Ubuntu uTouch gesture support will be easier to integrate into existing GTK+ applications. There is no potential for regression in Ubuntu because it is a new package without any dependencies, either explicit or implicit.

-----
Original bug report:

Please upload libgrip into Ubuntu Natty universe. The packaging branch is lp:~utouch-packaging/libgrip/packaging

Revision history for this message
Bhavani Shankar (bhavi) wrote :

Please do not assign the bug to the sponsors team in the future. Instead if you have something ready to be sponsored please subscribe the sponsors team

regards

Changed in ubuntu:
assignee: Ubuntu Sponsors Team (ubuntu-sponsors) → nobody
importance: Undecided → Wishlist
Didier Roche (didrocks)
Changed in ubuntu:
assignee: nobody → Didier Roche (didrocks)
Revision history for this message
Didier Roche (didrocks) wrote :

Nice work! just a few minor things that will be nice to fix though:

* debian/copyright:
Can you please update to latest revision of DEP5. Please refer to libunity package (http://bazaar.launchpad.net/~ubuntu-desktop/libunity/ubuntu/view/head:/debian/copyright) to have the latest syntax.

* debian/control:
   in debian/rules, you have DEB_CONFIGURE_EXTRA_FLAGS += --disable-gtk-doc
   seems that in debian/control, you build-dep on gtk-doc-tools which is unneeded then.

* On the Vcs, can you please look at my last comment on bug #684275? I think it applies as well (moving the packaging branch)

if you need any help, to not hesitate :)

Changed in ubuntu:
assignee: Didier Roche (didrocks) → Cody Russell (bratsche)
Revision history for this message
Cody Russell (bratsche) wrote :

Fixed debian/copyright to be DEP5, removed the gtk-doc-tools dependency from debian/control, added Vcs-Bzr tag, and pushed to a new location lp:~utouch-packaging/libgrip/ubuntu

Revision history for this message
Didier Roche (didrocks) wrote :

* You added some files since last time, you need to do a new release with this :)

* I'm not sure about shipping the Grip.py gi override in a separate package (python-grip). I think most of people will expect just install the gir package, isn't it? shouldn't it make more sense to ship it in the gir package rather?

* from http://www.netfort.gr.jp/~dancer/column/libpkg-guide/libpkg-guide.html, the -dev package name should be: libgrip-0.10-dev
(see objdump -p debian/libgrip-0.1-0/usr/lib/libgrip-0.1.so.0.0.0 | sed -n 's/^[[:space:]]*SONAME[[:space:]]*//p' | sed 's/\(0-9\)\.so\./\1/; s/\.so\.//; s/$/-dev/'). This is not important IMHO and really depends on how you want to handle it (multiple -dev package? just one -dev without soname in it?).

* if you want to keep the python- package,
can you fix that new lintian warning btw:

$ lintian-info --tags old-versioned-python-dependency
N: old-versioned-python-dependency
N:
N: This package appears to be an architecture-independent Python module
N: but has a dependency on a version of python less than a particular
N: version, doesn't use python-support and no Python-Version control
N: field. This normally means that the package isn't using the current
N: Python policy; most architecture-independent Python packages will work
N: with any future version of Python if they follow the new policy.
N:
N: If this package really does require only a particular range of Python
N: versions and uses python-central, add a Python-Version control field
N: (as described in 2.3 of the Python policy) to resolve this warning.
N:
N: Severity: normal, Certainty: certain
N:

really optional:
You build libgrip.pc libgrip-0.1.pc (libgrip.pc comes from libgrip.pc.in). You ship the -0.1.pc, maybe you should mv instead of cp

for the future: shipping the examples source (in its own package for instance or in -dev) can be interesting.

Apart frorm that, all the cryptic gir- package is perfectly handled! nice work :)

Changed in libgrip:
assignee: nobody → Chase Douglas (chasedouglas)
importance: Undecided → High
Stephen M. Webb (bregma)
Changed in libgrip:
assignee: Chase Douglas (chasedouglas) → Stephen M. Webb (bregma)
Stephen M. Webb (bregma)
description: updated
Revision history for this message
Stephen M. Webb (bregma) wrote :

I believe all the problems have been addressed:

(1) A new upstream version was released with the new files.

(2) The python- package contains all the python bindings, not just the gir overrides.

(3) The libgrip-0.1-dev package is consistently named following gtk add-on convention and does not include the SONAME.

(4) Lintian warnings are fixed.

(5) The example source will be added as a package at a later date.

Changed in libgrip:
assignee: Stephen M. Webb (bregma) → nobody
Revision history for this message
Artur Rona (ari-tczew) wrote :

We are in FeatureFreeze and new packages needs FFe exception.
https://wiki.ubuntu.com/FreezeExceptionProcess

Please complete the informations mentioned in above link and subscribe ubuntu-release.

Changed in ubuntu:
status: New → Incomplete
description: updated
Changed in ubuntu:
status: Incomplete → New
assignee: Cody Russell (bratsche) → nobody
Revision history for this message
Martin Pitt (pitti) wrote :

As discussed on IRC, approved. My preference would be to keep this in universe for Natty and ship the evince/eog/etc. patches (which are presumably very intrusive) in a PPA for testing, and we land them early in 11.10. As usual this can be overridden by SABDFL powers.

Changed in ubuntu:
status: New → Confirmed
Changed in libgrip:
status: New → Confirmed
Revision history for this message
Scott Kitterman (kitterman) wrote :

This is in Natty.

Changed in ubuntu:
status: Confirmed → Fix Released
Changed in libgrip:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers