can not boot after update

Bug #700831 reported by Teemu Nikkilä on 2011-01-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Ubuntu 10.10 will not boot after an update containing kernel packages.

I have a clean install of Maverick on an IBM ThinkPad T41P. Everything was working perfectly until I did an ordinary system update. The update finished with an error and the filesystem had become read-only. After a reboot (Ctrl-Alt-F1, login, sudo halt, power-on) the system can not find /sbin/init during boot, and falls back to the initramfs busybox prompt.

I tried to use the install CD to do fsck.ext4 on /dev/sda5 (root partition), but fsck reports the partition as mounted. It is not in /etc/mtab, nor can it be unmounted with sudo umount.

Fabio Marconi (fabiomarconi) wrote :

Hello
Starting your pc press right shift to show the grub menu, then select to start the old kernel, then when ubuntu is ready, run in a terminal
sudo apt-get clean
and run again update manager
Thanks
Fabio

Changed in ubuntu:
status: New → Incomplete
Teemu Nikkilä (teemu-nikkila) wrote :

Hi,

nothing that I tried on the boot prompt helped (different kernels, specifying the boot partition as /dev/sda1, not by UUID). Finally I removed the disk, hooked it up to a USB box, and fsck'd the root partition on a different machine.

Then I inserted it back to the original machine and it booted the newest kernel from the list just fine.

After logging in, Update Manager reports: "Software index is broken - It is impossible to install or remove any software. Please use the package manager "Synaptic" or run "sudo apt-get install -f" in a terminal to fix this issue at first."

Now let's see what happens when I try to update again.

Teemu Nikkilä (teemu-nikkila) wrote :

I did what apt-get suggests:

first:
sudo apt-get update

sudo dpkg --configure -a

sudo apt-get install -f (this fails):

dpkg: error while cleaning up:
 unable to restore backup version of `/usr/src/linux-headers-2.6.35-23-generic/arch/x86/kernel/.asm-offsets.s.cmd': Read-only file system
...
touch: cannot touch `/var/lib/update-notifier/dpkg-run-stamp': Read-only file system
sh: cannot create /var/lib/update-notifier/updates-available: Read-only file system
E: Problem executing scripts DPkg::Post-Invoke 'if [ -d /var/lib/update-notifier ]; then touch /var/lib/update-notifier/dpkg-run-stamp; fi; if [ -e /var/lib/update-notifier/updates-available ]; then echo > /var/lib/update-notifier/updates-available; fi '
E: Sub-process returned an error code
E: Sub-process /usr/bin/dpkg returned an error code (2)

Teemu Nikkilä (teemu-nikkila) wrote :

sudo apt-get install -s -f:
...
Inst linux-headers-2.6.35-23-generic [2.6.35-23.40] (2.6.35-23.41 Ubuntu:10.10/maverick-updates [i386])
Conf linux-headers-2.6.35-23-generic (2.6.35-23.41 Ubuntu:10.10/maverick-updates [i386])

uname -a:
Linux T41p 2.6.35-23-generic #41-Ubuntu SMP Wed Nov 24 10:18:49 UTC 2010 i686 GNU/Linux

Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

Changed in ubuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers