after hibernate wireless doesn't work

Bug #69426 reported by huntermix
16
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

In my laptop (sony vaio fe690) with ipw3945 wireless card, if i hibernate and then turn it on the wireless can't connect to the network anymore, it works again if i do a dhclient eth1, so my guess is when he laptop hibernates it keeps the old ip address but when it comes back on it doesn't work and it can't get a new one by itself.
something similar happens if i connect first with the wired adapter (intel 10/100 ethernet) and then disconnect the cable and try to use the wireless... same error and i can't get an ip address until i reboot.

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

are you using network manager?

if not, please try.

This should solve this problem.

Revision history for this message
huntermix (sm01p) wrote :

I have tried using network-manager. First I disabled network-admin applet from the taskbar and then I install network manager (following the wiki) and reboot. But with network manager I can't connect to the wireless network.
After some testing I noticed that if i manually do:
iwconfig eth1 essid myessid
iwconfig eth1 key myhexkey
iwconfig eth1 mode Managed
The problem is when getting an IP, if I do dhclient eth1 it works if it is the first time I connect to any network (wired or wireless), but if I disconnect and I want to connect to another network then the only way is to reboot.
It's weird that no one else has this problem since this seems something that every user does, so i will keep investingating if the error is on my side.
Thanks for the reply

Revision history for this message
huntermix (sm01p) wrote :

i found a workaround, after the hibernate i have to do:
ifconfig eth1 down (bring down wireless interface)
then:
ifconfig eth0 or eth1 up (and dhclient that interface)

Revision history for this message
Duncan Lithgow (duncan-lithgow) wrote :

Have you tried this on a different wireless network to see if it's something to do with the way IP's are being given out?

Revision history for this message
Sarah Kowalik (hobbsee-deactivatedaccount) wrote :

This appears to be fixed in feisty, with the 2.6.20 kernel. I have the same problem under edgy.

Revision history for this message
Murali (mshanker) wrote :

I am still having the same trouble in Feisty (Beta), but will try the above solutions. There also appears to be a similar solution/bug report at
https://bugs.launchpad.net/ubuntu/+source/dhcdbd/+bug/88327

Revision history for this message
Ilya Boyandin (ilyabo) wrote :

I have the same problem with Feisty and 2.6.20 kernel on my thinkpad r50.

Revision history for this message
Giampiero Salvi (giampi-kth) wrote :

Hi,
I have the same problem with a Vaio VGN-SZ3HP. The wlan led is dead when I resume from hibernation and I do not see any network in the network manager. It doesn't help to switch off and on the wireless card (with the wireless hardware switch).

The wireless network starts working again if I run

sudo modprobe -r ipw3945
sudo modprobe ipw3945

Giampiero

Revision history for this message
Thomas de Graaff (thomasdegraaff) wrote :

My computer with Xubuntu feisty had a problem with getting an ip-adress after waking from hibernation. I´ve solved this problem by changing /etc/default/acpi-support

Editing this file, look for the line below, where to add [networking] after that no problems anymore:

# Add services to this list to stop them before suspend and restart them in
# the resume process.
STOP_SERVICES="networking"

Hope this will work for you to,
Thomas.

Revision history for this message
NT (ntrivedi) wrote :

This worked for me. Thanks!

Revision history for this message
lalaland (lalaland-deactivatedaccount) wrote :

Seems to have fixed the issue for me, too. But I think the real problem is somewhere else...

Revision history for this message
GGrigsby (garl-grigsby-gmail) wrote :

I'm running Feisty on a Dell Inspiron 9300 with a Intel 2200BG radio. When Feisty recovers from hibernate I have the exact same problem. When I try to connect to via wireless I get a eth1 not ready. rmmod'ing the module and re-adding it does not resolve the issue. Neither does restarting networking. Adding the STOP_SERVICES="networking" does resolve the issue.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers