[needs-packaging] Ethiopic true type fonts

Bug #68863 reported by teferra on 2006-10-28
12
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Sebastian Bator

Bug Description

This is a request to create "ttf-ethiopic" directory under http://archive.ubuntu.com/ubuntu/pool/main/t/ and include Ethiopic true type fonts.
The fallowing fonts are released under GPL or OFL.

WashRa 4.1:
http://www.senamirmir.org/projects/typography/washra.html

GF Zemen Unicode:
ftp://ftp.ethiopic.org/pub/fonts/TrueType/gfzemenu.ttf

Already in Ubuntu:
AbyssinicaSIL1.0.zip at http://www.sil.org/
or http://scripts.sil.org/cms/scripts/page.php?site_id=nrsi&id=AbyssinicaSIL_Download

Changed in malone:
status: Unconfirmed → Rejected
Nicolas Spalinger (yosch) wrote :

Abyssinica SIL is already available in Ubuntu : https://launchpad.net/ubuntu/+source/ttf-sil-abyssinica

The other fonts should go into separate packages.

GF Zemen Unicode seems to have problems with the licensing as described in the metadata. Could you contact upstream for clarification about licensing choices and embedding? The other fonts are under GPL + experimental font exception.

teferra (teferra) wrote :

All washera fonts are released under GPL: I am sure there is some technical reason but I am not clear on why they should go in to separate packages. I will try to contact the GF Zemen creators and clear up the licensing issue.

Arne Goetje (arnegoetje) wrote :

They should be packaged separately, because they come from different upstream sources. In general I find it easier to manage fonts if they separate packages, because if you pack multiple fonts into one package, then you force the users to always install all of them, even if the user only wants to use one.

As Hardy is already frozen, this is a target for Hardy+1.

summary: - Ethiopic true type fonts
+ [needs-packaging] Ethiopic true type fonts
description: updated
Martin Pool (mbp) on 2010-03-21
affects: malone → null
Sebastian Bator (eremit7) wrote :

I'am working on a package for the washra fonts.

Changed in ubuntu:
assignee: Arne Goetje (arnegoetje) → eremit7 (eremit7)
status: Confirmed → In Progress

eremit7 wrote:
> I'am working on a package for the washra fonts.

Thanks a lot!

Please consider putting the package under the
http://pkg-fonts.alioth.debian.org/ umbrella and become a member of that
team in debian. That way we have all fonts in a central place.

Cheers
Arne

Sebastian Bator (eremit7) wrote :

A short information on the progress: The technical site is complete (since a wile) and I will begin the procedure to get the package into Debian soon.

Eremit7

Johan Van de Wauw (johanvdw) wrote :

Perhaps you can share the package already on a ppa? Then interested
people can already use it!

On Thu, Aug 26, 2010 at 10:52 AM, eremit7 <email address hidden> wrote:
> A short information on the progress: The technical site is complete
> (since a wile) and I will begin the procedure to get the package into
> Debian soon.
>
> Eremit7
>
> --
> [needs-packaging] Ethiopic true type fonts
> https://bugs.launchpad.net/bugs/68863
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Sebastian Bator (eremit7) wrote :

Nice to see that there are people interested in this package, I will do that after I got some feedback in Debian.

Johan Van de Wauw (johanvdw) wrote :

Link to debian ITP (to keep bug status in sync)
http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=594587

Sebastian Bator (eremit7) wrote :

Hello, I added the package to my PPA:
https://launchpad.net/~eremit7/+archive/washera-ppa

I expect the package to be added to Debian soon.

Curtis Hovey (sinzui) on 2011-11-11
no longer affects: null
Changed in ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.