No sound in omap (beagle, beagleXM).

Bug #651302 reported by Tobin Davis on 2010-09-29
48
This bug affects 8 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Natty
Undecided
Unassigned
alsa-lib (Ubuntu)
Low
Unassigned
Natty
Low
Unassigned

Bug Description

By default, audio doesn't work on beagle platforms (Beagle C4, BeagleXM) unless alsa mixer controls are manually adjusted. Even then, pulseaudio consumes 70% cpuload as it can't map audio to the proper codec.

To enable audio, use alsamixer from a terminal and unmute 'HeadsetL Mixer AudioL2', and 'HeadsetR Mixer AudioR2', then volume can be controlled through 'DAC2 Analog' and 'Headset' volume controls. This will only enable audio to work without Pulseaudio.

To get pulseaudio working, a configuration file needs to be created and added to /usr/share/alsa/cards.

ProblemType: Bug
DistroRelease: Ubuntu 10.10
Package: linux-image-2.6.35-22-omap 2.6.35-22.33
Regression: No
Reproducible: Yes
ProcVersionSignature: User Name 2.6.35-22.33-omap 2.6.35.4
Uname: Linux 2.6.35-22-omap armv7l
AlsaVersion: Advanced Linux Sound Architecture Driver Version 1.0.23.
AplayDevices:
 **** List of PLAYBACK Hardware Devices ****
 card 0: omap3beagle [omap3beagle], device 0: TWL4030 twl4030-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0
Architecture: armel
ArecordDevices:
 **** List of CAPTURE Hardware Devices ****
 card 0: omap3beagle [omap3beagle], device 0: TWL4030 twl4030-0 []
   Subdevices: 1/1
   Subdevice #0: subdevice #0
CurrentDmesg:
 [ 742.562225] SGI XFS with ACLs, security attributes, realtime, large block/inode numbers, no debug enabled
 [ 742.604064] SGI XFS Quota Management subsystem
 [ 742.700164] JFS: nTxBlock = 1861, nTxLock = 14890
 [ 743.197052] NTFS driver 2.1.29 [Flags: R/O MODULE].
 [ 743.891784] QNX4 filesystem 0.2.3 registered.
Date: Wed Sep 29 09:48:49 2010
Lspci:
 Error: command ['lspci', '-vvnn'] failed with exit code 1: pcilib: Cannot open /proc/bus/pci
 lspci: Cannot find any working access method.
Lsusb:
 Bus 001 Device 005: ID 05d5:6781 Super Gate Technology Co., Ltd
 Bus 001 Device 004: ID 05dc:a731 Lexar Media, Inc.
 Bus 001 Device 003: ID 07a6:8511 ADMtek, Inc. ADM8511 Pegasus II Ethernet
 Bus 001 Device 002: ID 05e3:0608 Genesys Logic, Inc. USB-2.0 4-Port HUB
 Bus 001 Device 001: ID 1d6b:0002 Linux Foundation 2.0 root hub
ProcCmdLine: quiet splash ro elevator=noop vram=12M omapfb.mode=dvi:1280x720MR-16@60 root=UUID=ce0e8a39-e298-4958-8307-8e8cebd37525 fixrtc
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
SourcePackage: linux

Tobin Davis (gruemaster) wrote :
Tobin Davis (gruemaster) wrote :

Ignore lspci errors as there is no pci bus on this arm platform.

tags: added: iso-testing
tags: added: omap3
Jeremy Foshee (jeremyfoshee) wrote :

Hi Tobin,

If you could also please test the latest upstream kernel available that would be great. It will allow additional upstream developers to examine the issue. Refer to https://wiki.ubuntu.com/KernelMainlineBuilds . Once you've tested the upstream kernel, please remove the 'needs-upstream-testing' tag. This can be done by clicking on the yellow pencil icon next to the tag located at the bottom of the bug description and deleting the 'needs-upstream-testing' text. Please let us know your results.

Thanks in advance.

    [This is an automated message. Apologies if it has reached you inappropriately; please just reply to this message indicating so.]

tags: added: kj-triage
Changed in linux (Ubuntu):
status: New → Incomplete
Tobin Davis (gruemaster) wrote :

It was discovered yesterday that this is a regression from Lucid. More investigation needed.

I'm having a similar issue. Sound is not working by default , and changing the mixers to the ones stated earlier doesn't work either.

http://www.alsa-project.org/db/?f=49968cd5896a5aeee9a90507067e9df770492129

Thanks

Tobin Davis (gruemaster) wrote :

This bug should be revisited once alsa-1.0.24 is pulled in. The latest alsa includes UCM api for configuring SOC codecs in user space.

Changed in alsa-lib (Ubuntu):
milestone: none → natty-alpha-3
affects: linux (Ubuntu) → ubuntu
Changed in alsa-lib (Ubuntu):
importance: Undecided → Low
tags: added: regression-release
Martin Pitt (pitti) wrote :

Moving to beta-1, too late for alpha-3. Tobin, we do have alsa 1.0.24 now, is that working any better now?

Changed in alsa-lib (Ubuntu Natty):
assignee: nobody → Tobin Davis (gruemaster)
milestone: natty-alpha-3 → ubuntu-11.04-beta-1
Tobin Davis (gruemaster) wrote :

Well, once I get a working image based on 1.0.24 I (or someone else) can create a UCM configuration for this and get it into the image. First critical step was alsa 1.0.24 as it adds UCM support.

Tobin Davis (gruemaster) on 2011-03-10
tags: added: bitesize
Tobin Davis (gruemaster) wrote :

Moving to beta-2 as I just finished release testing beta-1 and no change.

Changed in alsa-lib (Ubuntu Natty):
milestone: ubuntu-11.04-beta-1 → ubuntu-11.04-beta-2
Tobin Davis (gruemaster) wrote :

Missed beta 2 freeze. Hope to get fixed post freeze.

Changed in alsa-lib (Ubuntu Natty):
milestone: ubuntu-11.04-beta-2 → ubuntu-11.04
Tobin Davis (gruemaster) on 2011-04-12
tags: removed: needs-upstream-testing ubuntu-une
Tobin Davis (gruemaster) on 2011-04-20
Changed in alsa-lib (Ubuntu Natty):
status: New → In Progress
Tobin Davis (gruemaster) wrote :

Retargeting for Natty Updates.

Changed in alsa-lib (Ubuntu Natty):
milestone: ubuntu-11.04 → natty-updates
Marietto (marietto2008) wrote :

I have the same problem. This is my environment :

root@omap:~# uname -a
Linux omap 3.0.4-x3 #1 SMP Wed Aug 31 05:51:34 UTC 2011 armv7l armv7l armv7l GNU/Linux

Tobin Davis (gruemaster) on 2011-11-21
Changed in alsa-lib (Ubuntu Natty):
assignee: Tobin Davis (gruemaster) → nobody
milestone: natty-updates → none
status: In Progress → Won't Fix
Tobin Davis (gruemaster) on 2012-01-28
Changed in alsa-lib (Ubuntu):
milestone: natty-updates → none
assignee: Tobin Davis (gruemaster) → nobody
dino99 (9d9) on 2013-05-18
Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers