KDM is installed on Edubuntu, resulting in an unwanted gconf question during upgrade

Bug #650615 reported by Jonathan Carter on 2010-09-28
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Release Notes for Ubuntu
Undecided
Unassigned
Ubuntu
High
Jonathan Carter

Bug Description

KDM is installed on a default Edubuntu system.

This results in an unwanted gconf question being asked choosing between gdm and kdm during upgrades.

tags: added: iso-testing
Jonathan Carter (jonathan) wrote :

It would probably be a good idea to add this to the release notes, we should let the user now that they should choose GDM when prompted.

Jonathan Carter (jonathan) wrote :

Some further information:

i plasma-scriptengine-javascript Depends libplasma3 (>= 4:4.5.1)
i kdebase-runtime Depends plasma-scriptengine-javascript (= 4:4.5.1-0ubuntu3)
i blinken Depends kdebase-runtime

i nautilus-sendto Suggests pidgin (>= 2.0.0) | gajim
p pidgin Suggests gnome-panel (>= 2.1) | kdebase-workspace-bin | docker
p kdebase-workspace-bin Depends plasma-desktop (= 4:4.5.1-0ubuntu8) | plasm a-netbook (= 4:4.5.1-0ubuntu8)
p plasma-netbook Recommends kdebase-workspace
p kdebase-workspace Recommends kdm (>= 4:4.5.1-0ubuntu8)

Changed in ubuntu:
milestone: none → natty-alpha-1
importance: Undecided → High
Jonathan Carter (jonathan) wrote :

The current proposed workaround for Natty alpha 1 is to conflict the KDE packages that are installed via recommends in the edubuntu-live package. This will prevent the excess of KDE packages to be installed, and still make it installable on the final system.

Changed in ubuntu:
assignee: nobody → Jonathan Carter (jonathan)
Scott Kitterman (kitterman) wrote :

What's pulling in kdebase-workspace?

Jonathan Carter (jonathan) wrote :

After digging around in a clean Maverick installation it turns out that this has been fixed in Maverick. This bug will still affect Lucid users who upgrade to Maverick, as mentioned in the release notes. For future releases it will not be a problem though. We will conflict hal, virtuoso-minimal, kubuntu-debug-installer and icoutils in edubuntu-live to prevent those necessary recommends from being installed.

Changed in ubuntu:
status: Confirmed → Fix Released
Changed in ubuntu-release-notes:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers