Inconsistency detected by ld.so

Bug #63222 reported by archville on 2006-09-30
36
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Linux Mint
Invalid
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

Hello.

I've installed Edgy Eft knot 3 about two weeks ago.
Today (as of sep 30 with all packages updated) noticed this error:

Inconsistency detected by ld.so: ../sysdeps/i386/dl-machine.h: 554: elf_machine_rel_relative: Assertion `((reloc->r_info) & 0xff) == 8' failed!

It shows up when i start xmms, xchat and some other programs.
I'm using the kernel: 2.6.17-10-generic

Edit:
It seems the prior kernel (2.6.17-9-generic) is not affected. I'll try to test it the next days.

Also, xchat and xmms are not the only apps that trigger the error message, as sometimes when the X.org is restarted they fail loading, showing the same error message.

Edit: (9 oct, 2006)
I can confirm this bug is now fixed with the latest updates for 2.6.17-10-generic, or at least i haven't experienced error messages anymore.

archville (archville) on 2006-09-30
description: updated
archville (archville) on 2006-10-09
description: updated
Revision history for this message
Alex Monteiro (a13x-ibest) wrote :

I have this problem with the final version of Edgy Eft.
When I try to start firefox:

alex@ubuntu:~$ firefox
Inconsistency detected by ld.so: dl-open.c: 610: _dl_open: Assertion `_dl_debug_initialize (0, args.nsid)->r_state == RT_CONSISTENT' failed!

but when I start again, this don't happen.

alex@ubuntu:~$ uname -a
Linux ubuntu 2.6.17-10-generic #2 SMP Fri Oct 13 18:45:35 UTC 2006 i686 GNU/Linux

Revision history for this message
Jean-Baptiste Lallement (jibel) wrote :

We appreciate the difficulties you are facing, but this version of Ubuntu (Edgy Eft) has reached end of life and is not supported anymore. So we are closing this report. If this is still an issue, can you try with latest Ubuntu release and re-open if needed ? Thanks in advance and don't hesitate to fill any new bug you may find.

Changed in ld.so:
status: New → Invalid
Revision history for this message
Nils Måsén (nilsmasen) wrote :

I have get the same error, running a fresh install of 9.10 whilst trying to run `wget`:

spaculo@spaculo-desktop:~$ wget
Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 460: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xffffffff) == 8' failed!

Changed in ld.so (Ubuntu):
status: Invalid → Incomplete
Revision history for this message
GroovyMotion (flywaver) wrote :

Same error msg here whn I start pidgin or emesene! Fresh install of Ubuntu 9.10 with all the updates!

Inconsistency detected by ld.so: ../sysdeps/i386/dl-machine.h: 628: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xff) == 8' failed!

Revision history for this message
Giuseppe Pennisi (giupenni78) wrote :

The same error when I start Firefox in Ubuntu 9.10.
Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 460: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xffffffff) == 8' failed!

Changed in ld.so (Ubuntu):
status: Incomplete → Confirmed
Revision history for this message
Blake Johnson (johnsonblake1) wrote :

Just ran update manager before heading to class this morning, everything working fine for about 2 weeks on this install until whatever updates hit this morning. Now:

laptop:~$ firefox
Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 460: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xffffffff) == 8' failed!

Ran in debug and got this info: Program exited with code 0177.

Linux laptop 2.6.31-17-generic #54-Ubuntu SMP Thu Dec 10 17:01:44 UTC 2009 x86_64 GNU/Linux

Revision history for this message
Dan Kegel (dank) wrote :

On ubuntu 9.10 386 desktop, updated, I got

Inconsistency detected by ld.so: dl-open.c: 256: dl_open_worker: Assertion `_dl_debug_initialize (0, args->nsid)->r_state == RT_CONSISTENT' failed!

once just now while building Chromium in Visual C++ 2005 in Wine.

Revision history for this message
Dan Kegel (dank) wrote :

Happened again later in the run. I should mention this is an 8 core machine,
and devenv.exe has seven cl.exe's spawned, so it's pretty busy.

Revision history for this message
Alexey Kotlyarov (koterpillar) wrote :

As far as I can tell, this breaks every possibility of upgrades: apt-get, aptitude, synaptic and update-manager are all affected. Dpkg is not, however.

Revision history for this message
Alexey Kotlyarov (koterpillar) wrote :

This seems to be a very un-informative message, so all these cases might as well be different bugs. For the record: my error was probably caused by pulling some packages from Lucid into Karmic - and solved by updating to Lucid's aptitude.

Revision history for this message
Ted Anderson (ota-surfvi) wrote :

This happened to me suddenly this morning (after resuming from standby) when starting Pidgin. The message differs trivially from those above:

% pidgin
Inconsistency detected by ld.so: ../sysdeps/i386/dl-machine.h: 640: elf_machine_rel_relative: Assertion `((reloc->r_info) & 0xff) == 8' failed!

% uname -a
Linux anapneo 2.6.32-29-generic #58-Ubuntu SMP Fri Feb 11 19:00:09 UTC 2011 i686 GNU/Linux

I am running Ubuntu Lucid 10.04.02 LTS. What other debugging data would be useful?

From this forum thread[1], I gather that the problem goes away after a while. Any idea how to trigger this improvement?

[1] http://ubuntuforums.org/showthread.php?t=1025896

Revision history for this message
Ted Anderson (ota-surfvi) wrote :

Tried running pidgin with ld debugging and found libsametime.so was corrupted.
    % LD_DEBUG=reloc pidgin
    ...
   5427: relocation processing: /usr/lib/purple-2/libsametime.so
    Inconsistency detected by ld.so: ../sysdeps/i386/dl-machine.h: 640: elf_machine_rel_relative: Assertion `((reloc->r_info) & 0xff) == 8' failed!

    % md5sum -c /var/lib/dpkg/info/libpurple0.md5sums
    ...
    usr/lib/purple-2/libqq.so: OK
    usr/lib/purple-2/libsametime.so: FAILED
    usr/lib/purple-2/libsilcpurple.so: OK
    ...
    md5sum: WARNING: 1 of 54 computed checksums did NOT match

Rebooted (ran fsck, which didn't find any significant problems) and the
problem went away. The same md5sum command, no shows no problems. This
suggests some kind of memory/cache corruption of libsametime.so, but
that's disturbing.

Revision history for this message
Phillip Susi (psusi) wrote :

Indeed, this all looks like corrupt files. Anyone still affected by this, please verify the md5sums.

affects: ld.so (Ubuntu) → ubuntu
Changed in ubuntu:
status: Confirmed → Incomplete
Revision history for this message
Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

Changed in ubuntu:
status: Incomplete → Expired
Revision history for this message
Rahul Ghose (rahulg) wrote :

This bug affects me as well.

Changed in ubuntu:
status: Expired → Confirmed
Revision history for this message
Rahul Ghose (rahulg) wrote :

This happens when I try to run chromium-browser.

Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 460: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xffffffff) == 8' failed!

By the way, looks like a resume after suspend bug. I had my laptop in suspended mode.

I found this: http://bugs.debian.org/cgi-bin/bugreport.cgi?bug=574657

Revision history for this message
Rahul Ghose (rahulg) wrote :

This is my specs:

Linux 3.5.0-36-generic #57-Ubuntu SMP Wed Jun 19 15:10:49 UTC 2013 x86_64 x86_64 x86_64 GNU/Linux

Distributor ID: LinuxMint
Description: Linux Mint 14 Nadia
Release: 14
Codename: nadia

The last time I used my latop was 2 days ago. This is a work laptop. I guess, the problem will go if I reboot, but that is something I rarely do.

Revision history for this message
chemicalfan (mike-lumsden) wrote :

Does this bug apply to any of the currently supported releases (i.e. Maya, Petra or Qiana)? If not, this bug should be closed.

Revision history for this message
darkenk (darkenk) wrote :

I can confirm this on ubuntu 14.04 with custom application.
Kernel: 3.13.0-30-generic #54-Ubuntu SMP Mon Jun 9 22:45:01 UTC 2014 x86_64 x86_64 x86_64 GNU/Linux

It seems that bug occure after wake up from suspend. Rebooting system solve problem. Does anyone know the root cause or workaround for that issue?

Revision history for this message
vinay bhargav (vinstheking) wrote :

Hi, I'm facing similar problem on 12.04, 64 bit system while starting firefox. Exact error message -

Inconsistency detected by ld.so: ../sysdeps/x86_64/dl-machine.h: 460: elf_machine_rela_relative: Assertion `((reloc->r_info) & 0xffffffff) == 8' failed!

Recently my firefox started crashing just after waking up from suspend. Problem could be with suspend.

I usually get "refresh rate error message" while waking up from suspend. But it did not cause any real problem until now. I don't know what exactly is the problem. I'm trying to find a fix. I'll post here if something works :)

Revision history for this message
vinay bhargav (vinstheking) wrote :

Restarting ubuntu has brought back my firefox to normal state.

Changed in linuxmint:
status: New → Confirmed
Revision history for this message
Phillip Susi (psusi) wrote :

I'm closing this since it is just a disk or memory corruption issue. If it is memory, then a reboot should clear it. If it is disk, then reinstalling the affected package should fix it.

Changed in ubuntu:
status: Confirmed → Invalid
Changed in linuxmint:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.