no graphic with hd 5670 Graphic Card

Bug #600351 reported by K Dietrich on 2010-06-30
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When I upgraded my system with a Saphier HD 5670 graphic card, the Monitor goes in powersave mode during boot. I assume this happens when the system switches to graphics mode.

Maybe this is related to my motherboard ASRock A780 Full HD with HD 3200 onboard graphic which can't be diisabled.
The output of the internal graphic is off too.

The Problems occurs both wiht Onboard Graphics AND with PCIE Graphic set as primary Adapter.

I tried a clean re-Install of Kubuntu 10.04 386. The CD has the same problem when booting from it.
Install by alternate Installer is possible, but after first boot from Diisk, the same problem occurs.

The System iis not frozen, pushing the power button when screen is off performs a graceful shut down.

klog says:
(EE) RADEON(0): Acceleration initialization failed
..
KCrash: Application 'kdmgreet' crashing...
error setting MTRR (base = 0xd0000000, size = 0x10000000, type = 1) Inappropriate ioctl for device (25)
 ddxSigGiveUp: Closing log
drkonqi: cannot connect to X server :0.0

I attached syslog, udev and kdm logfile

K Dietrich (kdietrich) wrote :
K Dietrich (kdietrich) wrote :

I was able to fix my system using the repair console of the alternate installer disk.

after opening the console on the linux partition I did

apt-get install fglrx
aticonfig --initial -f

afterwards I was able to boot.
I believe this is not the perfect way. I got some dev packages installed with "apt-get install fglrx"
Acceleration was not running.
The GUI for Installing proprietary drivers diid not show the fglrx as installed. It did allow to install the fglrx. After booting acceleration worked.

Attached is the Xorg.0.log file for all three sges.

Hello!
I am Aleksandra, 26 yo.
Are you ready to be my boyfriend and to start big friendship?
March is the best time for this :)
wish you good spring time this year!

please check my new photos and message for you here:

http://ruhotladies.ru

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers