Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL

Reported by Larry Martin on 2010-05-16
40
This bug affects 6 people
Affects Status Importance Assigned to Milestone
Wubi
Undecided
Unassigned
Ubuntu
Undecided
Unassigned

Bug Description

I am NOT a developer so don't expect any technical stuff from me.

Ubuntu 10.4 64bit drops to a BusyBox v1.13.3 / Initramfs Shell - won't boot up AT ALL. I downloaded Ubuntu 10.4 via the Wubi installer SEVERAL, SEVERAL, SEVERAL, SEVERAL TIMES. Each time I've done so (and I've done it almost a dozen (12) times) I get the same results. I get the SAME DARN error msg which is:

Alert! /host/ubuntu/disks/root.disk does not exist

Dropping to a shell

BusyBox v1.13.3

This happens will both Kernels (2.6.32-21) and (2.6.32-22)

Even after I try to do a recovery the same thing happens.

I have 64Bit Dual Core AMD PC. bought it brand new about a year ago.

I've used Ubuntu for several years now. I am TOTALLY disgusted w//10.4 and can't help wonder if this is THE RESULT OF MARK SHUTTLEWORTH STEPPING DOWN AS CEO?

I am not going to recommend Ubuntu to friends and family any more!!

I am so put out by this sloppy version (10.4) I am going to either switch BACK TO 9.10 or go w/Fedora or SUSE.

GET IT FIXED. I AM ASHAMED OF YOU ALL!

Larry Martin (larry-martin) wrote :

Also, I've noticed a few other people are having the same problems. I googled the error msg. and got a few hits on the web showing I am not alone.

Also, I downloaded 10.4 Kubuntu AND DID NOT HAVE ANY SUCH PROBLEMS. I just don't like the KDE desktop experience. I uninstalled it. I now regret that.

Larry Martin (larry-martin) wrote :

Same thing just now happened when I installed Xubuntu via the wubi-installer.

Here is a more thorough, accurate description of the bug:

Alert! /host/ubuntu/disks/root.disk does not exist

Dropping to a shell

BusyBox v1.13.3 (Ubuntu 1:1.13.3-1ubuntu1) built in shell (ASH)
enter 'help' for a list of commands

(initramfs)

Thank you for your bug report. To maintain a respectful atmosphere, please follow the code of conduct - http://www.ubuntu.com/community/conduct/ . Bug reports are handled by humans, the majority of whom are volunteers, so please bear this in mind.

It looks like your problem is related to the fact that the system is installed from Wubi. Can you confirm this by trying to run Ubuntu from a live CD or a live USB key? Can you give us a few clues about the way your computer is installed: operating systems, partitions, etc. ? Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
Changed in wubi:
status: New → Incomplete
Changed in ubuntu:
status: Incomplete → Invalid

Okay. Understand about the Code of Conduct. Sorry for my crassness and
blunt anger. I just believe that 10.4 was release w/such an obvious serious
bug. Some other people have had the same problem from my googling it.

Have been using Ubuntu for several years. I initially upgraded to 10.4 from
w/in Ubuntu 9.04 via the notification of a new version, "would you like to
upgrade" option. It installed and ran fine for only one (1) session. Then
after that I imediately had the "no root disk found, dropping to a shell"
error msg.. every time I would try to boot up.

So, I uninstalled Ubuntu from Windows 7 Home Premium (64Bit) via the
Uninstall App Option w/in the Control Panel of Windows 7. Then I download
from Wubi 10.4 and installed it again. It installed at least initially w/no
problems and it boot up. Then it got some updates. Then it started to NOT
BOOT UP due to the same ole' "No root disk found, dropping to a shell" error
msg.

I am using a 64 Bit dual Core AmD PC w/a on a SATA 3.0 H/D w/4GB of SDRAM.
The PC is only a year old.

Larry Martin
AUSTIN, tx

--------------------------------------------------
From: "Philippe Gauthier" <email address hidden>
Sent: Monday, May 17, 2010 1:58 PM
To: <email address hidden>
Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs
shell -WON'T BOOT UP AT ALL

> Thank you for your bug report. To maintain a respectful atmosphere,
> please follow the code of conduct -
> http://www.ubuntu.com/community/conduct/ . Bug reports are handled by
> humans, the majority of whom are volunteers, so please bear this in
> mind.
>
> It looks like your problem is related to the fact that the system is
> installed from Wubi. Can you confirm this by trying to run Ubuntu from a
> live CD or a live USB key? Can you give us a few clues about the way
> your computer is installed: operating systems, partitions, etc. ? Thanks
> in advance.
>
> ** Changed in: ubuntu
> Status: New => Incomplete
>
> ** Also affects: wubi
> Importance: Undecided
> Status: New
>
> ** Changed in: wubi
> Status: New => Incomplete
>
> ** Changed in: ubuntu
> Status: Incomplete => Invalid
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.
>

Thanks Larry! For some reason, it seems that Ubuntu installed over Windows is not able to boot if the disk is "dirty", meaning that the shutdown was done improperly. It is possible to fix that by logging into Windows and running "chkdsk /r". I don't have a Windows system to test that, so I will mark this bug as open and affecting Wubi hoping that someone else can pick up this bug report.

Changed in wubi:
status: Incomplete → New

Okay. Thx. for the followup and for the tip. I will try that.
Larry

> Date: Mon, 17 May 2010 20:19:13 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> Thanks Larry! For some reason, it seems that Ubuntu installed over
> Windows is not able to boot if the disk is "dirty", meaning that the
> shutdown was done improperly. It is possible to fix that by logging into
> Windows and running "chkdsk /r". I don't have a Windows system to test
> that, so I will mark this bug as open and affecting Wubi hoping that
> someone else can pick up this bug report.
>
> ** Changed in: wubi
> Status: Incomplete => New
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
The New Busy think 9 to 5 is a cute idea. Combine multiple calendars with Hotmail.
http://www.windowslive.com/campaign/thenewbusy?tile=multicalendar&ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_5

Aaron (aaron-fd) wrote :

Hi,
I am glad to find here that somebody else had the same issue before me.

I have to say that i am having the same problem described above but i did not install ubuntu 10.4 from wubi. I booted ubuntu from a live cd and installed it from there. After that, when choosing Ubuntu from GRUB i get the message of BusyBox 1 13 3.

I hope this info helps you to find out the cause of the problem.

Regards!
Aaron

Changed in ubuntu:
status: Invalid → New
bl.main72@gmail.com (bl-main72) wrote :

Hi
I meet the same issue
I was upgrading a 2.6..31-21 (karmic ) to 2.6.32-22 system ( lucid )
I was on a GUI Gnome interface
I did the upgrade using a terminal
I wrote sudo do-release-upgrade
The restart was ok
So I did a shutdown
But after restarting it I have had this issue
I did a test integrity disk
the boot part looked to need to be fixed
I did it
then after a Touch /forcefsck
then a reboot
It look to works well
Unfortunatly, the usal user of this computer let it in hibernation mode or sleep mode
When the user try to wake up the system she has once again the busybox message.
So i try again with touch /forcefsck
the reboot
But the system still go on the issue
Do you have any idea solve this ?

Thanks for your help

Changed in ubuntu:
status: New → Invalid
Larry Martin (larry-martin) wrote :

No, I am not a developer. I just know a few terminal commands, that's about it. To tell the truth, I've kind of lost interest in Linux and Ubuntu. I do support it and respect it, however. After Windows 7 came out, I started using Windows again as well my Mac.
I don't really have more time to waste. Since you & I corresponded last, I downloaded 10.4 AGAIN via the wubi-installer website and installed it on my EIDE H/D which has Vista 32bit on it. It installed fine and booted up fine once. Then after I got a bunch of updates, I got A DIFFERENT, BUT SIMILAR ERROR MSG - something about not finding the root directory. Now it won't boot up at all.
 Whatever happened, it really goofed up my EIDE H/D because the next time I booted it, it automatically went into a CHKDSK and found SEVERAL, SEVERAL PROBLEMS - all of which it was able to fix, THANK GOD.
After that, I said no more. I can't believe Canonical has released 10.4 w/no so many, what I consider, serious bugs. Its HORRIBLE!
I might try Ubuntu again when 10.10 comes out. Until then, you can forget about it.
Larry MartinAustin, TX

> Date: Mon, 24 May 2010 16:26:14 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> Hi
> I meet the same issue
> I was upgrading a 2.6..31-21 (karmic ) to 2.6.32-22 system ( lucid )
> I was on a GUI Gnome interface
> I did the upgrade using a terminal
> I wrote sudo do-release-upgrade
> The restart was ok
> So I did a shutdown
> But after restarting it I have had this issue
> I did a test integrity disk
> the boot part looked to need to be fixed
> I did it
> then after a Touch /forcefsck
> then a reboot
> It look to works well
> Unfortunatly, the usal user of this computer let it in hibernation mode or sleep mode
> When the user try to wake up the system she has once again the busybox message.
> So i try again with touch /forcefsck
> the reboot
> But the system still go on the issue
> Do you have any idea solve this ?
>
> Thanks for your help
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

_________________________________________________________________
Hotmail is redefining busy with tools for the New Busy. Get more from your inbox.
http://www.windowslive.com/campaign/thenewbusy?ocid=PID28326::T:WLMTAGL:ON:WL:en-US:WM_HMP:042010_2

Larry Martin (larry-martin) wrote :

Whoever is overseeing this bug. I believe you may have misunderstood one very key point. The VERY FIRST time I had this problem of it dropping to busybox shell happened after I opted for the upgrade to 10.4 FROM IN 9.10.

I was using 9.10 and the Update Mgr. notified me that 10.4 was out and would I like to upgrade to 10.4. i did the upgrade from w/in 9.10. It installed fine and booted up once fine w/no problems. I got a bunch updates immediately. The next it booted up I got the "dropping to a shell, busybox / initramfs error msg. It not only happened when I did it from wubi-installer but also from w/in 9.10 via the UPDATE MGR.

I only used the wubi-installer after the "automatic update to 10.4" option w/in 9.10.

Larry Martin (larry-martin) wrote :

I really don't care to participate anymore. Windows 7 & Mac 10.6 meet all my needs. I may try Fedora later on. I may just wait till 10.10 comes out. Maybe at least at time, 10.4 will be usable. I am TOTALLY disgusted w/Ubuntu after using it for a good number of years. Something happened after Mark Shuttleworth stepped down as CEO of Canocial.

No need to send me any more updates on this bug. I've got more pressing matters to tend to than to waste anymore time.

Aaron (aaron-fd) on 2010-06-10
Changed in ubuntu:
status: Invalid → New
MightyPork (mighty-pork) wrote :

Hi, I have the same problem too, and I DID NOT use Wubi or anything else, I've just installed some updates for my Kubuntu 10.04 (including some kernel updates) and after shutdown I was unable to boot again due to this error. I didn't get any info about the bug at all.

I'm really disappointed (note that I've just migrated to Kubuntu from Mandriva) and I seriously think about changing OS again, because Kubuntu is full of bugs these days (before this issue I've noticed some other bugs such as not-working logout, sleep mode and hibernation mode, broken main KDE menu editor, some bugs in package manager etc.). Now I hope I'll find at least one properly working distro.

robtreed (robt4reed) wrote :

I had no trouble with Ubuntu 10.04 and this bug, however after installing
Ubuntu 10.10 Alpha 2 on second drive I get similar type of message that Larry Martin.

"{Alert! /host/ubuntu/disks/root.disk b3674ec4-xxx....... does not exist

  Dropping to a shell

  BusyBox v1.13.3 (Ubuntu xxxxxxx.....1) built in shell (ASH)
  enter 'help' for a list of commands

  (initramfs)}"

I also receive a disk read time out error.

I found that by waiting at initramfs prompt until machine is not active (Light Off) and typing "exit" machine will boot from drive. (one that says it can not find)

Robert Reed

AJenbo (ajenbo) on 2010-08-09
Changed in ubuntu:
status: New → Invalid
wes wa (weswada) wrote :

Looks like I've been nailed by the same bug as well.

After 3 months of getting 10.04 wubi working with all my customizations (wine, compiz, etc.), i did an update, and then reboot and unable to boot.

http://ubuntuforums.org/showthread.php?t=1558343

I'm not about to go thru all that effort again.

Back to XP for me as well.

Let's hope Manic Monkey, or whatever they call the next release, is much better tested.

I understand. Thx. for letting me know I wasn't the only person struck by the same bug/flaw in Ubuntu 10.4 via the WUBI app.
I am back to using Mac OS X & Windows 7. Speaking of XP, I can tell you its not as good as Windows 7. XP is stable but as you probably already know, XP is the #1 targeted O/S by Bad Guy Hackers WORLDWIDE. XP is the primary target on their Radar screen. Windows 7 & Vista (for that matter) have a few built security features w/in the kernel itself that XP does not have.
Larry

> Date: Tue, 24 Aug 2010 17:21:08 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> Looks like I've been nailed by the same bug as well.
>
> After 3 months of getting 10.04 wubi working with all my customizations
> (wine, compiz, etc.), i did an update, and then reboot and unable to
> boot.
>
> http://ubuntuforums.org/showthread.php?t=1558343
>
> I'm not about to go thru all that effort again.
>
> Back to XP for me as well.
>
> Let's hope Manic Monkey, or whatever they call the next release, is much
> better tested.
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

lengoanhcat (lengoanhcat) wrote :

I do have the same problem stated above. It can be solved for my case when a new kernel is upgraded for ubuntu. It means that I can boot into my Ubuntu 10.04 64 bit fine. But I still happens If I want to boot up the recovery mode. Is there any permanent solution to remove this bug out of Ubuntu Lucid ?

Larry Martin (larry-martin) wrote :

Thx. 4 the email. Glad to hear that you found a partial solution by way of a new kernel. I don't know of any permanent solution to remove the bug. I am not a developer, just an end-user. I now use Ubuntu by way of it installed BY ITSELF on hard drive. I have not, nor do plan to use the WUBI installer ever again. It cost me a lot. My version of Windows 7 had to be removed off the H/D. I can reinstall Windows 7, its just a pain in the butt. Forunately, I have all my personal files (music, photos, bookmarks, etc.) on my Mac and a external H/D.
Larry Martin

> Date: Fri, 1 Oct 2010 10:34:45 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> I do have the same problem stated above. It can be solved for my case
> when a new kernel is upgraded for ubuntu. It means that I can boot into
> my Ubuntu 10.04 64 bit fine. But I still happens If I want to boot up
> the recovery mode. Is there any permanent solution to remove this bug
> out of Ubuntu Lucid ?
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

Logan John (logan-2k6) wrote :

Hi,

I keep having the same problem with wubi since before 10.04

Actually i think with last update that was available for last ubuntu 9.x.

Ofcourse i couldnt solve the problem but i found something about it after playing with grub/busybox shell

it seems that the grub and the busybox has different hard drive mapping (hd0 in grub is something like sde in busybox) although Im not sure if there is a file that associiate sdXX with hdXX (i notice that opensuse has one)...if it has then this theory is not good :)
also in busybox if i do ls /host i get another hard drive than the hdd with windows/ubuntu

Logan John (logan-2k6) wrote :

hahaha now this one is unbelievable

open your grub.cfg with some editor

and on your linux /boot/blablabla line remove quiet splash from the end of the line.

It works for me...maybe it will work for u too

DaJMart (danmartinj) wrote :

Hey All,

I have been dealing with this problem for a couple of weeks now. When the OS boots up it is great, but when it is hanging with this busybox issue it is a nightmare.

It seems the main trend is if there is a hard shutdown the box always enters this busybox problem.
Currently, my system has been down for 3 hours and It confuses me since it is all so random.

Is there a solid fix for this bug?

What are most people doing to get around this?

I am starting to think another OS is the only rational choice.

I gave up. Now using my Mac & Win7 PC.

Sent from my Samsung Captivate(tm) on AT&T

DaJMart <email address hidden> wrote:

>Hey All,
>
>I have been dealing with this problem for a couple of weeks now. When
>the OS boots up it is great, but when it is hanging with this busybox
>issue it is a nightmare.
>
>It seems the main trend is if there is a hard shutdown the box always enters this busybox problem.
>Currently, my system has been down for 3 hours and It confuses me since it is all so random.
>
>Is there a solid fix for this bug?
>
>What are most people doing to get around this?
>
>I am starting to think another OS is the only rational choice.
>
>--
>Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>https://bugs.launchpad.net/bugs/581157
>You received this bug notification because you are a direct subscriber
>of the bug.
>

I just gave up and switched back to my Mac & Win7 PC.

> Date: Thu, 11 Nov 2010 10:16:29 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> Hi,
>
> I keep having the same problem with wubi since before 10.04
>
> Actually i think with last update that was available for last ubuntu
> 9.x.
>
> Ofcourse i couldnt solve the problem but i found something about it
> after playing with grub/busybox shell
>
> it seems that the grub and the busybox has different hard drive mapping (hd0 in grub is something like sde in busybox) although Im not sure if there is a file that associiate sdXX with hdXX (i notice that opensuse has one)...if it has then this theory is not good :)
> also in busybox if i do ls /host i get another hard drive than the hdd with windows/ubuntu
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

Andrew (andrew-p-burton) wrote :

Try reinstalling 10.10 fresh using wubi

Larry Martin (larry-martin) wrote :

I might. Thx. for the suggestion.
Larry

> Date: Sun, 14 Nov 2010 22:35:57 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> Try reinstalling 10.10 fresh using wubi
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

10.10 is not any better with Windows 7 as near as I can tell. I think installing on a partition would be much easier. I only wanted wubi for cross platform read and write between hard drive. There seems to be always way more trouble with linux being compatible with NTFS than Windows reading the ext2 ext3 + drives.

Larry Martin (larry-martin) wrote :

I TOTALLY AGREE. I am now very "gun shy" of using Wubi. It burned me last time. Something went terribly wrong starting w/10.4 regarding the wubi installer. Initially, the ubuntu bug team said that they didn't see any problem and even closed my bug report as being invalid. Then I started getting emails from other wubi users who experience either same thing or something very close.
It will be a long time before I venture to try wubi again. Thx. for your email. I take comfort in knowing that I wasn't just "imagining" all of this. The bug is real.

Larry

> Date: Sun, 28 Nov 2010 03:30:42 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> 10.10 is not any better with Windows 7 as near as I can tell. I think
> installing on a partition would be much easier. I only wanted wubi for
> cross platform read and write between hard drive. There seems to be
> always way more trouble with linux being compatible with NTFS than
> Windows reading the ext2 ext3 + drives.
>
> --
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
> https://bugs.launchpad.net/bugs/581157
> You received this bug notification because you are a direct subscriber
> of the bug.

Fernando Lozano (flozan) wrote :

take it easy, my friend. do you know the power of the simple?
try the following:
start your machine with a live cd (10.04 for example). check install option. use the manual partition option in order to choose the partition were your problem is (I mean the hdd that does not work). In my case, es hda1 and also the starter (83 id)
follow instructions (mount in the same point you already had) In my case " / ". don't check format opcion but select the file extension you use (in my case ext4) click next and before begin to do anything, cancel the process. Exit. Expulse your live cd and restart. You will see how everything is again as the begining.
my problem was the same as your but using 10.10 in hd1, 10.04 in hd5 and I used a 10.04 lucyd live CD to do what I had just explained.
Hope to help you and future users. Probably everything was because of a run out battery whith a pen inside usb. I restarted and probably in a wrong way. Note: I am a use, not a programer nor developer and have no idea of linux commands and so on, but I believe and use sense common.
Best regards.

Larry Martin (larry-martin) wrote :

Thank you very much for your help and kind words.
Larry

> Date: Mon, 17 Jan 2011 23:24:21 +0000
> From: <email address hidden>
> To: <email address hidden>
> Subject: [Bug 581157] Re: Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT ALL
>
> take it easy, my friend. do you know the power of the simple?
> try the following:
> start your machine with a live cd (10.04 for example). check install option. use the manual partition option in order to choose the partition were your problem is (I mean the hdd that does not work). In my case, es hda1 and also the starter (83 id)
> follow instructions (mount in the same point you already had) In my case " / ". don't check format opcion but select the file extension you use (in my case ext4) click next and before begin to do anything, cancel the process. Exit. Expulse your live cd and restart. You will see how everything is again as the begining.
> my problem was the same as your but using 10.10 in hd1, 10.04 in hd5 and I used a 10.04 lucyd live CD to do what I had just explained.
> Hope to help you and future users. Probably everything was because of a run out battery whith a pen inside usb. I restarted and probably in a wrong way. Note: I am a use, not a programer nor developer and have no idea of linux commands and so on, but I believe and use sense common.
> Best regards.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/581157
>
> Title:
> Ubuntu 10.4 drops to a BusyBox / Initramfs shell - WON'T BOOT UP AT
> ALL

Espinoza (goroman) wrote :

Hi everybody, I am having the same problem and I really don't want to loose all my data.
I have been using ubuntu for more than a year and I haven't have this error before.

FERNANDO LOZANO could you please tell me where to check install option? and how to use the manual partition you mention.

As you can see I have no knowledge at all. Hope you can help me... I have been at other forums with people with the same case and no real solutions... Be the man...

Thanks

mitchell scholz (hxcmole) wrote :

I decided to use wubi and use Ubuntu 10.10 with Win 7 and It's been problem after problem. I've reinstalled at least 5 times and I keep getting the same problem. I've looked at some other blogs saying that a partition and CD install will work but after everything that I've read IDK anymore.

bcbc (bcbc) wrote :

There've been a number cases of this particular error. There may be different causes but the ones I have seen are not wubi-specific: sometimes when the kernel is updated the initial ram disk is not generated correctly. You can tell If this is the problem by booting a previous kernel - if it works then it's got nothing to do with a corrupt root.disk or unclean ntfs etc.

Once you've booted from the old kernel, you can rebuild the initrd.img on the latest kernel:
sudo update-initramfs -u -k <latest_kernel_release>

If you only have one kernel, then you have to chroot into it to rebuild the initrd.img which is more complex for Wubi.

Lately, most wubi problems are related to bad grub updates: https://wiki.ubuntu.com/WubiGuide#Warning

Tiago G. (ozulus) wrote :

I believe I have the same problem. I have tried to install ubuntu 10.04 and 10.10 32 and 64 via Wubi and I always get the following errors and then drop onto BusyBox:

"Cannot mount /dev/sda on /tmpmountpoint".

It's a Asus EeePC 1201N (Atom 330, nVidia ION), I tried installing wubi on both windows partitions, I used chkdsk to make sure it was clean. The Windows version used is Windows 7 64bit.

If you need any additional details please let me know.

Thanks in advance.

Doug Lomax (dlomax11) on 2013-02-27
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers