Networking disabled after a failed hibernate

Bug #579941 reported by Davor Cubranic on 2010-05-13
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I upgraded to KUbuntu Lucid by a clean install from the CD to the root partition (keeping the home), which worked fine for a couple of days. A couple of days ago, I had to reboot after a hibernate locked up, and I didn't have the network connection any more.

The network card is detected fine (see lshw output below), and I can turn on the networking manually if I add "iface eth0 inet dhcp" line to /etc/interfaces. I'd rather handle it through the NetworkManager because of better integration (Firefox, for instance, insists on starting offline this way), but NM just does not want to manage the interface.

Ashutosh Rishi (ashutoshrishi) wrote :

The network connection (for DHCP) should be either be allowed to automatically get configured through the 'Network Connections GUI' OR by including:

auto ethX
iface ethX inet dhcp

where X is replaced by your preferred network card's number. Not both.

Davor Cubranic (cubranic) wrote :

Ashutosh, why do you think anything was done through the Network Connections GUI?

To be clear: I did a straightforward install from a KUbuntu Lucid CD, formatting my root partition first. Other than picking my timezone and partitions to format, I picked installer's defaults. The network connection then worked fine for over a week, during which I updated the installed packages at least once. Then a few days ago it stopped working. While trying to fix the problem, I realized that /etc/network/interfaces only contained the definition for loopback, and restored my network access by adding eth0 to this file. I didn't try fixing the problem via the GUI, because I didn't know about it. At any rate, something caused my network configuration to be lost, wherever it is defined by default -- in the GUI or /etc/network/interfaces.

Ashutosh Rishi (ashutoshrishi) wrote :

I had almost the same problem. Searching around for it I came upon this:

Ashutosh Rishi (ashutoshrishi) wrote :

(sorry I pressed post by mistake)
1) Ensure that the /etc/network/interfaces file has no 'auto eth0..' only 'auto lo'. Then create a new connections through 'Edit Connections' and enter the mac address and keep ipv4 to 'Automatic (DHCP)'. At first it didn't work, but later it did.

But before that even I edited my interfaces file to add 'auto eth0...'. Connection was done properly but then something was wrong with the network connection panel applet (it did not show no matter what I did).
I did what I was told (i.e point 1) and the connection was still proper and the applet was proper.

The main point I kept reading was that it is recommended to try connecting using the applet rather than editing the interfaces file. So I thought I would share that.

Davor Cubranic (cubranic) wrote :

Aha, thank you, I didn't realize that you had the same problem and that going through the GUI was the recommended way.

Either way, whatever was done by default worked fine until some package upgrade messed it up.

Davor Cubranic (cubranic) wrote :

I read a bit about the current network interface management system and compared my setup with another Lucid install where networking works fine. Ashutosh, you're correct: my /etc/network/interfaces should not contain a line about eth0, Network Manager should pick up the hardware and activate it automatically. So why doesn't it? And, if 'ifup' and /etc/network/interfaces is the old way of doing things, what is the correct way?

Here is the output of lshw, when the computer is started without 'eth0' in /etc/network/interfaces:

$ sudo lshw -c network
  *-network DISABLED
       description: Ethernet interface
       product: NetLink BCM5789 Gigabit Ethernet PCI Express
       vendor: Broadcom Corporation
       physical id: 0
       bus info: pci@0000:02:00.0
       logical name: eth0
       version: 11
       serial: 00:30:1b:b9:70:1c
       capacity: 1GB/s
       width: 64 bits
       clock: 33MHz
       capabilities: pm vpd msi pciexpress bus_master cap_list ethernet physical tp 10bt 10bt-fd 100bt 100bt-fd 1000bt 1000bt-fd autonegotiation
       configuration: autonegotiation=on broadcast=yes driver=tg3 driverversion=3.102 duplex=half firmware=5789-v3.29a latency=0 link=yes multicast=yes port=twisted pair
       resources: irq:18 memory:dfef0000-dfefffff

Why would it be disabled? After I explicitly activate eth0 with 'ifup', 'lshw network' does not show it as 'DISABLED' any more. What do I need to do to boot up enabled?

Davor Cubranic (cubranic) wrote :

According to a thread in the forum (http://ubuntuforums.org/showthread.php?t=1491242&highlight=eth0+network+manager), my disabled networking was probably caused after a hibernate locked up the machine and I had to physically reboot it. Unfortunately, the solution in the thread is for Ubuntu, not KUbuntu which is what I'm running.

description: updated
summary: - Upgrade removes eth0 from /etc/network/interfaces
+ Networking disabled after a failed hibernate
Davor Cubranic (cubranic) wrote :

This seems a duplicate of bug #524565, and caused by Debian issue 566891 (Network Management disabled after "suspend to ram"), http://osdir.com/ml/debian-bugs-dist/2010-01/msg07864.html.

As suggested there, running

service network-manager stop
rm /var/lib/NetworkManager/NetworkManager.state
service network-manager start

fixed the problem for me.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers