Mobile broadband Huawei E1550 not working

Bug #574119 reported by gavin on 2010-05-03
14
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I have a usb Huawei e1550 mobile broadband modem from Starhub in SIngapore. This device worked fine under 9.10 but after upgrading to 10.04 the latest release fully patched this device is no longer detected as a mobile broadband modem. It is detected as a mass storage device as it also contains a micro sd card but the modem functionality isn't. Attached is dmesg output.

In 9.10 the device was detected and under networks a Mobile Broadband option was available. Under 10.04 no additional network device is available.

Hardware is a Dell Latitude d430

dmesg output
[ 2765.103998] bridge-eth2: disabling the bridge
[ 2765.112142] bridge-eth2: down
[ 2765.112161] bridge-eth2: detached
[ 2765.779483] /dev/vmnet: open called by PID 1096 (vmnet-bridge)
[ 2765.779509] /dev/vmnet: hub 0 does not exist, allocating memory.
[ 2765.779563] /dev/vmnet: port on hub 0 successfully opened
[ 2765.779591] bridge-eth2: is a Wireless Adapter
[ 2765.779600] bridge-eth2: up
[ 2765.779724] bridge-eth2: attached
[ 2766.410343] usb 1-6: USB disconnect, address 4
[ 2767.238513] scsi 4:0:0:0: rejecting I/O to dead device
[ 3034.020189] usb 1-6: new high speed USB device using ehci_hcd and address 5
[ 3034.163953] usb 1-6: configuration #1 chosen from 1 choice
[ 3034.168099] scsi6 : SCSI emulation for USB Mass Storage devices
[ 3034.168542] usb-storage: device found at 5
[ 3034.168548] usb-storage: waiting for device to settle before scanning
[ 3034.168617] scsi7 : SCSI emulation for USB Mass Storage devices
[ 3034.168912] usb-storage: device found at 5
[ 3034.168916] usb-storage: waiting for device to settle before scanning
[ 3039.167257] usb-storage: device scan complete
[ 3039.168832] usb-storage: device scan complete
[ 3039.171591] scsi 7:0:0:0: Direct-Access HUAWEI MMC Storage 2.31 PQ: 0 ANSI: 2
[ 3039.171666] scsi 6:0:0:0: CD-ROM HUAWEI Mass Storage 2.31 PQ: 0 ANSI: 2
[ 3039.174465] sd 7:0:0:0: Attached scsi generic sg1 type 0
[ 3039.189886] sd 7:0:0:0: [sdb] Attached SCSI removable disk
[ 3039.196997] sr1: scsi-1 drive
[ 3039.197229] sr 6:0:0:0: Attached scsi CD-ROM sr1
[ 3039.197359] sr 6:0:0:0: Attached scsi generic sg2 type 5

ProblemType: Bug
DistroRelease: Ubuntu 10.04
Package: firefox 3.6.3+nobinonly-0ubuntu4
ProcVersionSignature: Ubuntu 2.6.32-21.32-generic 2.6.32.11+drm33.2
Uname: Linux 2.6.32-21-generic i686
NonfreeKernelModules: wl
Architecture: i386
Date: Mon May 3 09:20:17 2010
FirefoxPackages:
 firefox 3.6.3+nobinonly-0ubuntu4
 firefox-gnome-support 3.6.3+nobinonly-0ubuntu4
 firefox-branding 3.6.3+nobinonly-0ubuntu4
 abroswer N/A
 abrowser-branding N/A
InstallationMedia: Ubuntu 9.10 "Karmic Koala" - Release i386 (20091028.5)
ProcEnviron:
 LANG=en_SG.UTF-8
 SHELL=/bin/bash
SourcePackage: firefox

gavin (gavinewin) wrote :
Malikussaid (malikussaid) wrote :

Try to use "lsusb" in terminal.

If you find string "12b1:1446" and followed by modem's brand, then this trick should work for you.

Open Gedit, copy this text :

----------BEGIN----------
ACTION!="add", GOTO="huawei_zerocd_end"

SUBSYSTEM=="usb", ATTR{bDeviceClass}!="ff" ,ENV{DEVTYPE}=="usb_device", GOTO="huawei_zerocd_disable"
SUBSYSTEM=="scsi", ENV{DEVTYPE}=="scsi_device", GOTO="huawei_zerocd_disable"
GOTO="huawei_zerocd_end"

LABEL="huawei_zerocd_disable"
ATTRS{idVendor}=="12d1", ATTRS{idProduct}=="1446", RUN+="modem-modeswitch -v 0x%s{idVendor} -p 0x%s{idProduct} -t option-zerocd"

LABEL="huawei_zerocd_end"
------------END------------

Do not copy the begin and end line, of course.

Save it on your desktop, named "15-huawei-e1551.rules" (I know, your modem is E1550, but this should work) and quit Gedit.
Press Alt+F2, type "gksudo nautilus", this will launch nautilus in Super-User mode.
Now open "/home/username/Desktop", select the file, right-click it, choose copy.
Finally, open "/etc/udev/rules.d" and paste it there.
Restart your computer, and then plugin your modem.
Type "lsusb" again in terminal, if the string change to 12d1:1001 followed by your modem brand, you should be able to use your modem.

Source : https://launchpad.net/bugs/401655

gavin (gavinewin) wrote :

Thanks Malikussaid
Great workaround, I followed your clear instructions and I can now connect to mobile broadband. I do hope that this issue is fixed permanently. Not a very friendly introduction to new linux users with this type of modem. Reading the other bug reports it looks like a common issue. I tried it on Fedora 12 and had the same issue. I will try your workaround there.

Malikussaid (malikussaid) wrote :

No problem, but I've never tried on Fedora. Hope you successful.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers