Comment 2 for bug 573981

Peter,

I really appreciate your workaround. It worked just fine and essentially
fixes the problem which would also be affecting many of my friends once they
install 10.04. Thanks again for your response.

All the best,

Wayne Schneidman

On Sun, May 2, 2010 at 11:54 PM, peter watson <email address hidden>wrote:

> As a work around, I removed USBMOUNT using Synaptic. Solved problem
> after a reboot but I do not know why.
>
> --
> Ubuntu 10.04 - VFAT usb drives mount with root access only
> https://bugs.launchpad.net/bugs/573981
> You received this bug notification because you are a direct subscriber
> of the bug.
>
> Status in Ubuntu: New
>
> Bug description:
> On a fresh install of Ubuntu 10.04 Desktop 32 bit, not an upgrade, all USB
> VFAT drives I've tried mount with root access only which means I can not
> create or edit files or folders on these drives. The workaround I found was
> to use the Disk Utility to unmount and then mount the drives. This changed
> permissions on the drives to my login. However every time the system is
> rebooted the USB VFAT drives mount with root permissions only and the same
> procedure with Disk Utility has to be repeated for all the VFAT usb drives,
> same as before. The problem does not occur on the same drives, on the same
> system with ubuntu 9.10 Desktop 32 bit. The drives mount with permissions
> for me every time with Ubuntu 9.10 Desktop 32 bit.
>
> Examining fstab I noticed there is a line in it in Ubuntu 9.10 that is not
> present in Ubuntu 10.04 with respect to mounting usb drives. That line is:
>
> none /proc/bus/usb usbfs auto,devmode=0666 0 0
>
> Placed that line in fstab in the 10.04 load and found the system would not
> boot without bypassing that line. The choice was to skip processing that
> line or manually attempt to force it.
>
> Anyone installing a VFAT usb drive who encounters this symtom will not be
> able to copy files to the drive, nor edit existing files or folders at all
> without using the Disk Utility workaround I discovered.
>
> Have no idea what packages are involved in this. It's a problem mounting
> VFAT usb drives for sure. Haven't tried NTFS or EXT type usb file systems.
>
> Simply pulling out the drive connector and re-installing it does not fix
> the problem. Drive Utility must be used.
>
> To unsubscribe from this bug, go to:
> https://bugs.launchpad.net/ubuntu/+bug/573981/+subscribe
>