Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broken

Bug #554099 reported by Viktors Petrovs on 2010-04-02
478
This bug affects 84 people
Affects Status Importance Assigned to Milestone
Linux
Fix Released
Medium
Ubuntu
High
Unassigned
Lucid
High
Unassigned
Maverick
High
noarz
gobi-loader (Ubuntu)
Undecided
Unassigned
Lucid
Undecided
Unassigned
Maverick
Undecided
Unassigned
linux-backports-modules-2.6.32 (Ubuntu)
Undecided
Unassigned
Lucid
Medium
Stefan Bader
Maverick
Undecided
Unassigned

Bug Description

SRU justification (for LBM in Lucid):

Impact: Certain models of 3G hardware (Gobi) which apparently are quite
common, require several changes to work. First, the kernel module needs
to be updated, which requires larger modifications. Second, a new firm-
ware loader is required together with a matching udev rule.

Fix: In order to prevent regressions, the driver backport was done in
LBM and also adds a new binary subpackage (lbm-wwan). This package also
contains the loader and the udev rule.
NOTE! The drivers also requires firmware files which need to be manually
gathered as they are not redistributable.

Testcase: Without this backport no 3G connections are possible. Sevral
users in the bug report had successfully used the driver from the test
package after collecting the required firmware files.

---

Binary package hint: linux-image-generic

$ uname -a
Linux phoenix 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux

$ cat /proc/version_signature
Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1

$ lsusb
03f0:201d Hewlett-Packard <-- HP un2400 Mobile Broadband Module (QDL interface)

HP un2400 mobile broadband modem stopped working after i upgraded to lucid.
I can not load firmware anymore to my modem's Qualcomm Gobi USB chip using gobi_loader.
http://www.codon.org.uk/~mjg59/gobi_loader/

There was no problems on previous Ubuntu version (Karmic, kernel 2.6.31*). As i understand all devices based on this chip will not work on lucid, if this will not be fixed.

HP un2400 is recognized by kernel's qcserial module. qcserial.c was not changed from 2.6.31 to 2.6.32.
After searching internet i found that this is related to changes in the kernel's usbserial module:
"The qcserial driver is currently broken in 2.6.32 and later. It's due to the switch to using kfifo for usb serial, but we haven't been able to work out the actual cause. I'm looking at alternative approaches."
Source: http://mjg59.livejournal.com/120577.html

Contact me if You need additional information.

Jeremy Foshee (jeremyfoshee) wrote :

[This is an automated message. Apologies if it has reached you inappropriately.]

This bug was reported against the linux-meta package when it likely should have been reported against the linux package instead. We are automatically transitioning this to the linux kernel package so that the appropriate teams are notified and made aware of this issue.

If this bug really is a bug in the linux-meta package you can move it back to linux-meta and tag it kj-linux-meta, or contact us on the #ubuntu-kernel channel on the FreeNode IRC server. Thanks.

affects: linux-meta (Ubuntu) → linux (Ubuntu)
lordlaurin (lordlaurin) wrote :

same here ... please fix this in final lucid!

Tom Inglis (tominglis) wrote :

Please get the Qualcomm Gobi 2000 drivers working again in the release version of 10.04! It would be great to be able to use this modem in my Lenovo ThinkPad T510.

darko (darko2) wrote :

I have the same problem with HP EliteBook 6930p. It works if I activate it in Karmic and reboot to Lucid. But after shutdown gobi_loader hangs ... Please fix this. There are many HP laptops with UN2400!
Thank!

Darko

Changed in linux (Ubuntu):
status: New → Confirmed

I have the same problem with Lenovo ThinkPad T410. Please fix the problem in final release of Ubuntu Lucid Lynx...

Tom Inglis (tominglis) wrote :

In Ubuntu 9.10, it was possible to update the qcserial driver with the correct ID for your device, to compile and install gobi_loader 0.4, and copy the correct firmware files to /lib/firmware/gobi. There were issues with coming out of suspension / hibernation, but with a regular boot this worked.

This method no longer works in Ubuntu 10.04, presumably because of the changes mentioned above in the qcserial driver et al.

It would be great if the Gobi and Gobi 2000 devices were supported natively in the kernel by a combined driver / firmware loader with the unlocked firmware as the default (even if these have to be "restricted").

Motin (motin) wrote :

Seems like this netbook (Compaq Mini 110c) is not going to meet Lucid anytime soon... :(

Awaiting meerkat...

John Smith (jn-smith) wrote :

Same problem with Compaq mini 733ez. Any news?

AmenophisIII (amenophisiii) wrote :

there are kernel patches available. see http://thread.gmane.org/gmane.linux.usb.general/29707

Jesse Palser (jessepalser) wrote :

I have this problem too on my netbook. The only method for me to use my Qualcomm 9212 3G modem is to load the firmware using Gobi Loader. This worked OK on Ubuntu 9.10, but it does not work on 10.04. Please fix this before 10.04 release or I will have no method to use my 3G modem in my netbook. Thanks.

Viktors Petrovs (viks77) wrote :

Thank You, AmenophisIII!

I used patch parts 1/4 & 2/4 to compile only qcserial.ko & usb-wwan.ko for current kernel (2.6.32-21-generic) and now my HP un2400 Mobile Broadband Module is working again!!
But beware there are some errors in the patch! usb-wwan files sometimes is referenced as usb-wwan and sometimes as usb_wwan ! Must be changed everywhere uniformly!

Paul Stadig (pjstadig) wrote :

It's been too long since I did a kernel compile. I installed the linux-source package, expanded it, configured the kernel (I just accepted the defaults), patched with the patch from http://www.codon.org.uk/~mjg59/gobi_loader/kernel_patches/, compiled, and copied options.ko, qcserial.ko, and usb_wwan.ko to /lib/modules/`uname -r`/kernel/drivers/usb/serial, and when I do `sudo modprobe qcserial` I get an error about unknown symbols from usb_wwan. I tried `sudo modprobe usb_wwan` but I get an error that usb_wwan is an unknown module. What steps am I missing? Could someone kindly post step-by-step instructions?

Viktors Petrovs (viks77) wrote :

After You copied modules try:
sudo /sbin/depmod -a

Viktors Petrovs (viks77) wrote :

Sometimes i need to compile just one kernel module for current kernel without compiling full kernel tree.
This is how i get it done:

1) get attached patch
2) install and extract kernel source

sudo apt-get install linux-source
tar xjf /usr/src/linux-source-2.6.32.tar.bz2

3) patching and compilation (only drivers/usb/serial subdirectory)

mkdir temp

cd ./linux-source-2.6.32
patch -p1 < ../usb-wwan-2.6.32.diff

cp /lib/modules/`uname -r`/build/.config ../temp
cp /lib/modules/`uname -r`/build/Module.symvers ../temp
cp /lib/modules/`uname -r`/build/Makefile .

make O=../temp outputmakefile
make O=../temp archprepare
make O=../temp prepare
make O=../temp modules SUBDIRS=scripts
make O=../temp modules SUBDIRS=drivers/usb/serial/

4) copy resulting modules to kernel modules directory

sudo cp ../temp/drivers/usb/serial/usb_wwan.ko /lib/modules/`uname -r`/kernel/drivers/usb/serial/
sudo cp ../temp/drivers/usb/serial/qcserial.ko /lib/modules/`uname -r`/kernel/drivers/usb/serial/
sudo cp ../temp/drivers/usb/serial/option.ko /lib/modules/`uname -r`/kernel/drivers/usb/serial/
sudo /sbin/depmod -a

Viktors Petrovs (viks77) wrote :

There is patch i forgot to add to previous post!

Tom Inglis (tominglis) wrote :

Is there a fix for this issue that enables ordinary users of Ubuntu to get their Qualcomm Gobi 2000 chip working without having to compile a new kernel, patch it, install a firmware loader, and copy the correct firmware from their Windows installation!?

Paul Stadig (pjstadig) wrote :

Thanks you very much, Viktors! I was missing the depmod step, and by following your instructions I was able to build the modules without having to build the entire kernel, which saved a bunch of time.

I agree with, Tom, even though there is a workaround, this should be fixed, especially for users who may not be able to build a kernel.

Tom Inglis (tominglis) wrote :

If we can get this chip working for the ordinary user, without them having to do anything extra, then that would be fantastic, particularly if it can be patched into 10.04?

Otherwise, the least we could do is to provide a really detailed step by step explanation of how to get it to work on the Ubuntu wiki?

These chips are probably going to get a lot more popular over the next year or two, as people use 3G / 4G / GPS more in their laptops...

Nick vd Merwe (nickvdmer) wrote :

I am running the Released Lucid and it was not fixed. I have a HP Elitebook 8530w.
Thus I have a Not-Functioning 3G. To access the Internet I have to borrow the wife's Huawei Vodafone card.

Please can someone fix the kernel and make it available through Update-Manager?

Changed in linux (Ubuntu):
status: Confirmed → Triaged
importance: Undecided → Medium
tags: added: patch
Boris Bopp (boris.bopp) wrote :

It should be possible to create a package for ordinary users, if there is a patched Kernel.

The steps are:
1. Download firmware. I don't know the legal situation.
wget ftp://ftp.hp.com/pub/softpaq/sp44501-45000/sp44916.exe
2. cabextract 44916.exe
3. Dialog that asks which firmware to use (http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01738839&jumpid=reg_R1002_USEN)
4. move firmware to /lib/firmware/gobi
5. install gobi_loader
6. insert qcserial and hp-wmi into /etc/modules.

A rfkill power switch somewhere would be nice , too.

Tom Inglis (tominglis) wrote :

NB - This is not just a problem for HP laptops, it affects anything with the Qualcomm Gobi series of chips (including in my case the Lenovo ThinkPad series).

Paul Stadig (pjstadig) wrote :

Thanks, Tom. I was actually going to post the same thing. I have a Lenovo ThinkPad. It's anyone with the Gobi 2000, not just HP.

summary: - HP un2400 mobile broadband module not working after upgrade to lucid
+ qualcomm gobi (2000) mobile broadband module not working after upgrade
+ to lucid

The Problem is also on Acer Aspire one with Qualcomm Gobi modem. I think very much Laptops use this
Modem so please try to fix it.

jay (htl-rudi) wrote :

I have the same problem (HP 6930p; Gobi 1000)
Patch worked for me without any problems.

Danie Thom (danie-thom-gmail) wrote :

I have the same problem with the Fujitsu Lifebook S710. They ship with the Sierra Wireless modules using the Qualcomm firmware. I received the following SDK file that was supposed to be the driver for the card, but it is only the SDK. Can anyone help with a How To that can help me with the installation? I have never done this, so I don't know where to start.?field.comment=I have the same problem with the Fujitsu Lifebook S710. They ship with the Sierra Wireless modules using the Qualcomm firmware. I received the following SDK file that was supposed to be the driver for the card, but it is only the SDK. Can anyone help with a How To that can help me with the installation? I have never done this, so I don't know where to start.

Same issue with HP ProBook 6440B, but patch worked without problems.

description: updated
tnf (tnf-ars-solvendi) wrote :

I tried to follow the instructions on comments 14 and 20, but unfortunately this seems to work only partly. I get the following in /var/log/messages:

Jun 1 08:24:33 tptfeubu kernel: [ 4.805522] USB Serial support registered for Qualcomm USB modem
Jun 1 08:24:33 tptfeubu kernel: [ 4.805771] qcserial 2-1.4:1.1: Qualcomm USB modem converter detected
Jun 1 08:24:33 tptfeubu kernel: [ 4.805958] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
Jun 1 08:24:33 tptfeubu kernel: [ 4.806006] usbcore: registered new interface driver qcserial

I also have /dev/ttyUSB0, but NetworkManager and umtsmon don't recognize the device. lsusb shows

Bus 002 Device 004: ID 05c6:9204 Qualcomm, Inc.

Any ideas where I might start looking?

Viktors Petrovs (viks77) wrote :

Hello, tnf!
05c6:9204 is a Gobi 2000 QDL device. You need to download firmware.

http://www.codon.org.uk/~mjg59/gobi_loader/download/

tnf (tnf-ars-solvendi) wrote :

I installed gobi_loader and put the firmware in /lib/gobi/formware as suggested in comment 20. This seemed to work. Anything I might have missed? I did a make and make install, nothing else

Tom Inglis (tominglis) wrote :

Is there any chance of making a package for ordinary users so that they can grab the firmware and the package and get their modem working?

If not, is it possible to create some instructions for ordinary users to explain how to get these modems working in the Ubuntu wiki?

Will the 10.04 kernel be patched with this update, or will this only be something that makes its way into Maverick?

tomx (tom-xitio) wrote :

I'd be grateful for some clarification, too.
So, the hardware is used in 2 different aspects (9204/9205 - QDL/Modem Device) AND the qcserial has to be compiled manually?
I use a Thinkpad T410s on Ubuntu 10.04 2.6.32-22-generic.

lsusb gives
Bus 002 Device 003: ID 05c6:9204 Qualcomm, Inc.
and no ttyUSB0 shows up in /dev.

tnf (tnf-ars-solvendi) wrote :

@Viktors: thanks for the hint, I didn't realize I had the wrong firmware

tnf (tnf-ars-solvendi) wrote :
Download full text (3.3 KiB)

@Tom Inglis and tomx: following are the steps I did to get the device working. I didn't create a wiki page because I couldn't find the right place and ubuntuguide.org doesn't let me edit. And maybe some day this bug will be fixed and getting the device to work will be easier :)

## Download the firmware and copy it to the right place
I have a ThinkPad T510, so I downloaded the driver from http://www-307.ibm.com/pc/support/site.wss/document.do?lndocid=MIGR-72938 and installed it on Windows. Then I copied the files from c:\Programme\QUALCOMM\Images\Lenovo\6 and c:\Programme\QUALCOMM\Images\Lenovo\UMTS to /lib/firmware/gobi (you'll have to create that folder). Check http://h20000.www2.hp.com/bizsupport/TechSupport/Document.jsp?lang=en&cc=us&objectID=c01738839&jumpid=reg_R1002_USEN to find out which folders are right for you

## Install the kernel patch and gobi_loader
Open a terminal
mkdir umts
cd umts
wget http://launchpadlibrarian.net/46353288/usb-wwan-2.6.32.diff
sudo apt-get install linux-source
tar xjf /usr/src/linux-source-2.6.32.tar.bz2
mkdir temp
cd ./linux-source-2.6.32
patch -p1 < ../usb-wwan-2.6.32.diff
cp /lib/modules/`uname -r`/build/.config ../temp
cp /lib/modules/`uname -r`/build/Module.symvers ../temp
cp /lib/modules/`uname -r`/build/Makefile .
make O=../temp outputmakefile
make O=../temp archprepare
make O=../temp prepare
make O=../temp modules SUBDIRS=scripts
make O=../temp modules SUBDIRS=drivers/usb/serial/
sudo cp ../temp/drivers/usb/serial/usb_wwan.ko /lib/modules/`uname -r`/kernel/drivers/usb/serial/
sudo cp ../temp/drivers/usb/serial/qcserial.ko /lib/modules/`uname -r`/kernel/drivers/usb/serial/
sudo cp ../temp/drivers/usb/serial/option.ko /lib/modules/`uname -r`/kernel/drivers/usb/serial/
sudo /sbin/depmod -a
cd ..
wget http://www.codon.org.uk/~mjg59/gobi_loader/download/gobi_loader-0.5.tar.gz
tar -xzf gobi_loader-0.5.tar.gz
cd gobi_loader-0.5/
make
sudo make install
cd ../..
rm -r umts

Now reboot the system and the NetworkManager applet should have an "activate mobile broadband" option
lsusb shows "Bus 002 Device 004: ID 05c6:9205 Qualcomm, Inc."
In /var/log/messages I see
Jun 2 09:08:04 tptfeubu kernel: [ 4.324342] USB Serial support registered for Qualcomm USB modem
Jun 2 09:08:04 tptfeubu kernel: [ 4.324378] qcserial 2-1.4:1.1: Qualcomm USB modem converter detected
Jun 2 09:08:04 tptfeubu kernel: [ 4.327814] ip_tables: (C) 2000-2006 Netfilter Core Team
Jun 2 09:08:04 tptfeubu kernel: [ 4.328086] usb 2-1.4: Qualcomm USB modem converter now attached to ttyUSB0
Jun 2 09:08:04 tptfeubu kernel: [ 4.328105] usbcore: registered new interface driver qcserial
and later
Jun 2 09:08:15 tptfeubu kernel: [ 14.546188] usb 2-1.4: USB disconnect, address 3
Jun 2 09:08:15 tptfeubu kernel: [ 14.546406] qcserial ttyUSB0: Qualcomm USB modem converter now disconnected from ttyUSB0
Jun 2 09:08:15 tptfeubu kernel: [ 14.546414] qcserial 2-1.4:1.1: device disconnected
Jun 2 09:08:15 tptfeubu kernel: [ 14.777742] usb 2-1.4: new high speed USB device using ehci_hcd and address 4
Jun 2 09:08:15 tptfeubu kernel: [ 14.897398] usb 2-1.4: configuration #1 chosen from 1 choice
Jun 2 09:08:15 tptfeubu kernel: [ ...

Read more...

Tom Inglis (tominglis) wrote :

TNF that's great thank you very much. I'll try that now and will look into creating a wiki page.

Is this something that needs to be done each time the kernel is updated, and will the USB-WWAN patch be included in a future kernel update in 10.04?

I have Lenovo Thinkpad T410 with Gobi 2000 and I used tnf's instructions. However it does not work completely, because I have to run Windows first and next Ubuntu and then I see 05c6:9205 Qualcomm, Inc. in lsusb. If not I run Windows first I see 05c6:9204 Qualcomm, Inc.

How to run GPS module of Gobi 2000?

Martijn vdS (martijn) wrote :

My Gobi 2000 works fine with 2.3.35-rc1 mainline (from the kernel-team PPA) + the gobi-loader tool from http://www.codon.org.uk/~mjg59/gobi_loader/ + the firmware I copied from my Windows partition.

In 2.3.34 /dev/ttyUSB0 doesn't show up, so firmware uploading can't be done.

tnf (tnf-ars-solvendi) wrote :

@Tom Inglis: not sure if this will be the same for other updates, but it still works for me after the last 2.6.32-22 fix. I guess it won't work after a 2.6.32-23 update, but I don't now for sure

Marco (bulletxt) wrote :

Hi Martijn vdS, where can I get that kernel 2.6.35RC1? Did you compile it yourself or did you get it from PPA? If from PPA, which one? The only one I can find for Ubuntu 10.04 is a kernel ppa with linux kernel 2.6.34! Thanks

Marco (bulletxt) wrote :

Thanks. About the gobi loader, which version did you use? Version 0.6? Also, did you apply a patch to it?

Paul Sladen (sladen) on 2010-07-04
summary: - qualcomm gobi (2000) mobile broadband module not working after upgrade
- to lucid
+ [PATCH] Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broke in 10.04
tags: added: regression
Paul Sladen (sladen) on 2010-07-04
summary: - [PATCH] Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broke in 10.04
+ [PATCH] Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broken in 10.04
Changed in linux (Ubuntu Lucid):
status: New → Confirmed
Changed in linux (Ubuntu Maverick):
status: Triaged → Confirmed
importance: Medium → High
Changed in linux (Ubuntu Lucid):
importance: Undecided → High
tags: added: kernel-needs-review kernel-net regression-release
removed: regression
papukaija (papukaija) on 2010-07-26
tags: added: lucid maverick
summary: - [PATCH] Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broken in 10.04
+ Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broken
Stefan Bader (smb) on 2010-08-06
Changed in linux (Ubuntu Maverick):
status: Confirmed → Fix Released
Changed in linux-backports-modules-2.6.32 (Ubuntu Maverick):
status: New → Invalid
Changed in linux (Ubuntu Lucid):
status: Confirmed → Won't Fix
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
assignee: nobody → Stefan Bader (stefan-bader-canonical)
importance: Undecided → Medium
status: New → In Progress
Stefan Bader (smb) on 2010-08-06
description: updated
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: In Progress → Fix Committed
DocHofa (zifotronic) on 2010-08-18
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released
status: Fix Released → Fix Committed
Changed in linux (Ubuntu Lucid):
status: Won't Fix → Confirmed
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Confirmed
Steve Langasek (vorlon) on 2010-08-19
Changed in linux (Ubuntu Lucid):
status: Confirmed → Won't Fix
Stefan Bader (smb) on 2010-08-20
Changed in gobi-loader (Ubuntu Lucid):
status: New → Invalid
Changed in gobi-loader (Ubuntu Maverick):
status: New → Fix Released
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Confirmed → Fix Committed
Martin Pitt (pitti) on 2010-09-01
tags: added: verification-needed
Martin Pitt (pitti) on 2010-09-15
tags: added: verification-done
removed: verification-needed
Changed in linux-backports-modules-2.6.32 (Ubuntu Lucid):
status: Fix Committed → Fix Released
111 comments hidden view all 191 comments

Are there clear instructions for where to find the firmware in the first
place?

Brian (x-brian) wrote :

@ Mark #152

I don't think there are clear instructions--part of that is because firmware has to be obtained from the hardware manufacturer, and they are only provided in Windows driver packages. Mine came from Dell, so I had to pry the firmware out of the Dell Windows drivers. Others have to get it from Lenovo, HP, etc. The md5sums are available for at least a couple of firmware sources above, but there's probably a need for some kind of HowTo or something.

Jelle de Jong (jelledejong) wrote :

Is this problem already fixed in the mainstream kernel. The WLAN modules are broken for quite a while now.... A fix should be this hard? An status report would be appreciated.

Stefan Bader (smb) wrote :

The kernel modules in Maverick and onward are fine. gobi_loader is a separate
package there.

darren (darrenm) wrote :

So if it doesn't work we should file bugs against gobi_loader?

Stefan Bader (smb) wrote :

I could think of two cases. If the usb id for your modem is in the udev rules
file provided by the package and the firmware files get loaded but it does not
work, the problem would rather be the kernel (linux) package.
If the udev rules miss the id and there is no indication that the firmware is
tried to load, then the problem should be reported against the loader.
Any case it helps to have problems reported separately as things work for some
people and this hints that this is rather a problem very specific to a certain
make of hardware.

Anders Østerholt (diebels) wrote :

Howto for Maverick, generic UMTS on Thinkpads:
Download and extract windows driver install file from Lenovo. http://download.lenovo.com/ibmdl/pub/pc/pccbbs/mobiles/7xwc44ww.exe or get the latest from http://www-307.ibm.com/pc/support/site.wss/MIGR-72938.html
Install a recent wine as 1.2 crashes during msi extraction.
Run the install file with wine.
Extract firmware from GobiInstaller.msi. mkdir ~/.wine/drive_c/DRIVERS/GOBI; wine msiexec /a ~/.wine/drive_c/DRIVERS/WWANQL/Driver/GobiInstaller.msi /qb TARGETDIR=C:\\DRIVERS\\GOBI

install "gobi-loader"

Copy firmware into /lib/firmware/gobi. sudo mkdir /lib/firmware/gobi; cd ~/.wine/drive_c/DRIVERS/GOBI/Images/Lenovo; sudo cp 6/* /lib/firmware/gobi/; sudo cp UMTS/* /lib/firmware/gobi/

Do a reboot or modem-manger restart and qcserial unload load. sudo pkill modem-manager; sudo rmmod qcserial; sudo modprobe qcserial

You should now have a "New Mobile Broadband (GSM) connection..." in the nm-applet. If not, do the thing in the previous paragraph or have a look at syslog

@Andres
thanks for your guide.
I've a thinkpad edge 13 with qualcomm gobi 2000 modem. I've done your instructions with Maverick release.
Now i can see a "New Mobile Broadband (GSM) connection..." in the nm-applet but it's impossibile to connect.
The message is always the same "GSM network, now it's offline"..
I'don't undrestand because:
* /lib/udev/60-gobi.rules contain my ID modem
* when i reboot in /var/log/messages i can see: Qualcomm USB modem converter now attached to ttyUSB0
* run lsusb and id changes from 05c6:9204 to 05c6:9205 (firmware loaded)
...is there anything else I can do?

(Thinkpad EDGE 13" Ubuntu maverick 32bit)
Thanks a lot!

Anders Østerholt (diebels) wrote :

@Giuseppe
you could try ~/.wine/drive_c/DRIVERS/GOBI/Images/Lenovo/8/UQCN.mbn

There are different providers listed at http://www.thinkwiki.org/wiki/Talk:Qualcomm_Gobi_2000

Do a tail -f /var/log/syslog, and modem-manager should give some output when it tries to connect.

Konstantin (jakshi) wrote :

I also have problem with autostarting.
udev rule with firmware loading executed but nothing happend.
But when I try to do the same in console, all work well. Firmware uploads to device, 3G appears.
May be gobi loader broken and exit without do anything in certain circumstance?

Konstantin (jakshi) wrote :

My workaround is:
Create file ~/bin/gobi1000:

#! /bin/sh
sudo /lib/udev/gobi_loader-25-generic /dev/ttyUSB0 /lib/firmware/gobi
sudo pkill modem-manager

Set execution bit for this file:

chmod a+x ~/bin/gobi1000

place gobi1000.desktop in ~/.config/autostart:

[Desktop Entry]
Type=Application
Exec=/home/jakshi/bin/gobi1000
Hidden=false
NoDisplay=false
X-GNOME-Autostart-enabled=true
Name[ru_UA]=Gobi1000 3G activate
Name=Gobi1000 3G activate
Comment[ru_UA]=upload firmware and restart modem-manager
Comment=upload firmware and restart modem-manager

add to /etc/sudoers:

%admin ALL=NOPASSWD: /lib/udev/gobi_loader-25-generic
%admin ALL=NOPASSWD: /usr/bin/pkill

Simon Hirscher (codethief) wrote :

For those of you who own a W510 and couldn't get the gobi device working in the past (due to it constantly crashing) I have very good news:
Lenovo finally released (it took them more than half a year) a new firmware version which should fix this issue: http://forums.lenovo.com/t5/W-Series-ThinkPad-Laptops/w510-BSOD/m-p/309878#M11808

darren (darrenm) wrote :

Can someone change this from fix released please? It's not fixed, it still doesn't work unless you manually load the driver yourself using gobi_loader -2000 /dev/ttyUSB0 /lib/firmware/gobi and then killall modem-manager after every boot.

Mark Shuttleworth (sabdfl) wrote :

Yes, please leave the bug open until the fix is Dad-proof:

 - enable backports
 - install a package
 - go

Mark

Brian Candler (b-candler) wrote :

@lapistano: to get thinkpad_acpi.c, see #557736 comment #23

The one I was using is:

$ grep TPACPI_VERSION /v/build/thinkpad_acpi.c | head -1
#define TPACPI_VERSION "0.24-20100516"

$ sha1sum /v/build/thinkpad_acpi.c
029c81cb90b0e0b8d3775913e4ddb5820b50683b /v/build/thinkpad_acpi.c

However I've now moved to Maverick and the default thinkpad_acpi module loads without problems.

1 comments hidden view all 191 comments
J Boyan (ubuntu-boyan) wrote :

The workaround is *not* working for me, I cannot activate the device from Ubuntu. lsusb shows
     Bus 002 Device 003: ID 05c6:9204 Qualcomm, Inc.
and when I run
     sudo gobi_loader -2000 /dev/ttyUSB0 /lib/firmware/gobi
it just hangs. :-(

However, if I boot into Windows and initiate the Verizon connection there, and then reboot back into Ubuntu, the setup DOES work - I see "Verizon connection" in the network manager dropdown; the lsusb shows "05c6:9205"; and I can connect, disconnect, reconnect successfully. Unfortunately, after suspend and resume, or after shutdown and powering back on, the device is deactivated (05c6:9204) and I can't reactivate it from Ubuntu.

Any ideas? What additional info can I provide to help debug this?

I'm running Maverick 10.10 with kernel 2.6.35-23 on a Lenovo Thinkpad X201 with Gobi 2000 / Verizon CDMA.
$ md5sum /lib/firmware/gobi/*
06f76ed398458dad7b91c2d99a85a0a7 /lib/firmware/gobi/amss.mbn
88a60ed745d75fb1b92c539574ecc972 /lib/firmware/gobi/apps.mbn
2dccbd125ddd2cb327309ba75c6054d2 /lib/firmware/gobi/UQCN.mbn
(these were copied from the Qualcomm 1/ subdirectory in Windows)

Jochen Gruse (lpnet) wrote :

@JBoyan:
On my T410 with the same modem (but different firmware), I have had the same problem. I've opened a new bug - including a bugfix/workaround - for modem-manager, which I found to be the culprit.

Have a look here: https://bugs.launchpad.net/ubuntu/+source/modemmanager/+bug/686418

Short version: Add the line

ATTRS{idVendor}=="05c6", ATTRS{idProduct}=="9204", ENV{ID_MM_DEVICE_IGNORE}="1"

to the file "/lib/udev/rules.d/77-mm-usb-device-blacklist.rules", then reboot. This should prevent the modem-manager from corrupting the firmware download.

Hope that helped,
Jochen Gruse

Download full text (3.2 KiB)

Just followed the steps given by Anders (comment 158) and now I can see the new Mobile Broadband connection in the NetworkManager applet. But, when I try to use it, 3G won't work, the connection only sets up in GSM mode (not even GPRS mode). Of course, I can use that connection with 3G or GPRS when using the external usb dongle.

Any idea why this would happen?

When I configure the mobile broadband connection to force using only 3G, syslog says:
ec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Dec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <warn> GSM connection failed: (32) Operation not supported
Dec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 4 -> 9 (reason 1)
Dec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <info> Marking connection 'Orange' invalid.
Dec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <warn> Activation (ttyUSB0) failed.
Dec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 9 -> 3 (reason 0)
Dec 25 21:02:09 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): deactivating device (reason: 0).
Dec 25 21:02:10 piticli-ubuntu modem-manager: CS registration state changed: 1
Dec 25 21:02:10 piticli-ubuntu modem-manager: Modem /org/freedesktop/ModemManager/Modems/0: state changed (searching -> registered)
Dec 25 21:02:10 piticli-ubuntu modem-manager: PS registration state changed: 1
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) starting connection 'Orange'
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 3 -> 4 (reason 0)
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 4 -> 6 (reason 0)
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) scheduled...
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) started...
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 6 -> 4 (reason 0)
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Activation (ttyUSB0) Stage 1 of 5 (Device Prepare) complete.
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <warn> GSM connection failed: (32) Operation not supported
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 4 -> 9 (reason 1)
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> Marking connection 'Orange' invalid.
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <warn> Activation (ttyUSB0) failed.
Dec 25 21:02:20 piticli-ubuntu NetworkManager[1213]: <info> (ttyUSB0): device state change: 9 -> 3 (reason 0)
Dec 25 21:02:20 piticli-u...

Read more...

Simon Hirscher (codethief) wrote :

@Aleksander: I suppose you have a ThinkPad. Which one exactly? Also, are you using the latest Gobi firmware available?

@Simon: Yes, it's a thinkpad T510i bought a couple of months ago. The gobi firmware was freshly downloaded from the Lenovo Support webpage (1.1.170/2.0.7.3, released on 2010/10/28)

Simon Hirscher (codethief) wrote :

Hm, the only thing I know is that the firmware still has some bugs. At least I experience the one or other every now and then. However, I've got a W510 where it's known that the firmware is extremely buggy. I'm not sure about your problem… Does it always occur?

@Simon: At least all the 5-6 times I've tried, always connected in GSM mode and if forcing GPRS or 3G it didn't work. So, quite useless the SIM connector right now... :-/

Michael Rauch (michael-rauch) wrote :

Post 158 works, but i had to install also the following package for ubuntu 10.04.

linux-backports-modules-wwan-2.6.32-27-generic

You have to choose the package accordingly to your running kernel.

michal@linux:~$ uname -r
2.6.32-27-generic

Testet with a lenovo T510

michal@linux:~$ lsusb
Bus 002 Device 004: ID 05c6:9205 Qualcomm, Inc.

AIAMUZZ (muzafsh-113) wrote :

Hi,

All-in-all i have been able to find my Gobi 2000 device on my Ubuntu 10.10, Network Manager only 3 times.
(the first time as a GSM device, the second as a CDMA device and third as a GSM device again.)

ever since i am just not able to get it running ...

When i try to run the following command ...

"sudo /lib/udev/gobi_loader /dev/ttyUSB0 /lib/firmware/gobi"
or
"sudo /lib/udev/gobi_loader -2000 /dev/ttyUSB0 /lib/firmware/gobi"

the terminal hangs...

Could this be because the modem manager may be preventing the gobi_loader from loading the firmware ?
Or
Could it be because the patch (usb-wwan-2.6.34.diff from - http://www.codon.org.uk/~mjg59/gobi_loader/) spoken about in Viktors Petrov's post 14 was not added ?
" https://bugs.launchpad.net/ubuntu/maverick/+source/linux/+bug/554099/comments/14 "

Detail of My Machine :
----------------------

Acer Aspire One 8.9
hosting a 'HP Qualcomm Gobi 2000 card'
with no luck on Windows 7 with this card, i am trying to have it running on my Ubuntu.

I am using Ubuntu : 10.10
on kernel : 2.6.35-24-generic

I have uninstalled 'gobi_loader' as well as 'qcserial' completely

I did the following...

1. firmware files : 3 firmware files copied to /lib/firmware/gobi/ Checked

2. Gobi_loader : 60-gobi-rules file carries my device ID's Checked
   downloaded-extracted-make-make install-

3. qcserial : qcserial.c file carries my device ID's Checked
   downloaded-extracted-make-make install-

post installation i verified the installation ...

1. 'gobi_loader' executable installed to location ... - /lib/udev/...
2. '60-gobi-rules' file installed to location ... - /etc/udev/rules.d/...
3. 'qcserial.ko' installed to location ... - /lib/modules/.../kernel/drivers/usb/serial...

the command 'lsmod' shows the following activity ...
"
qcserial 2620 1
bluetooth 50500 9 rfcomm,sco,bnep,l2cap,btusb
snd_seq_device 5744 3 snd_seq_midi,snd_rawmidi,snd_seq
psmouse 59033 0
usbserial 33100 3 qcserial
"

command 'dmesg' shows the following activity ...
"
[ 13.955839] USB Serial support registered for Qualcomm USB modem
[ 13.960673] qcserial 1-6:1.1: Qualcomm USB modem converter detected
[ 13.961281] usb 1-6: Qualcomm USB modem converter now attached to ttyUSB0
[ 13.961485] usbcore: registered new interface driver qcserial
"

Please let me know what i should try...

to apply the patch ' usb-wwan-2.6.34.diff ' or a different direction all together...

PS : I am not a programmer just a brave novice ubuntu user :).
So any instructions bearing this fact in mind would be most helpful.

thanks
Muzafsh.

AIAMUZZ (muzafsh-113) wrote :

Well I tried the procedure listed by "Viktors Petrov's post 14 "

Can somebody who understands the output/result of those steps go through the attached file and confirm if my effort to patch " usb-wwan-2.6.34.diff " was a success or a failure ?

However after running the above My Gobi 2000 device is still as elusive as before :(

the 'dmesg' and 'lsmod' commands record the following activity ...

"
[ 14.071236] USB Serial support registered for Qualcomm USB modem
[ 14.071305] qcserial 1-6:1.1: Qualcomm USB modem converter detected
[ 14.071564] usb 1-6: Qualcomm USB modem converter now attached to ttyUSB0
[ 14.071655] usbcore: registered new interface driver qcserial
"

&

"
usb_wwan 9953 1 qcserial
acerhdf 6895 0
cfg80211 144470 3 ath5k,mac80211,ath
videodev 43098 1 uvcvideo
psmouse 59033 0
usbserial 33100 4 qcserial,usb_wwan
"

Please help ...

thanks,

AIAMUZZ (muzafsh-113) wrote :

Well I tried the procedure listed by "Viktors Petrov's post 14 "

Can somebody who understands the output/result of those steps go through the attached file and confirm if my effort to patch " usb-wwan-2.6.34.diff " was a success or a failure ?

However after running the above My Gobi 2000 device is still as elusive as before :(

the 'dmesg' and 'lsmod' commands record the following activity ...

"
[ 14.071236] USB Serial support registered for Qualcomm USB modem
[ 14.071305] qcserial 1-6:1.1: Qualcomm USB modem converter detected
[ 14.071564] usb 1-6: Qualcomm USB modem converter now attached to ttyUSB0
[ 14.071655] usbcore: registered new interface driver qcserial
"

&

"
usb_wwan 9953 1 qcserial
acerhdf 6895 0
cfg80211 144470 3 ath5k,mac80211,ath
videodev 43098 1 uvcvideo
psmouse 59033 0
usbserial 33100 4 qcserial,usb_wwan
"

Please help ...

thanks,

AIAMUZZ (muzafsh-113) wrote :

Hi,
Without any explanation my Gobi 2000 show's up in the network manager. subsequent restarts don't result in a consistent firmware load. so its is occassional.

When the firmware got loaded, i tried to connect through my DOCOMO(indian SIM Card) 3G network.
But no success in establishing an effective connection.

I have attached the syslog file.
Can somebody help me diagnose the reason why my 3G account is not able to connect.

thanks.

Changed in linux:
status: Unknown → Confirmed
Changed in linux:
importance: Unknown → Medium
status: Confirmed → Fix Released
darren (darrenm) wrote :

Fix released? Awesome!

Anyone know where I can get it?

Alex Denvir (coldfff) wrote :

Done some testing with both lucid and maverick on a Dell Latitude E5410 here -

With maverick, installing gobi-loader, dropping the firmware into /lig/firmware/gobi and rebooting works first time, nice and easy.

With lucid, I had absolutely no success at all. Installed gobi-loader, backports etc. and network-manager would never show any options under mobile broadband.

Ideally I'd like to get this working on lucid as I have about 4 of these laptops in the company, and would preferably like to stick to the LTS, but I guess I can cope with shifting to maverick for this.

Simon Hirscher (codethief) wrote :
Download full text (4.1 KiB)

@Alex: I'm also running Lucid and Gobi works fine here (at least most
of the time but that might be related to my ThinkPad W510). I didn't
install any backports packages, though, but patched the kernel by hand
as described in one of messages at the very beginning of this bug
discussion. (Also 2.6.35-020635rc4-generic is my kernel version in
case you need it but any newer version should do, too.)

On Wed, Mar 2, 2011 at 17:32, Alex Denvir <email address hidden> wrote:
> Done some testing with both lucid and maverick on a Dell Latitude E5410
> here -
>
> With maverick, installing gobi-loader, dropping the firmware into
> /lig/firmware/gobi and rebooting works first time, nice and easy.
>
> With lucid, I had absolutely no success at all. Installed gobi-loader,
> backports etc. and network-manager would never show any options under
> mobile broadband.
>
> Ideally I'd like to get this working on lucid as I have about 4 of these
> laptops in the company, and would preferably like to stick to the LTS,
> but I guess I can cope with shifting to maverick for this.
>
> --
> You received this bug notification because you are a direct subscriber
> of the bug.
> https://bugs.launchpad.net/bugs/554099
>
> Title:
>  Qualcomm Gobi 2000 3G (gobi_loader/qcserial) broken
>
> Status in The Linux Kernel:
>  Fix Released
> Status in “gobi-loader” package in Ubuntu:
>  Fix Released
> Status in “linux” package in Ubuntu:
>  Fix Released
> Status in “linux-backports-modules-2.6.32” package in Ubuntu:
>  Invalid
> Status in “gobi-loader” source package in Lucid:
>  Invalid
> Status in “linux” source package in Lucid:
>  Won't Fix
> Status in “linux-backports-modules-2.6.32” source package in Lucid:
>  Fix Released
> Status in “gobi-loader” source package in Maverick:
>  Fix Released
> Status in “linux” source package in Maverick:
>  Fix Released
> Status in “linux-backports-modules-2.6.32” source package in Maverick:
>  Invalid
>
> Bug description:
>  SRU justification (for LBM in Lucid):
>
>  Impact: Certain models of 3G hardware (Gobi) which apparently are quite
>  common, require several changes to work. First, the kernel module needs
>  to be updated, which requires larger modifications. Second, a new firm-
>  ware loader is required together with a matching udev rule.
>
>  Fix: In order to prevent regressions, the driver backport was done in
>  LBM and also adds a new binary subpackage (lbm-wwan). This package also
>  contains the loader and the udev rule.
>  NOTE! The drivers also requires firmware files which need to be manually
>  gathered as they are not redistributable.
>
>  Testcase: Without this backport no 3G connections are possible. Sevral
>  users in the bug report had successfully used the driver from the test
>  package after collecting the required firmware files.
>
>  ---
>
>  Binary package hint: linux-image-generic
>
>  $ uname -a
>  Linux phoenix 2.6.32-19-generic #28-Ubuntu SMP Wed Mar 31 17:46:20 UTC 2010 i686 GNU/Linux
>
>  $ cat /proc/version_signature
>  Ubuntu 2.6.32-19.28-generic 2.6.32.10+drm33.1
>
>  $ lsusb
>  03f0:201d Hewlett-Packard <-- HP un2400 Mobile Broadband Module (QDL interface)
>
>  HP un2400 mobile broadband modem stoppe...

Read more...

noarz (noar-adv) on 2011-03-17
Changed in linux (Ubuntu Maverick):
assignee: nobody → noarz (noar-adv)
Benjamin Tayehanpour (konaya) wrote :

I wish I could reproduce Alex's success on my own laptop, but I can't. I'm running Maverick, I've installed gobi-loader, extracted the firmware etc etc, but it just won't work. lsof shows that gobi_loader is stuck in the background trying to upload the firmware to /dev/ttyUSB0, which shows that it at least recognizes the device...

Oh, and I've tried with both 2.6.35-28 and 2.6.36-020636. What to do what to do?

Tom Inglis (tominglis) wrote :

I've got Ubuntu 10.04. I recently reformatted my computer, and since then have not been able to get my Gobi device to work. I installed the correct backport and put the firmware in /lib/firmware/gobi. The firmware doesn't load automatically or manually.

I have tried loading the firmware manually using "sudo /lib/udev/gobi_loader-31-generic -2000 /dev/ttyUSB0 /lib/firmware/gobi", but I get:

"Failed to open serial device: : No such file or directory
usage: /lib/udev/gobi_loader-31-generic [-2000] serial_device firmware_dir"

Kenrick Bingham (loxo) wrote :

This still seems to be broken on Ubuntu 10.04.2 LTS x86_64. This worked about a year ago, but stopped working with some kernel upgrade, probably somewhere near 2.6.32-25. The device does not show up in Network Manager, and "sudo modprobe qcserial" gives the error:

FATAL: Error inserting qcserial (/lib/modules/2.6.32-33-generic/updates/wwan/qcserial.ko): Invalid module format

Is this perhaps a packaging problem? I think it would be important to restore the functionality of this device.

Stefan Bader (smb) wrote :

The module failing to load is indeed a packaging problem. I opened bug #814186 to track that getting fixed.

steve coleman (scoleman) on 2011-11-27
affects: linux (Ubuntu Maverick) → Ubuntu Maverick
Sugunakar (sugunakar2-2) wrote :

@Tom Inglis (tominglis) wrote on 2011-05-11:
It is working for me with "sudo /lib/udev/gobi_loader /dev/ttyUSB0 /lib/firmware/gobi" after copying firmware files in /lib/firmware/gobi

thanks. after lot of struggle it is working.
How to send and recieve the messages, through network manager or other application in ubuntu to check the balance?

Displaying first 40 and last 40 comments. View all 191 comments or add a comment.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.