Add a plymouth theme for sabily

Bug #543679 reported by أحمد المحمودي (Ahmed El-Mahmoudy)
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Unassigned

Bug Description

A package is being prepared for Sabily plymouth theme.

Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :
Revision history for this message
Fabrice Coutadeur (fabricesp) wrote :

As explained by IRC, you should get first a Release ack. Unsubscribing sponsors.

Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :
Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :
Revision history for this message
Steve Langasek (vorlon) wrote :

The postinst script in the package on REVU has:

    configure)
        # FIXME: do this with alternatives
        plymouth-set-default-theme --rebuild-initrd sabily
        ;;

First, this isn't safe; if the user has this package installed but chooses to use a different theme, that choice will be clobbered on every upgrade.

Second, the code to implement update-alternatives handling of themes is already in place in the bzr branch at lp:ubuntu/plymouth, and will be uploaded shortly. Please implement compatible handling in your package, and if necessary add a versioned dependency on plymouth 0.8.1-1, so that your package will play well with the theme handling targeted for lucid from the first upload.

Third, this theme has been constructed by cut-and-pasting the ubuntu-logo theme from the plymouth package, and that theme is still actively under development - you need to implement this in a way that doesn't duplicate the bugs whatever bugs happen to be in the current ubuntu-logo code. I would suggest that the correct way to accomplish this is by having your package Depend on plymouth-theme-ubuntu-logo and reference /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script directly as the ScriptFile in sabily.plymouth - then you just need to provide the same image set under the same names but in the /lib/plymouth/themes/sabily directory.

Provided that these packaging issues are addressed, FFe granted - this package is a clear successor to usplash-theme-sabily and sabily-xsplash-artwork and should be permitted in so we don't regress from karmic.

Changed in ubuntu:
importance: Undecided → Medium
Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote : Re: [Bug 543679] Re: Add a plymouth theme for sabily

Thanks,

On Fri, Mar 26, 2010 at 08:29:02AM -0000, Steve Langasek wrote:
> Third, this theme has been constructed by cut-and-pasting the ubuntu-
> logo theme from the plymouth package, and that theme is still actively
> under development - you need to implement this in a way that doesn't
> duplicate the bugs whatever bugs happen to be in the current ubuntu-logo
> code. I would suggest that the correct way to accomplish this is by
> having your package Depend on plymouth-theme-ubuntu-logo and reference
> /lib/plymouth/themes/ubuntu-logo/ubuntu-logo.script directly as the
> ScriptFile in sabily.plymouth - then you just need to provide the same
> image set under the same names but in the /lib/plymouth/themes/sabily
> directory.
---end quoted text---

Actually, I modified .script file a bit (modified the vertical positions
of the progress dots & labels). So I don't think that this suggestion
would work for me.

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :

Modified according to discussion above, and re-uploaded to REVU.

Revision history for this message
Steve Langasek (vorlon) wrote :

It's unfortunate that the script has to be modified to change the colors instead of being able to pass these as variables in the .plymouth file, but at least this is now in sync. FFe granted.

Changed in ubuntu:
status: New → Confirmed
Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :

Renamed the package to plymouth-theme-sabily & re-uploaded to: http://revu.ubuntuwire.com/details.py?upid=8040

Revision history for this message
Daniel Holbach (dholbach) wrote :

Unsubscribing sponsors for now. Seems Emmet uploaded it.

Revision history for this message
Daniel Holbach (dholbach) wrote :

Is sabily-plymouth-artwork on REVU still needed?

Revision history for this message
أحمد المحمودي (Ahmed El-Mahmoudy) (aelmahmoudy) wrote :

On Tue, Apr 06, 2010 at 08:18:46AM -0000, Daniel Holbach wrote:
> Is sabily-plymouth-artwork on REVU still needed?
---end quoted text---

I don't think so, since it is in the repository now:
http://packages.ubuntu.com/lucid/plymouth-theme-sabily

--
 ‎أحمد المحمودي (Ahmed El-Mahmoudy)
  Digital design engineer
 GPG KeyID: 0xEDDDA1B7
 GPG Fingerprint: 8206 A196 2084 7E6D 0DF8 B176 BC19 6A94 EDDD A1B7

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers