[FFe] [needs-packaging] mysql workbench package request

Bug #53062 reported by Mark Van den Borre on 2006-07-15
160
This bug affects 25 people
Affects Status Importance Assigned to Milestone
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned
Declined for Karmic by Micah Gersten
Declined for Lucid by Scott Kitterman

Bug Description

Hi there,

I would really like to have a nice package of MySQL Workbench. See http://dev.mysql.com/downloads/workbench/1.0.html

It seems like this is one of the only decent free software ERD tools available.

See also:
http://www.monkeyhelper.com/2006/07/mysql_workbench_and_ubuntu_dap.html

Thank you!

Mark

William Grant (wgrant) wrote :

This would be nice, but isn't practical until they fix the dependency on libsigc++ 2.0.11. Dapper uses 2.0.16, and Edgy something higher, and Workbench is broken on those versions.

2006/7/16, William Grant <email address hidden>:
> This would be nice, but isn't practical until they fix the dependency on
> libsigc++ 2.0.11. Dapper uses 2.0.16, and Edgy something higher, and
> Workbench is broken on those versions.

I reported this in http://bugs.mysql.com/21082 .

Mark

http://bugs.mysql.com/bug.php?id=16880

At least some work has been done. The bug has been closed. It's unclear though if the issue itself was fixed.

Philip Paquette (pcpaquette) wrote :

Setting package to libsigc++-2.0, so this bug gets out of the list of bugs without a package.
Can you confirm this bug still happens in edgy/feisty?
Should I close this bug since it has been closed upstream?
Thanks.

2007/4/17, Philip Paquette <email address hidden>:
> Setting package to libsigc++-2.0, so this bug gets out of the list of bugs without a package.
> Can you confirm this bug still happens in edgy/feisty?
> Should I close this bug since it has been closed upstream?
For as far as I know, the bug was inappropriately closed upstream.

Added a comment upstream to know if bug was fixed in 2.0.16+, setting this bug to confirmed.

Changed in libsigc++-2.0:
assignee: shooters → nobody
status: Needs Info → Confirmed
Daniel Holbach (dholbach) wrote :

Not a libsigc++-2.0 bug.

Changed in libsigc++-2.0:
importance: Undecided → Wishlist

"Please note that at this point only the Windows release is available. Linux and OS X releases will be available in 2008."

From http://dev.mysql.com/downloads/workbench/5.0.html

marcosdsanchez (marcosdsanchez) wrote :

There's a new Linux alpha release now.

It should be great to have this in the repositories.

Cymen Vig (cymenvig) wrote :

There are now Ubuntu source and binary packages for the alpha release on the download page:

http://dev.mysql.com/downloads/workbench/5.1.html

Frank Cheung (fcuk112) wrote :

which version should be packaged, 5.1 or 5.2 (alpha)?

Micah Gersten (micahg) wrote :

I suggest 5.1, it shouldn't be too hard to upgrade once the initial packaging is done, I would think.

hpp3 (hpp3) wrote :

5.2 is now Beta and packages for Karmic are available:
http://dev.mysql.com/downloads/workbench/5.2.html#downloads

Also note that MySQL Workbench is intended to replace MySQL Query Browser and MySQL Administrator.

agent 8131 (agent-8131) wrote :

I'd suggest packaging 5.2 Beta as it is a huge improvement over 5.1. It is a bit buggy, but then so is 5.1.

pfrenssen (pieter-frenssen) wrote :

MySQL Workbench 5.2 has been stable for a while now, and is now at release 5.2.34. I'd love to have this in the Ubuntu repository.

Changed in ubuntu:
status: Confirmed → In Progress
Changed in debian:
status: Unknown → Fix Committed
Changed in debian:
status: Fix Committed → Fix Released

Can we make this before Precise launch or it'is to late?

We don't have query mysql-query-browser in 12.04 LTS

Chad A. Davis (chadadavis) wrote :

Note that the deb provided for download on the MySQL site is linked against libzip1 because it was built for natty whereas precise now provides only libzip2. In other words, the package provided by MySQL no longer works out of the box on Ubuntu.

In the meantime, the simple (and risky) workaround:
sudo ln -sf /usr/lib/libzip.so.2 /usr/lib/libzip.so.1
sudo dpkg --force-depends -i ./mysql-workbench-gpl-5.2.38-1ubu1104-amd64.deb

If I could have only one client-side-mysql-tool, it would be mysql-workbench:
http://dev.mysql.com/downloads/workbench/#downloads

Please get this packaged before the next release; there's not much time left:
http://www.ubuntu.com/community/countdown

As Julian mentioned, the mysql tool-set is shrinking in recent repositories. This fact makes "packaging mysql-workbench" an even higher priority, in my opinion; it is a rich and cohesive tool that takes the place of multiple applications that are now missing from the repositories.

tags: added: precise
Jim Rorie (jfrorie) wrote :

@Lonnie: I expect Oracle will have a package shortly after Precise release, as they typically do.

Micah Gersten (micahg) wrote :

Subscribed the release team since there seems to be demand for this. Package builds fine on precise amd64.

summary: - [needs-packaging] mysql workbench package request
+ [FFe] [needs-packaging] mysql workbench package request
Changed in ubuntu:
status: In Progress → New
Lasana Murray (lmurray) wrote :

Is it stable on precise? Are there any crashes when editing foreign keys for example?

Scott Kitterman (kitterman) wrote :

Is this a proposed sync from Debian?

Jim Rorie (jfrorie) wrote :

FYI, when I compiled it, it wouldn;t let me administrate the servers. Threw an error. That why I grabbed the old packages.

Scott Kitterman (kitterman) wrote :

If someone can build/test 5.2.38+dfsg-3 from Debian Unstable and verify it works on precise, I don't mind doing this.

Benedikt (benedikt-klotz) wrote :

Hello,

I have build mysql-workbench 5.2.38+dfsg-3 from Sid with pbuilder without a problem!

After that i have tested the connection and managing of the official MySql in Precise without a problem.

I don't know if this is enough! If not, let me know i will then test it further.

Scott Kitterman (kitterman) wrote :

Ack. Approved. I'll do the new processing once another Ubuntu dev syncs it from Debian.

Micah Gersten (micahg) wrote :

This bug was fixed in the package mysql-workbench - 5.2.38+dfsg-3

---------------
mysql-workbench (5.2.38+dfsg-3) unstable; urgency=low

  * native server administration profile (Closes: #667714 I:"Creating new
    server instance profile fails...")
  * patch to fix ifconfig invocation
  * d-rules:
    + better CPU number detection
    + build with all but 'bindnow' hardening

 -- Dmitry Smirnov <email address hidden> Fri, 06 Apr 2012 23:00:35 +1000

mysql-workbench (5.2.38+dfsg-2) unstable; urgency=low

  * patch to fix FTBFS with glib 2.32
    (Closes: #665584 I:"individual glib headers no longer supported")
  * d-rules: get correct number of CPUs for parallel build on Linux
    (Closes: #665862 W:"Build process not is paralleled on some Linux
     architectures")

 -- Dmitry Smirnov <email address hidden> Tue, 27 Mar 2012 21:57:45 +1100

mysql-workbench (5.2.38+dfsg-1) unstable; urgency=low

  * first Debian release (Closes: #604174 ITP)
    Thanks to David Paleino

 -- Dmitry Smirnov <email address hidden> Thu, 01 Mar 2012 21:57:30 +1100

Changed in ubuntu:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Related questions

Remote bug watches

Bug watches keep track of this bug in other bug trackers.