[needs-packaging] Include PHP 5.3 in Lucid

Bug #522295 reported by Wido den Hollander on 2010-02-15
This bug affects 12 people
Affects Status Importance Assigned to Milestone
Nominated for Lucid by mycroes

Bug Description

Since Ubuntu 10.04 is becoming the new LTS, i would suggest including PHP 5.3 in this new release, since we have to use it for about 5 years.

I found a discussion on the "ubuntu-devel" list about this topic: https://lists.ubuntu.com/archives/ubuntu-devel/2010-February/030201.html

It seems that packaging PHP 5.3 wouldn't be a real problem, but it's not sure weather PHP 5.3 is going to make it into Lucid.

In my opinion PHP 5.3 has to be included in Lucid to make it a "future proof" LTS, packaging it with PHP 5.2 will push people towards PPA's where non-official 5.3 packages are supplied.

What's Ubuntu opinion on this topic?

tags: added: needs-packaging
description: updated
Japje (x-launchpad-japje-nl) wrote :

I agree, PHP 5.3 is a much better choise for the next LTS!

ISPI (randy-ispi) wrote :

Agree. This is a LTS version witch should last for 5 years. Therefore, any PHP version below 5.3 should be unacceptable.

Brian Murray (brian-murray) wrote :

*** This is an automated message ***

This bug is tagged needs-packaging which identifies it as a request for a new package in Ubuntu. As a part of the managing needs-packaging bug reports specification, https://wiki.ubuntu.com/QATeam/Specs/NeedsPackagingBugs, all needs-packaging bug reports have Wishlist importance. Subsequently, I'm setting this bug's status to Wishlist.

summary: - Include PHP 5.3 in Lucid
+ [needs-packaging] Include PHP 5.3 in Lucid
Changed in ubuntu:
importance: Undecided → Wishlist
Hugo Rodenburg (hugo-gardenrs) wrote :

I also agree. It would be very nice to have 5.3 included in 10.04.

Agreed, need's to be PHP5.3

chocoschijt (goedhartm) wrote :

I Agree, we need PHP5.3

lhoBas (bas-lh-online) wrote :

I totally agree, the LTS should ship with PHP5.3 in stead of PHP5.2.

If 5.3 is not included, we won't be able to use Zend Framework 2.0. This would mean I need to compile my own packages...

mycroes (mycroes) wrote :

On every new PHP 5.3 release there's the following line: "All users of PHP are encouraged to upgrade to this release." In other words, that means Ubuntu users, PHP 5.2 users and everyone else.

I personally don't know about any issues concerning PHP 5.3, but some of the features that are really important in PHP 5.3 are:
- namespaces
- late static binding
- __callStatic support

There's already some projects relying on features solely available in PHP 5.3, so I don't think upgrading to PHP 5.3 is optional.

description: updated

PHP 5.3 should be included in Ubuntu 10.04.

Andrés Felipe Vargas (andphe) wrote :

Then people using non PHP 5.3 compatible applications can't upgrade to the next LTS ? I think at least should be possible to go back and use PHP 5.2, the 5.2 branch of PHP still maintained for the PHP team so there is not reason to simply forget it and put an obstacle to upgrade the system becasue the PHP.

Sure we could have php5.2 and php5.3 packages, but if PHP 5.3 doesn't get included at all, this will hold back wide 5.3 development at least another 6 months.

Wido den Hollander (wido) wrote :

@Andrés Felipe Vargas:

The current LTS (8.04) is supported until 2013, so if upgrading is a problem, don't!

A LTS always bringes new features which could possibly break something, that's progression.

So no, i don't think upgrading should be the showstopper here.

PHP 5.3.1 is in lucid, I think this bug can be closed?


Wido den Hollander (wido) wrote :

Indeed, i set the bug to: Fix released

Changed in ubuntu:
status: New → Fix Released
Rick Vugteveen (rickvug) wrote :

Is there any effort to have a php 5.2 package also available as an option (perhaps php52 like in Macports)? I agree with everyone else that its time to move up to 5.3. However, there are applications that will have problems. In the Drupal community newer versions (6+) work fine with 5.3 but it is common for contributed modules to lag behind in support. When developers are working with dozens of modules per site compatibility problems will be inevitable.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers