[needs-packaging] right_http_connection

Bug #521006 reported by Scott Moser on 2010-02-12
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Medium
Scott Moser

Bug Description

Under blueprint https://blueprints.launchpad.net/ubuntu/+spec/server-lucid-aws-client-libraries we want to have right_aws packaged. right_http_connection is a dependency of right_aws.

 Rightscale::HttpConnection is a robust HTTP/S library. It implements a retry algorithm for low-level network errors.

URL: http://rightscale.rubyforge.org/
License: MIT/X

Note this package fulfills a dependency of right_aws (bug 521002).

Scott Moser (smoser) on 2010-02-12
tags: added: needs-packaging
Mathias Gug (mathiaz) wrote :

Looks good to me. Some minor comments:

1. The short description of the binary packages are all the same. I'd add a "for ruby1.X" at the end of the description for the -ruby1.X packages.

2. The full description for -ruby1.9 refers to ruby1.8.

3. Could you bump the Debian policy revision to the latest? You should go through the upgrade checklist to make sure the package is compliant with the new version (/usr/share/doc/debian-policy/upgrading-checklist.txt.gz from the debian-policy package).

Note that all these comments were found by running lucid lintian on the dsc file:

(l)mathiaz@mathiaz-srv:~/src/libright-http-connection-ruby$ lintian -IE --pedantic *dsc
I: libright-http-connection-ruby source: duplicate-short-description libright-http-connection-ruby1.8 libright-http-connection-ruby1.9 libright-http-connection-ruby
I: libright-http-connection-ruby source: duplicate-long-description libright-http-connection-ruby1.8 libright-http-connection-ruby1.9
W: libright-http-connection-ruby source: out-of-date-standards-version 3.8.3 (current is 3.8.4)

The resulting binaries look good to me as well.

Mathias Gug (mathiaz) wrote :

There is a copyright statement missing:

setup.rb is licensed under LGPL:

#
# setup.rb
#
# Copyright (c) 2000-2005 Minero Aoki
#
# This program is free software.
# You can distribute/modify this program under the terms of
# the GNU LGPL, Lesser General Public License version 2.1.
#

It should be added to debian/copyright.

Note that this was found by running "licensecheck ." in the top source directory.

Mathias Gug (mathiaz) wrote :

It seems that libuuidtools-ruby is only available for ruby1.8 in the archive.

Thus supporting ruby1.9 for right_http_connection isn't possible.

Fabrice Coutadeur (fabricesp) wrote :

Unsubscribing u-u-s: new packages should follow the process described at https://wiki.ubuntu.com/UbuntuDevelopment/NewPackages

Thanks,
Fabrice

Scott Moser (smoser) wrote :

Mathias,
 current state of linked branch addresses all your issues. Please re-review.

Mathias Gug (mathiaz) wrote :

Uploaded. I made the following changes:

1. Fix the ubuntu revision number to be 0ubuntu1 instead of 0ubuntu2.
2. Update Maintainer field to Ubuntu Developers <email address hidden>
3. Fix -doc package

Here is the full diff:

=== modified file 'debian/changelog'
--- debian/changelog 2010-02-16 16:11:43 +0000
+++ debian/changelog 2010-02-16 21:39:51 +0000
@@ -1,5 +1,6 @@
-right-http-connection (1.2.4-0ubuntu2) lucid; urgency=low
+right-http-connection (1.2.4-0ubuntu1) lucid; urgency=low

+ [ Scott Moser ]
   * Initial package release. (LP: #521006)

- -- Scott Moser <email address hidden> Tue, 16 Feb 2010 10:50:32 -0500
+ -- Mathias Gug <email address hidden> Tue, 16 Feb 2010 16:39:49 -0500

=== modified file 'debian/control'
--- debian/control 2010-02-16 15:54:05 +0000
+++ debian/control 2010-02-16 21:22:38 +0000
@@ -1,7 +1,7 @@
 Source: right-http-connection
 Section: ruby
 Priority: optional
-Maintainer: Ubuntu MOTU Developers <email address hidden>
+Maintainer: Ubuntu Developers <email address hidden>
 Build-Depends: debhelper (>= 7), cdbs, libsetup-ruby1.8, ruby-pkg-tools
 Build-Depends-Indep: rdoc (>= 1.8.1), graphviz, ruby
 Standards-Version: 3.8.4
@@ -16,7 +16,7 @@
  .
  This is the package for ruby 1.8.

-Package: libright-aws-ruby-doc
+Package: libright-http-connection-ruby-doc
 Architecture: all
 Section: doc
 Depends: ${misc:Depends}

Changed in ubuntu:
status: Confirmed → Fix Committed
Mathias Gug (mathiaz) on 2010-02-17
Changed in ubuntu:
status: Fix Committed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers