Sony Ericsson z750 and C702: Media Transfer mode fails but Mass Storage mode works

Bug #495721 reported by Boondoklife on 2009-12-12
24
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu
Wishlist
Unassigned

Bug Description

I am using Karmic 9.10

I am trying to mount my Sony Ericsson Z750a via usb on my computer.

I am able to mount the card and phone memory if I use the mass storage mode, but this disables my phone functions while using it. Less than ideal. Instead I want to use the media transfer mode, which acts just like the the usb transfer but allows for calls and sms messages to still come in.

I get quite a few errors with the media transfer mode, all seem to stem from it being seen as a camera in the udev rules.

If you need any more information, udev test outputs etc please let me know as I would love for this to just work.

Przemek K. (azrael) wrote :

I've got the same issue with SE C702. I'm getting an error: Error initialising camera: -60: Could not lock the device. See the attached screenshot. Mass storage mode works fine. In multimedia transfer mode I also can't transfer more than 128MB at once to the phone's flash card (4GB) - Ubuntu always sees exactly 128.4 MB of free space on the card in multimedia transfer mode.

Changed in ubuntu:
status: New → Confirmed
affects: ubuntu → udev (Ubuntu)
summary: - Sony Ericsson z750, Media Transfer mode fails but Mass Storage mode
- works
+ Sony Ericsson z750 and C702: Media Transfer mode fails but Mass Storage
+ mode works
Przemek K. (azrael) wrote :

Also the transfers in media transfer mode fail quite often, ie. 50% of the time. I often need to disconnect the phone and try again to make it work.

Przemek K. (azrael) wrote :

Similar bug: Bug #488504

Przemek K. (azrael) wrote :

More similar bugs:
Bug #485878
Bug #393092

Przemek K. (azrael) wrote :

Another similar bug: Bug #318939

Przemek K. (azrael) wrote :

The "Error initialising camera: -60: Could not lock the device" is still present in Ubuntu 10.04 (Lucid Lynx) when I connect the phone in "Phone mode" and "Multimedia transfer mode".
Mass storage mode works without this issue.

Martin Pitt (pitti) wrote :

This is not an udev issue, but needs to be handled in whatever application handles the device. It should probably be blocked from automounting then?

affects: udev (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Wishlist

The application in Ubuntu would be Nautilus (or some Gnome backend).

On 20 August 2010 12:29, Martin Pitt <email address hidden> wrote:
> This is not an udev issue, but needs to be handled in whatever
> application handles the device. It should probably be blocked from
> automounting then?
>
> ** Package changed: udev (Ubuntu) => ubuntu
>
> ** Changed in: ubuntu
>   Importance: Undecided => Wishlist
>
> --
> Sony Ericsson z750 and C702: Media Transfer mode fails but Mass Storage mode works
> https://bugs.launchpad.net/bugs/495721
> You received this bug notification because you are a direct subscriber
> of the bug.
>

--
## Przemysław Kulczycki <<=>> Azrael Nightwalker ##
# Jabber/XMPP/Gtalk/Tlen ID: azrael[na]jabster.pl #
# (Co to jest? Zobacz na: http://jabberfaq.info ) #
## www: http://reksio.ftj.agh.edu.pl/~azrael/ #####

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers