[needs-packaging] pyxpcom

Bug #480407 reported by Marcus Brinkmann on 2009-11-11
102
This bug affects 15 people
Affects Status Importance Assigned to Milestone
Sugar
New
Critical
Unassigned
Debian
Fix Released
Unknown
Ubuntu
Wishlist
Unassigned
Maverick
Wishlist
Chris Coulson

Bug Description

PyXPCOM allows for communication between Python and XPCOM, such that a Python application can access XPCOM objects, and XPCOM can access any Python class that implements an XPCOM interface. With PyXPCOM, a developer can talk to XPCOM or embed Gecko from a Python application. PyXPCOM is similar to JavaXPCOM (Java-XPCOM bridge) or XPConnect (JavaScript-XPCOM bridge).

URL: https://developer.mozilla.org/en/PyXPCOM
License: MPL 1.1/GPL 2.0/LGPL 2.1

David Farning (dfarning) on 2010-01-11
Changed in xulrunner-1.9.1 (Ubuntu):
status: New → Confirmed
Micah Gersten (micahg) wrote :

This needs to be created as a new source package: pyxpcom since upstream split it out from the main repository.

affects: xulrunner-1.9.1 (Ubuntu) → ubuntu
Changed in ubuntu:
importance: Undecided → Wishlist
status: Confirmed → New
summary: - should build python-xpcom
+ [needs-packaging] pyxpcom
Changed in ubuntu:
assignee: nobody → Micah Gersten (micahg)
description: updated
Changed in ubuntu:
milestone: none → lucid-alpha-3
description: updated
Micah Gersten (micahg) on 2010-01-12
description: updated
tags: added: needs-packaging
steubens (steubens) wrote :

the absence of this causes constant warning messages in repo builds of firefox once a second about parts of it that are present but "missing", ie. the files are on disk but its still complaining, affecting battery life; about:buildconfig says python is still being enabled, but from what i've seen its been gone/broken since before 8.04; if nothing has been reported as broken since then, or if there's nothing that depends on it working; why not just remove it from the builds?

from buildconfig:

Configure arguments
--build=x86_64-linux-gnu --prefix=/usr '--includedir=/usr/include' '--mandir=/usr/share/man' '--infodir=/usr/share/info' --sysconfdir=/etc --localstatedir=/var '--libexecdir=/usr/lib/xulrunner-1.9.1' --disable-maintainer-mode --disable-dependency-tracking --srcdir=. --enable-tests --enable-mochitest --enable-system-cairo --enable-system-sqlite --with-system-nspr --with-system-nss --enable-system-hunspell --enable-application=xulrunner --enable-extensions=default,python --with-default-mozilla-five-home=/usr/lib/xulrunner-1.9.1.8 --enable-safe-browsing --enable-startup-notification --with-user-appdir=.mozilla --without-system-jpeg --with-system-zlib=/usr --with-system-bz2=/usr --disable-javaxpcom --disable-crashreporter --disable-elf-dynstr-gc --disable-installer --disable-strip --disable-strip-libs --disable-install-strip --disable-updater --enable-optimize --with-distribution-id=com.ubuntu

to wit;
> --enable-extensions=default,python <

karmic -
firefox:
  Installed: 3.5.8+build1+nobinonly-0ubuntu0.9.10.1

Please file a new bug against Firefox for this with the output of the
warnings.

On 03/03/2010 08:32 PM, steubens wrote:
> the absence of this causes constant warning messages in repo builds of
> firefox once a second about parts of it that are present but "missing",
> ie. the files are on disk but its still complaining, affecting battery
> life; about:buildconfig says python is still being enabled, but from
> what i've seen its been gone/broken since before 8.04; if nothing has
> been reported as broken since then, or if there's nothing that depends
> on it working; why not just remove it from the builds?
>
> from buildconfig:
>
> Configure arguments
> --build=x86_64-linux-gnu --prefix=/usr '--includedir=/usr/include' '--mandir=/usr/share/man' '--infodir=/usr/share/info' --sysconfdir=/etc --localstatedir=/var '--libexecdir=/usr/lib/xulrunner-1.9.1' --disable-maintainer-mode --disable-dependency-tracking --srcdir=. --enable-tests --enable-mochitest --enable-system-cairo --enable-system-sqlite --with-system-nspr --with-system-nss --enable-system-hunspell --enable-application=xulrunner --enable-extensions=default,python --with-default-mozilla-five-home=/usr/lib/xulrunner-1.9.1.8 --enable-safe-browsing --enable-startup-notification --with-user-appdir=.mozilla --without-system-jpeg --with-system-zlib=/usr --with-system-bz2=/usr --disable-javaxpcom --disable-crashreporter --disable-elf-dynstr-gc --disable-installer --disable-strip --disable-strip-libs --disable-install-strip --disable-updater --enable-optimize --with-distribution-id=com.ubuntu
>
> to wit;
>
>> --enable-extensions=default,python<
>>
> karmic -
> firefox:
> Installed: 3.5.8+build1+nobinonly-0ubuntu0.9.10.1
>
>

Micah Gersten (micahg) wrote :

I'll try for beta 2 on this, but I'm not sure if we'll be able to do this for Lucid.

Changed in ubuntu:
milestone: lucid-alpha-3 → ubuntu-10.04-beta-2

On Fri, Mar 12, 2010 at 10:04 PM, Micah Gersten
<email address hidden> wrote:
> I'll try for beta 2 on this, but I'm not sure if we'll be able to do
> this for Lucid.

That's unfortunate, more because this is a LTS, but it's your time so
there's noting to complain about :)

Building virtualbox sdk depends on it, and building pyxpcom from
source is not as clear as one would expect.

--
 .
..: Lucian

Micah Gersten (micahg) wrote :

Since I like Virtualbox, I'll try to make a push for it :)

On 03/12/2010 02:19 PM, Lucian Adrian Grijincu wrote:
> On Fri, Mar 12, 2010 at 10:04 PM, Micah Gersten
> <email address hidden> wrote:
>
>> I'll try for beta 2 on this, but I'm not sure if we'll be able to do
>> this for Lucid.
>>
> That's unfortunate, more because this is a LTS, but it's your time so
> there's noting to complain about :)
>
> Building virtualbox sdk depends on it, and building pyxpcom from
> source is not as clear as one would expect.
>
>
>

Micah Gersten (micahg) wrote :

Missed Beta 2, will try for RC.

Changed in ubuntu:
milestone: ubuntu-10.04-beta-2 → ubuntu-10.04
Alexander Sack (asac) wrote :

unless the server team raises this as a priority, we wont get pyxpcom for lucid.

Micah Gersten (micahg) wrote :

I don't think this can happen for Lucid. If there is anything in the archive that actually depends on python-xpcom, please let us know. I don't see any rdepends for it at present in Lucid.

Changed in ubuntu:
assignee: Micah Gersten (micahg) → nobody
milestone: ubuntu-10.04 → none

There's no reverse dependency because python-xpcom isn't packaged again yet (see #352968 for the previous removal of python-xpcom). Catch-22.

See #459532 for an example of a package that requires python-xpcom. If you decide not to ship python-xpcom, you effectively make Sugar (the desktop / learning environment) unusable for the LTS as the web browser is used to download and install activities (applications) from activities.sugarlabs.org (the Sugar equivalent of addons.mozilla.org). Even more so since Ubuntu doesn't ship all of the most basic activities (e.g. Write is missing).
#364871 has another example for a package (pyjamas-desktop) breaking (indirectly via hulahop) due to python-xpcom being unavailable.

Changed in sugar:
importance: Undecided → Critical
Changed in debian:
status: Unknown → New
Chris Coulson (chrisccoulson) wrote :

This isn't going to happen for Maverick, and considering we are now beginning the transition to xulrunner 2.0 for Natty, I don't see this happening at all.

Chris Coulson (chrisccoulson) wrote :

Saying that, there is some work happening upstream to make it work with 2.0, so it might be possible for us to support it

Martin Pitt (pitti) on 2011-02-15
Changed in ubuntu:
assignee: Chris Coulson (chrisccoulson) → nobody
Changed in debian:
status: New → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.