Quickly skipping through songs doesn't update notify-osd

Bug #471499 reported by Vincent on 2009-11-02
38
This bug affects 7 people
Affects Status Importance Assigned to Milestone
Panflute
Low
Paul Kuliniewicz
Ubuntu
Low
Unassigned

Bug Description

Binary package hint: notify-osd

(I'm having a hard time describing this so I hope it's not reported yet and that it's understandable.)

When skipping through my music, the first song I listen to is then shown in a notification, but doesn't fade out until it's expired so that, when I quickly skip through multiple songs, I'm not notified of the later songs. This happens with both gmpc and the Panflute GNOME panel applet, so I'm guessing the error is on notify-osd's side. I'm assuming that if the applications didn't support updating an existing notification then at least the new notifications should be displayed below the previous one (as in on the screen, i.e. not stacked on top of eachother).

ProblemType: Bug
Architecture: i386
CheckboxSubmission: a798cb1661eb815dd3971de049912b99
CheckboxSystem: edda5d4f616ca792bf437989cb597002
CurrentDmesg:

Date: Mon Nov 2 20:03:37 2009
DistroRelease: Ubuntu 9.10
GtkTheme: Shiki-Brave
IconTheme: gnome-brave
MachineType: To Be Filled By O.E.M. To Be Filled By O.E.M.
NonfreeKernelModules: nvidia
Package: notify-osd 0.9.24-0ubuntu1
ProcCmdLine: BOOT_IMAGE=/boot/vmlinuz-2.6.31-14-generic root=UUID=b126a1f2-1715-48c1-8272-1c021c4449ad ro quiet splash
ProcEnviron:
 LANG=en_US.UTF-8
 SHELL=/bin/bash
ProcVersionSignature: Ubuntu 2.6.31-14.48-generic
RelatedPackageVersions:
 xserver-xorg 1:7.4+3ubuntu7
 libgl1-mesa-glx 7.6.0-1ubuntu4
 libdrm2 2.4.14-1ubuntu1
 xserver-xorg-video-intel 2:2.9.0-1ubuntu2
 xserver-xorg-video-ati 1:6.12.99+git20090929.7968e1fb-0ubuntu1
SourcePackage: notify-osd
Uname: Linux 2.6.31-14-generic i686
WindowManager: gnome-wm
dmi.bios.date: 11/04/2005
dmi.bios.vendor: American Megatrends Inc.
dmi.bios.version: 1014.001
dmi.board.name: P5P800
dmi.board.vendor: ASUSTeK Computer Inc.
dmi.board.version: Rev 1.xx
dmi.chassis.asset.tag: Asset-1234567890
dmi.chassis.type: 3
dmi.chassis.vendor: Chassis Manufacture
dmi.chassis.version: Chassis Version
dmi.modalias: dmi:bvnAmericanMegatrendsInc.:bvr1014.001:bd11/04/2005:svnToBeFilledByO.E.M.:pnToBeFilledByO.E.M.:pvrToBeFilledByO.E.M.:rvnASUSTeKComputerInc.:rnP5P800:rvrRev1.xx:cvnChassisManufacture:ct3:cvrChassisVersion:
dmi.product.name: To Be Filled By O.E.M.
dmi.product.version: To Be Filled By O.E.M.
dmi.sys.vendor: To Be Filled By O.E.M.

Related branches

Vincent (vinnl) wrote :
Sebastien Bacher (seb128) wrote :

thank you for your bug report, the issue is a client one, it should update the bubble rather sending a new one

Changed in notify-osd (Ubuntu):
importance: Undecided → Low
affects: notify-osd (Ubuntu) → ubuntu
Changed in panflute:
status: New → Confirmed
importance: Undecided → Low
assignee: nobody → Paul Kuliniewicz (kuliniew)
milestone: none → 0.7.0
Changed in panflute:
status: Confirmed → Fix Committed
Changed in panflute:
status: Fix Committed → Fix Released
Dàrent (animaletdesequia) wrote :

I had this issue in maverick too. Installing a patched version of notify-osd solved it, and not only that, this ppa came with a notify-osd conifig than allows you to completely configure it (height, position, delay, colors, background, fons...). Unfortunatelly, in that ppa:

"Launchpad Leolik's PPA"
ppa:leolik/leolik

There's no version for natty so i have the problem again. And i can't just install the maverick .deb manually since it's an old version and doesn't let me install it (I supose i could unninstall the official package trough synaptic and install the outdated version for maverick but i don't want to risk the whole system since notify-osd is so linked to the gnome-desktop)

A solution, patch or workarround would be apreciated :) Thanks

Launchpad Janitor (janitor) wrote :

Status changed to 'Confirmed' because the bug affects multiple users.

Changed in ubuntu:
status: New → Confirmed
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers