sync, merges and FFe's need for getting maven built

Bug #443292 reported by Matthias Klose on 2009-10-05
16
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned
Karmic
Undecided
Unassigned

Bug Description

needed to build the current unbuildable maven packages (all universe):

FFe & merges:
 - doxia: FFe, merge 1.1.1-1

FFe & syncs:
 - modello: FFe, sync 1.1-1
 - plexus-interpolation: FFe, sync 1.11-2
 - plexus-containers: FFe, sync 1.0~beta3.0.7-3
 - maven-debian-helper: FFe, sync 0.6
 - maven-site-plugin, FFe, sync 2.0-2
 - maven-plugin-tools, FFe, sync 2.5-2
 - maven-clean-plugin FFe, sync 2.3-3
 - maven-doxia-tools, FFe, sync 1.0.2-2

syncs:
 - plexus-cdc, sync 1.0~alpha14-3
 - surefire: sync 2.4.3-3
 - maven-resources-plugin, sync 2.3-5
 - maven-jar-plugin, sync 2.2-4
 - maven-compiler-plugin, sync 2.0.2-4
 - plexus-maven-plugin, sync 1.3.8-4

Related branches

Matthias Klose (doko) wrote :

simple sync requests tracked in bug #443320

Matthias Klose (doko) wrote :

packages in debian, but not in karmic:

netbeans-cvsclient
plexus-ant-factory
libcommons-net2-java
plexus-cipher
plexus-sec-dispatcher

StefanPotyra (sistpoty) wrote :

yes, please, I'm all for getting maven back into shape. +1.

Ack 2. Approved. Someone please set to confirmed.

StefanPotyra (sistpoty) on 2009-10-06
Changed in ubuntu:
status: New → Confirmed
Matthias Klose (doko) wrote :

sync requests of new upstream versions tracked in bug #444714

Matthias Klose (doko) wrote :

doxia sync request in bug #446263, ubuntu changes can be discarded

Artur Rona (ari-tczew) wrote :

duplicate of bug #427539 ?

Martin Pitt (pitti) wrote :

I did the simple syncs, and ignored the doxia one since doko said he'd upload that manually in bug 446263.

I also synced and source-NEWed the new packages from Debian from comment 2.

Martin Pitt (pitti) wrote :

FFE&syncs packages synced as well.

Changed in ubuntu:
status: Confirmed → Fix Released
Matthias Klose (doko) wrote :

there is more ...

  http://people.canonical.com/~doko/ubuntu-diff/status/maven.html

I'll try to build packages from a fresh karmic chroot this weekend. I'd like to have pre-approval from motu-release for necessary syncs from unstable for packages found on this page.

Changed in ubuntu:
status: Fix Released → New
StefanPotyra (sistpoty) wrote :

ACK from me. Please make sure to not break (non-maven) things though. Thanks!

Scott Kitterman (kitterman) wrote :

Ack #2. Approved.

Matthias Klose (doko) wrote :

There are still some changes required in packages found in main:

 - promotion of maven-ant-helper and maven-repo-helper, which are used
   as build dependencies to add some meta-information (maven POM) to the built
   jars. See bug #454621.

 - syncs of some packages in main (no new upstream versions), which add
   this meta data to the jar files. See bug #446263.

 - merges of some packages in main (no new upstream versions), which add
   this meta data to the jar files. See bug #454822

 - more syncs (unstable -> universe). See bug #454826

Thierry Carrez (ttx) wrote :

As far as Ubuntu Server is concerned, just adding missing POM information (but no version upgrades, code changes or existing file relocation) should be alright.

Matthias Klose (doko) wrote :

maven2-core is now built. waiting for approval (and upload) after the release candidate as tracked in bug #454822:

 - backport-util-concurrent
 - commons-beanutils
 - qdox
 - libcommons-cli-java (maybe, new upstream version)

Matthias Klose (doko) on 2009-10-21
Changed in ubuntu:
status: New → In Progress
Martin Pitt (pitti) wrote :

> - backport-util-concurrent
> - commons-beanutils
> - qdox

Accepted, thanks.

> - libcommons-cli-java (maybe, new upstream version)

Not in unapproved yet. Is that necessary to get maven working, or just a "nice to have"?

Thierry Carrez (ttx) wrote :

@Martin:
Matthias is still missing two pieces of information to make the good choice on commons-cli:
1/ Does eucalyptus show any regression when run with commons-cli 1.2 rather than 1.1 ? (upstream analysis in progress, our testing reports its OK)
2/ Does maven work well enough with 1.1 ? (it builds, does it run ?)

If eucalyptus doesn't regress AND maven is unusable without 1.2, then we should consider moving to 1.2
IMO for any other combination we should just keep 1.1.

Thierry Carrez [2009-10-23 6:52 -0000]:
> @Martin:
> Matthias is still missing two pieces of information to make the good choice on commons-cli:
> 1/ Does eucalyptus show any regression when run with commons-cli 1.2 rather than 1.1 ? (upstream analysis in progress, our testing reports its OK)
> 2/ Does maven work well enough with 1.1 ? (it builds, does it run ?)
>
> If eucalyptus doesn't regress AND maven is unusable without 1.2, then we should consider moving to 1.2
> IMO for any other combination we should just keep 1.1.

IMO, if 2 is true, we shouldn't even bother spending time to test 1.

Matthias Klose (doko) wrote :

not yet there, I *think* that it will at least build, so we'll have to test when it's there

Matthias Klose (doko) wrote :

the maven package is now built. I think we should handle eventual patches/updates post-release.

Martin Pitt (pitti) wrote :

Unsubscribing ubuntu-archive, nothing to do here ATM.

Matthias Klose (doko) wrote :

bug #461090 now has the changes proposed for karmic-updates, which didn't make into karmic until the release.

Artur Rona (ari-tczew) wrote :

@ Matthias,
could you review this bug #446282 because it's about maven2 2.2.1.

Matthias Klose (doko) wrote :

The following packages need no-change uploads for karmic-proposed:

No build fauilures:
maven-war-plugin
maven-javadoc-plugin
maven-invoker-plugin
maven-ejb-plugin
maven-ear-plugin
maven-antrun-plugin
doxia-maven-plugin
clirr-maven-plugin

Build failures:
maven-repository-builder
plexus-active-collections

Dependency wait:
maven-assembly-plugin

See https://launchpad.net/~ubuntu-java/+archive/maven/+packages for the build logs

Scott Kitterman (kitterman) wrote :

Note for motu-sru: These are pre-uploaded for immediately post release. Unsubscibing motu-release since we're done.

Changed in ubuntu:
milestone: none → ubuntu-9.10
Steve Langasek (vorlon) wrote :

TTBOMK, these are done now.

Changed in ubuntu:
status: In Progress → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers