Karmic don´t see windows network

Bug #425994 reported by Fabricio1981 on 2009-09-07
20
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Karmic Don´t see windows network, can´t access to shared folder in windows, can´t see printers, when i use winbind and activate wins, only see the files but the printers still dosen´t work

EDIT: When i click in network, i see the windows network, called GRUPO_TRABAJO, but when i try to acces to the network, shows a screen telling this: "Opening GRUPO_TRABAJO" and after a few seconds show this: "can´t acces to GRUPO_TRABAJO". The same happeng in ubuntu 9.04 but in ubuntu 8.10 work, whit the same windows network.My network is called GRUPO_TRABAJO(i from argentina) and not WORKGROUP, but this is no soo important, samba-common not see the shared folder in windows network. The problem is partially fix when i install windows bind, i can acces perfectly to my shared folders in windows network, but the printer shared still don´t work.

edit2: this is in the log
2009/09/09 14:33:40, 0] smbd/server.c:456(smbd_open_one_socket)
  smbd_open_once_socket: open_socket_in: Dirección ya está en uso (Address already in use)

edit3: I completed the report in accordance with the guidelines of the wiki

What version of samba packages are used ?
root@SERVER:/# dpkg-query -W -f='${Package} ${Version} ${Source} ${Status}\n' | grep samba
gadmin-samba 0.2.7-2 deinstall ok config-files
libpam-smbpass 2:3.4.0-3ubuntu5.1 samba deinstall ok config-files
libsmbclient 2:3.4.0-3ubuntu5.1 samba install ok installed
libwbclient0 2:3.4.0-3ubuntu5.1 samba install ok installed
samba 2:3.4.0-3ubuntu5.1 install ok installed
samba-common 2:3.4.0-3ubuntu5.1 samba install ok installed
samba-common-bin 2:3.4.0-3ubuntu5.1 samba install ok installed
swat 2:3.4.0-3ubuntu5.1 samba deinstall ok config-files
system-config-samba 1.2.63-0ubuntu4 deinstall ok config-files

How is the remote share accessed from the Ubuntu system?
smbclient

If nautilus (or another GUI client) is used to access the remote share, can the share be accessed with the smbclient command line utility ?
root@SERVER:/# smbclient //server/studio
Enter root's password:
Domain=[STUDIO] OS=[Unix] Server=[Samba 3.4.0]
Server not using user level security and no password supplied.
smb: \>

If a cifs mount is used (/dev/sda2/)
the content of the file /etc/fstab
# /etc/fstab: static file system information.
#
# Use 'blkid -o value -s UUID' to print the universally unique identifier
# for a device; this may be used with UUID= as a more robust way to name
# devices that works even if disks are added and removed. See fstab(5).
#
# <file system> <mount point> <type> <options> <dump> <pass>
proc /proc proc defaults 0 0
# / was on /dev/sdb1 during installation
UUID=2e8b0010-63a6-442a-a43f-ea2b00e98f2d / ext4 errors=remount-ro 0 1
# swap was on /dev/sdb5 during installation
UUID=18e0c1fb-2a13-4771-9295-b5fd29bbd585 none swap sw 0 0
/dev/scd0 /media/cdrom0 udf,iso9660 user,noauto,exec,utf8 0 0
/dev/fd0 /media/floppy0 auto rw,user,noauto,exec,utf8 0 0
#disco archivio
/dev/sda2 /media/disk reiserfs defaults 0 0

/proc/fs/cifs/DebugData
the file is empty

What is the remote server ?
root@SERVER:/# smbclient -L //server
Enter root's password:
Domain=[STUDIO] OS=[Unix] Server=[Samba 3.4.0]

        Sharename Type Comment
        --------- ---- -------
        Studio Disk
        IPC$ IPC IPC Service (SERVER samba)
Domain=[STUDIO] OS=[Unix] Server=[Samba 3.4.0]

        Server Comment
        --------- -------
        SCANNER Scanner in Segreteria
        SERVER SERVER samba

        Workgroup Master
        --------- -------
        STUDIO SCANNER

Nicola Ferralis (feranick) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better. Unfortunately we can't fix it without more information.

Please include the information requested at https://wiki.ubuntu.com/DebuggingSamba#samba-client.

Changed in ubuntu:
status: New → Incomplete
Fabricio1981 (depdepcentra) wrote :

When i click in network, i see the windows network, called GRUPO_TRABAJO, but when i try to acces to the network, shows a screen telling this: "Opening GRUPO_TRABAJO" and after a few seconds show this: "can´t acces to GRUPO_TRABAJO". The same happeng in ubuntu 9.04 but in ubuntu 8.10 work, whit the same windows network.My network is called GRUPO_TRABAJO(i from argentina) and not WORKGROUP, but this is no soo important, samba-common not see the shared folder in windows network. The problem is partially fix when i install windows bind, i can acces perfectly to my shared folders in windows network, but the printer shared still don´t work.

description: updated
tags: added: samba
description: updated
Grzegorz Śliwiński (fizyk) wrote :

Same thing happened to me. Actually it was working on Karmic for the last two weeks, when I set up my ufw to work with samba, and other home computers, and suddenly, today I don't have anything in my network window apart from workgroup, like Fabricio wrote. Same thing happened on my other ubuntu pc with Ubuntu 9.04 where it was also working fine.

1.
dpkg-query -W -f='${Package} ${Version} ${Source} ${Status}\n' | grep samba:

libpam-smbpass 2:3.4.0-3ubuntu5 samba install ok installed
libsmbclient 2:3.4.0-3ubuntu5 samba install ok installed
libwbclient0 2:3.4.0-3ubuntu5 samba install ok installed
samba 2:3.4.0-3ubuntu5 install ok installed
samba-common 2:3.4.0-3ubuntu5 samba install ok installed
samba-common-bin 2:3.4.0-3ubuntu5 samba install ok installed
smbclient 2:3.4.0-3ubuntu5 samba install ok installed

2.
We're using nautilus to connect to samba shares and it works to connect to the samba shares using smbclient //remote_system/share_name it requires a password to guest readable shares.

3.
smbclient -L //remote_system
Domain=[WORKGROUP] OS=[Unix] Server=[Samba 3.3.2]

So, as I understand from the DebugginSamba page, problem is with nautilus.

Dario (dario657) wrote :

I would add to the problem
I found that if you restart the system sharing works
but if you turn off from the problem described

description: updated
Changed in ubuntu:
status: Incomplete → Confirmed
Dario (dario657) wrote :

hi
updated with new packages out yesterday the problem is resolved.

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers