error message on boot: unknown argument '--no-floppy'

Bug #391382 reported by stovalo on 2009-06-23
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I just did a system update on Ubuntu 9.10 with Ubuntustudio. The system first did some updates en re-checked and than did a partial upgrade. Finaly the systems asked to do a restart. On restart,on chosing wathever version from the (blue) picking list, i get the message as stated the first time, then, on chosing the same kernel the second time, nothing happens any more.
I removed the floppy drive from the bootsequence in the bios, but nothing changes.
Kernel 2.6.30-10-generic (after the update/upgrade) AMD64
Intel Pentium D 3.0Ghz, 3GB ram
AwardBios 1.0D (10/07/05)
Bootsequence: CD-Rom, HD, LAN

Any suggestions on how to start my PC without re-installing from CD ?
Thanks

Bart Kroon (tarmack) wrote :

To start your system you should select your kernel of choice, press 'e'
here you select the line starting with 'kernel' and again type 'e'
now you can edit this line, remove the --no-floppy kernel argument, type 'return'.
than if you press 'b' the system should boot, provided this was the only problem preventing it to start.

Now to make these changes permanent edit /boot/grub/menu.lst

P.S. it is posible you have grub2 installed, this may differ from my axplanation but this should push you in the right direction.

stovalo (geert-vanloo) wrote :

Hello Bart,

I removed the argument --no-floppy and rebooted with ctrl-X, and everything went well. Thank You! (grub 1.96 indeed)
Anyhow, maybe it's interesting to know that when I tried to boot without changing this and tried to edit after I got the message, the only line that was displayed was "set root = (hd0,3)". All the other lines were gone, making the system not even react on chosing this kernel. After powering off and on again, all the lines were back and editing was possible.

Thank you for your swift reaction.
Dank u wel.

Geert

Bart Kroon (tarmack) wrote :

This may be intended but I don't expect it to be, I sugest you file a bug report on that.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers