Python-devel not found during HPlip install

Bug #390194 reported by Ben
20
This bug affects 4 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Binary package hint: gnome-terminal

Since the Ubuntu 9.04 upgrade I coudn't upgrade the HPlip application.
the HPlip application was still present in accesories but didn't work any longer
During the HPlip install following info is gathered
ben@billaptop:~$ cd desktop
bash: cd: desktop: No such file or directory
ben@billaptop:~$ cd desktop
bash: cd: desktop: No such file or directory
ben@billaptop:~$ cd
ben@billaptop:~$
ben@billaptop:~$ cd Desktop
ben@billaptop:~/Desktop$ hplip-3.9.6.run
bash: hplip-3.9.6.run: command not found
ben@billaptop:~/Desktop$ sh hplip-3.9.6.run
Creating directory hplip-3.9.6
Verifying archive integrity... All good.
Uncompressing HPLIP 3.9.6 Self Extracting Archive......................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................................

HP Linux Imaging and Printing System (ver. 3.9.6)
HPLIP Installer ver. 5.1

Copyright (c) 2001-9 Hewlett-Packard Development Company, LP
This software comes with ABSOLUTELY NO WARRANTY.
This is free software, and you are welcome to distribute it
under certain conditions. See COPYING file for more details.

Installer log saved in: hplip-install_Sun-21-Jun-2009_12:52:57.log

/
note: Defaults for each question are maked with a '*'. Press <enter> to accept the default.

INSTALLATION MODE
-----------------
Automatic mode will install the full HPLIP solution with the most common options.
Custom mode allows you to choose installation options to fit specific requirements.

Please choose the installation mode (a=automatic*, c=custom, q=quit) : a

Initializing. Please wait...

INTRODUCTION
------------
This installer will install HPLIP version 3.9.6 on your computer.
Please close any running package management systems now (YaST, Adept, Synaptic, Up2date, etc).

DISTRO/OS CONFIRMATION
----------------------
Distro appears to be Ubuntu 9.04.

Is "Ubuntu 9.04" your correct distro/OS and version (y=yes*, n=no, q=quit) ? y

ENTER ROOT/SUPERUSER PASSWORD
-----------------------------
Please enter the root/superuser password:
Password incorrect. 2 attempt(s) left.
Please enter the root/superuser password:
Password accepted

INSTALLATION NOTES
------------------
Enable the universe/multiverse repositories. Also be sure you are using the Ubuntu "Main" Repositories. See: https://help.ubuntu.com/community/Repositories/Ubuntu for more information. Disable the CD-ROM/DVD source if you do not have the Ubuntu installation media inserted in the drive.

Please read the installation notes. Press <enter> to continue or 'q' to quit:

RUNNING PRE-INSTALL COMMANDS
----------------------------
OK

CHECKING FOR NETWORK CONNECTION
-------------------------------
Network connection present.

RUNNING PRE-PACKAGE COMMANDS
----------------------------
sudo dpkg --configure -a (Pre-depend step 1)
sudo apt-get install --yes --force-yes -f (Pre-depend step 2)
sudo aptitude update (Pre-depend step 3)
OK

DEPENDENCY AND CONFLICT RESOLUTION
----------------------------------
warning: A previous install of HPLIP is installed and/or running.
sudo apt-get remove --assume-yes hplip hpijs foomatic-db-hpijs (Removing old HPLIP version)
warning: HPLIP removal failed. The previous install may have been installed using a tarball or this installer.
warning: Continuing to run installer - this installation should overwrite the previous one.

RUNNING POST-PACKAGE COMMANDS
-----------------------------
OK

RE-CHECKING DEPENDENCIES
------------------------
OK

PRE-BUILD COMMANDS
------------------
OK

BUILD AND INSTALL
-----------------
Running './configure --with-hpppddir=/usr/share/ppd/HP --prefix=/usr --enable-qt4 --enable-doc-build --disable-cups-ppd-install --disable-foomatic-drv-install --disable-foomatic-ppd-install --disable-hpijs-install --enable-policykit --enable-cups-drv-install --enable-hpcups-install --enable-network-build --enable-dbus-build --enable-scan-build --enable-fax-build'
Please wait, this may take several minutes...
error: Configure failed with error: python-devel not found
ben@billaptop:~/Desktop$

Can someone help me?
with thanks in advance
B.E.

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
ExecutablePath: /usr/bin/gnome-terminal
Package: gnome-terminal 2.26.0-0ubuntu2
ProcEnviron:
 LANG=en_GB.UTF-8
 SHELL=/bin/bash
SourcePackage: gnome-terminal
Uname: Linux 2.6.28-13-generic i686

Revision history for this message
Ben (ben-eeman) wrote :
Revision history for this message
Ben (ben-eeman) wrote :

By uninstalling the C 6200 printer driver etc selecting also uninstall for HPlip via add/remove software I have now installed the HPlip and see back the nice round HP logo on top of the screen oef
the re-installation of the printer driver is also working C6200 ...and it prints (did not check photo print yet)

In the applications menu I find under office the HP fax address book as well as fax utility

The HP photosmart C 6280 all in one printer is recognised via sytem / administration / printing as HP C 6200 so I suppose everything is back to normal now

thanks
B.E.

Revision history for this message
Pedro Villavicencio (pedro) wrote :

That's not a gnome-terminal issue.

affects: gnome-terminal (Ubuntu) → ubuntu
Revision history for this message
Dennis Craven (dcraven) wrote :

Thanks for filing the bug. I'm going to mark this bug as invalid since the problem seems to be resolved if I read the comments correctly. If this decision is incorrect, please feel free to reopen and add more comments as you see fit. Thanks.

Changed in ubuntu:
status: New → Invalid
Revision history for this message
Ben (ben-eeman) wrote : Re: [Bug 390194] Re: Python-devel not found during HPlip install

Many thanks for your prompt follow up

Ben
Dennis Craven wrote:
> Thanks for filing the bug. I'm going to mark this bug as invalid since
> the problem seems to be resolved if I read the comments correctly. If
> this decision is incorrect, please feel free to reopen and add more
> comments as you see fit. Thanks.
>
> ** Changed in: ubuntu
> Status: New => Invalid
>
>
Man

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers