Mouse focus gets stuck over control objects

Bug #375905 reported by SteveWin1
This bug affects 23 people
Affects Status Importance Assigned to Milestone
Nominated for Maverick by Jakob Eriksson

Bug Description

This bug started for me and for others on the above thread after installing Ubuntu 9.04. Most, if not all, people with this problem are using a wireless logitech mouse (even someone back in 2005 had a similar problem and was using a logitech mouse -- see his thread at the bottom). I think it would be easiest to just copy and paste most of what I wrote in the forum:

While the mouse appears to be freely moving around the screen, it is actually getting stuck inside control objects (button, tab, edit box, menu item, slider bar, etc). The mouse cursor appears to move around the screen just fine, but when I click, nothing happens (because the mouse is still clicking inside the area in which it is actually trapped -- not where the cursor appears to be). If I hold the cursor over a hyperlink, the hyperlink is not underlined like normal and buttons that normally light up when the cursor is over them fail to do so. If the mouse is trapped in a slider bar, I can go back and move the slider bar around with the mouse and it works fine, but I cannot get the focus out of that control object by using the mouse and cannot use adjacent slider bars using the mouse. The tab key can be used to move the focus around in dialog boxes or on webpages and you can type in other fields or use the arrow keys to move slider bars around, but as soon as you click the mouse, the focus goes right back to the box or slider bar or whatever has the mouse trapped. If I click the right mouse button anywhere on the screen, the pop-up menu that would have come up if I had actually right clicked on the area where the mouse is trapped comes up with one corner of the box at the location of the traped (invisible) mouse and not where the mouse cursor appears to be. You can then left click somewhere to get rid of that box and the problem is fixed temporarily (until a few more clicks lands the cursor back in jail somewhere). The menu popping up seems to free the mouse cursor. If the mouse gets stuck somewhere where nothing happens when you right click, I can also free the mouse by closing whatever window has the cursor trapped. ALT + F4 or tabbing to a close button on a dialog box also frees the cursor. Unfortunately, sometimes you're at the desktop when the cursor gets trapped in some random area and right click does nothing and there's no window to close. In this instance unplugging the mouse and plugging it back in is a last resort and always works. This also seems to correct this problem for a very long time, instead of just seconds to minutes.

I am fairly certain that this is the same problem that most of the people on this thread are having and I am also fairly certain that the problem is that the mouse (or the mouse's focus) is getting trapped, even though it appears to be moving freely around the screen, and can only be freed by causing another window to steal the focus (like a pop-up menu when right clicking), closing the window that has trapped the mouse, or unplugging the usb cord for the mouse. Sometimes right clicking doesn't work, but using the keyboard button that does the same ting as the right mouse button (looks like a menu with a mouse cursor over it) DOES work and vice versa (not sure why).

The frequency of this problem is analogous to someone with the flu coughing. When you've got the flu, you cough randomly, but you go a few years without the flu and don't cough. This problem will not occur for a day or two and then will start happening very frequently until the mouse is unplugged. Using any other method described above to solve the problem is very temporary and the mouse will get stuck again in a matter of minutes. After unplugging the mouse and plugging it back in, I'll go for days without the problem and then it will randomly start occuring again. I am not sure what causes this to start happening. It has started occurring while using multiple different programs and even when I don't have a program open and am viewing the desktop.

This problem is extremely frustrating. I hope someone figures out what's wrong. I keep hoping the new updates that ubuntu installs are going to fix the problem, but they haven't. Logitech is a pretty common brand of mouse, so I think this bug would be worthwhile to address.

The exact same thing seems to have happened to someone back in 2005

ProblemType: Bug
Architecture: i386
DistroRelease: Ubuntu 9.04
Package: firefox-3.0 3.0.10+nobinonly-0ubuntu0.9.04.1
SourcePackage: firefox-3.0
Uname: Linux 2.6.28-11-server i686

Revision history for this message
SteveWin1 (stevewin1) wrote :
affects: ubuntu → logitech-applet (Ubuntu)
Revision history for this message
BorgHunter (borghunter) wrote :

I can reproduce this behavior on my Logitech MX1000 in Fedora 11 by holding down the scroll wheel button ("clicking" the scroll wheel but not releasing the click).

1. Hover cursor over e.g. an empty portion of a GNOME panel, or a launcher icon on the panel.
2. Click and hold down scroll wheel button and move cursor away from the panel, as if dragging it with the scroll wheel.
3. Right click mouse button (still holding down the scroll wheel button)

What results from the above steps is the context menu that you'd get from right clicking on whatever icon you "dragged" away from.

Revision history for this message
Pete (pvandoren) wrote :

I too am experience this issue, as described almost daily, with today being especially troublesome.

My system is a DELL Precision M6400 running ubuntu 9.04 (64 bit). I have seen issues with both the built in mouse-pad on this laptop, and external DELL usb wheel mouse.

Sometimes if I switch between the two mouse devices, I am able to re-gain control momentarily, othertimes, this doesn't help.

Other issues, is a see random mouse movements, (IE the cursor will move across the screen without touching the mouse), and what act like random stuck mouse buttons. (IE I'll get a instant click, when I highlight a button, or it will act like one of the buttons is held down on the mouse. and will cause either block highlighting, and/or right click menus to appear.

Un-plugging and re-plugging the USB mouse doesn't clear this issue. Most of the time I have to re-boot the machine to clear the issue, or if I randomly click buttons on the two mice (the USB, and touch-pad), I can sometimes get it to clear up enough for me to continue working for a bit.

Some of the forums suggested it might be an issue with the video driver, so I updated to the latest video driver as of today (from NVIDIA version 185.18.14, and I am still seeing these issues.

This is very frustrating, and for me at least seems to have gotten worse this last week. but like the previous poster stated, it's like the Flu, when you have it you see it a lot, but then it goes away for awhile where you hardly have any issues..

Revision history for this message
Dimitri Koussa (dimitri-koussa) wrote :

Went away for a while but now it's back and like the Pete described when it's back it's really bad. Right now it makes my system very unusable.
I'm running 9.10 with an ATI Radeon 5850 running fglrx. Oh, and I've got a wireless Logitech mouse (MX1000).
Let me know if more info is required.

Revision history for this message
Jethro_uk (jethro-uk) wrote :

After a while playing with this problem, I have got it down to be an annoyance, rather than a showstopper.

Not being a Linux guru, my opinions are of limited value, but I firmly believe this is an X-Server/XOrg problem. I've seen it happen under GNOME and KDE, and with all combinations of window managers, and decorators.

There appears to be a connection with ALT-TAB ... as soon as the mouse focus issue happens, you lose ALT-TAB.

Anyway, I have discovered that if I activate ALT-TAB as soon as I login, it seems to "protect" my system, and I don't seem to lose mouse focus.

I have also discovered, that CTL-ALT-D (show desktop) seems to recover mouse focus ... once all windows are minimised to the taskbar, then ALT-TAB seems to work again, and mouse focus is restored. Hopefully this workaround will prove useful to people, and can remove the need to logout/login again, or to restart the machine with the loss of data that implies.

Revision history for this message
MrLogistiX (kebrown) wrote :

I have the same issue using a Logitech MX1100 mouse on clean install of Ubuntu 9.10, re-re-retired Dell Dimension 2400. Found a workaround, but no fix: when the mouse stops responding (usually after switching back to the KVM port the Linux box is connected to), I power the mouse off using the switch on the bottom, then wait 5 secs or so, power back up. Has worked every time so far. I was THIS close to scrapping Karmic for, I dunno, anything? until I tried this. BTW, unplugging, right-clicking, etc, never worked.

Revision history for this message
IndyCore (jan-kjerbye) wrote :

Same issue on fresh 9.10 and even on a 10.04 alpha 2. Dell Mini 9.

Any fixes/suggestions?

The Ctrl-Alt-D works every time, but i loose focus (only on SOME elements weirdly enough) soon after.

Considering installing 8.04 again to make it usable.. or maybe win7 .. * shudder *

Revision history for this message
IndyCore (jan-kjerbye) wrote :

I just tried to install OpenBox and doing a openbox --replace.. Same error.. Back to metacity.

Revision history for this message
IndyCore (jan-kjerbye) wrote :

Is the Xorg fix in the end of the thread not included in the latest xorg???

Revision history for this message
ipx (viktor-knutsson) wrote :

What IndyCore was referring to I believe is this:

There is a fix in there from feb 09, should'nt this already be included in 9.10?

Revision history for this message
michboy (stevenpeters) wrote :

This just happened to me for the first time today, with 9.10 and a wireless Logitech M-RR67A mouse.

Revision history for this message
i30817 (i30817) wrote :

happens to me too. I installed the ppa from the xorg edgers driver only repo if it matters.

Revision history for this message
klk (kkassing) wrote :

After a long time without seeing this bug, it has come back in full force - X is basically unusable. Upgrading to latest maverick didn't change anything. I am running XFCE, and can reproduce the bug in the following way right after starting X:

1. Open xfce4-terminal by way of keyboard shortcut
2. Click inside the window, causing the cursor to get stuck as the text cursor
3. $ killall xfwm4, which gets the focus unstuck, but xfwm4 is automatically restarted by x-session-manager
4. Clicking in the xfce4-terminal window causes focus to stick immediately

The Ctrl+Alt+D shortcut also only gives me the briefest reprieve from this buggy behavior.

I am using a Logitech LX6 wireless mouse.

Revision history for this message
klk (kkassing) wrote :

As I said before, this bug manifests for me immediately after starting X, but apparently only the first time X is started after booting up. If I open an X session, then immediately log out and start a new session, I don't see the bug right away - nor have I experienced it at all in my limited testing. I do not use a login manager such as gdm, I run the startx command manually from the console.

Revision history for this message
Jakob Eriksson (jakob-vmlinux) wrote :

Still the same for me in Maverick.

I use a laptop, an HP 6730b. The same problem as other above, but no difference whether I start X from startx, gdm, restart the computer, restarts or whether I have an external USB mouse connected or not.

Same problem, all the time. Sometimes the problem goes away for a minute, then returns and stays like that for hours.

Revision history for this message
rv (shuihuzhuan-deactivatedaccount) wrote :

I have the same problem since the beginning of the week only. I only bought a new mouse 3 weeks ago (logitech usb and wired) that worked nice since then.

Tried with a different login : same problem.
Removed the nvidia proprietary driver, and used the nouveau driver : same problem (+ some refresh problems during scrolling)
Pluging and unpluging the mouse doesn't solve the problem. The computer is almost unusable without keyboard navigation skills (which isn't the case for everybody at home).

Note : in Rhythmbox, when the problem occurs and the mouse focus is grabed in the list of songs, I see sometimes the color of the selected song switching to grey during 1 or 2 seconds without doing anything.

Next tests I'll try :
- use another mouse on that computer (maverick AMD64)
- test the mouse on another computer with maverick (can try maverick 32bits only)
- test with a livecd on the same computer
- a few years ago, a program listed all actions of the mouse in a terminal in real-time (xmouse maybe?). I will try if I can find it.
- test with another distribution?

Revision history for this message
rv (shuihuzhuan-deactivatedaccount) wrote :

Problem seems to be solved for me (maybe to soon for rejoycing but if someone else can test for his case).

My previous mouse was not a USB one but a PS2 one. In the BIOS I have parameters to support USB mouse and keyboard. These parameters were disabled. I've changed the parameters to "enabled" and the problem seems to have disappeared. Don't know why the new mouse worked few weeks with these parameters disabled???

For completness and because some actions may have had an influence in the result (maybe some cold reboot or disabling/re-enabling USB could have correctly reseted the hardware) :
1 - I first enabled only the mouse parameter (since my keyboard is PS2) and did a warm reboot. The problem seemed to disappear. But few hours later my wife had once the problem.
2 - I completly shut down the computer to do a cold boot.
3 - I disabled USB in the BIOS and rebooted until login (so no mouse, just PS2 keyboard),
4 - then rebooted into the BIOS, only enabled USB 1.1, enabled both mouse and keyboard USB support, rebooted and played a while to check everything was okay in a session,
5 - then rebooted into the BIOS, re-enabled USB2, rebooted and since then I don't have anymore problems with the mouse.

Hope this can help.

Revision history for this message
Andrew Kirkpatrick (ubermonk) wrote :

I've had this problem intermittently since 9.04. Recently in 10.04 it became really bad, so I upgraded to 10.10 and the problem remained. Plugging in a second wired mouse didn't fix the problem, but the moment the wireless logitech mouse was unplugged the problem ceased and hasn't happened since.

Revision history for this message
Martinique (martinique) wrote :

I was plagued by this problem for a long time (probably since 9.04), until I got fed up, opened my laptop and disconnected its touchpad permanently (I prefer a mouse anyway). That fixed the problem for me, but this is not something I'd recommend others to do, especially since there's often a switch or a BIOS setting to disable a touchpad.

Apparently the touchpad was producing random click events (even without touching it at all), or so Ubuntu thought, and my guess is that those frequent extra clicks often caused control objects to become stuck. The few times I booted into Windows I had no problems with the touchpad, so maybe the Windows Synaptics driver has a filtration mechanism or sensitivity control of some sort.

Revision history for this message
Nick Seth-Smith (ubuntu-nss) wrote :

I, too, have inherited this problem since upgrading to Lucid. There are a few other characteristics which may help track down the issue:
  - Update Manager is the worst offender for triggering the problem and also reports that it cannot get mouse focus
  - Firefox is another program that will always trigger the issue
  - Most apps that have a Gnome right-click menu can be used to "escape" the block ...
    - Right click on the top menu of the window with focus
    - Right click on your target window
    - Start clicking in the target app
    - The tricky part can be finding the window that currently has the mouse trapped - particularly if it's buried
 - Occasionally I have had the situation where the mouse is focused in one window and the keyboard in another - particularly in an xterm.
 - Once stuck xev does not report window focus changes etc.
  - VMWare Player, as you might imagine, triggers this behavior and can render a machine almost useless

My hardware is as follows:
 - Intel Core 2 Quad Q8400
 - 8Gb RAM
 - Gigabyte EP45-UD3l mobo
 - Logitech wireless mouse
 - Gigabyte GV-R435OC-512I - ATI HD4350 based graphics card
 - SABRENT USB to PS/2 (Dual PS/2) Converter Adapter Cable Model SBT-PS2U
 - NMB RT8256CW keyboard (circa 1996)
 - assorted SATA disks etc.

I am running with ACPI=off noapic in the startup line (and still see all 4 cores in system monitor)

As much as I'd like to see this issue fixed I'm also prepared to buy a different mouse if someone can assure me that the problem would go away. I've almost got the point of turning the machine inside out and running Windows 7 as the host with a Linux guest under VMWare. However since I run a mail server, samba domain controller, web server, mysql server etc. you can understand that would be a last resort!

Any advice gratefully received. Also if you need me to test anything I will be happy to help where I can.


Revision history for this message
Nick Seth-Smith (ubuntu-nss) wrote :

Brief update:

In frustration I switched back to a USB wired mouse. It's branded HP but who knows who actually makes it. Since that point (knock on wood) everything has performed perfectly. I think this supports the theory that the issue is restricted to Logitech wireless mice; however I don't own any other wireless mice to confirm whether this is brand-specific.

Revision history for this message
Ben Sizer (kylotan) wrote :

I'm pretty sure this isn't about the mouse not moving, or about Logitech hardware specifically. I get a very similar problem but the symptoms I've noted are a bit different. Luckily I can reproduce this case all the time on my 11.04 box:

 - Click on the power button icon, select System Settings
 - The window appears with the various options laid out in a grid. I click 'Appearance'.
 - Appearance app opens up, in front of System Settings app, as expected.
 - When I click on the Appearance app, the mouse clicks go THROUGH that app and click on what is behind it.
 - This way, I can launch other apps within the System Settings window even when clicking directly on the Appearance window.
 - I can continue to click on things in the System Settings window through whichever new windows appear, if I know where on the screen below the top-most window they are located.

So it's not that the mouse pointer is stuck, it's that the clicks are going to the wrong window entirely. The mouse position is reflected correctly however.

This happens for me with both of the mice I have tried in the months that I have had this problem (a Razer Diamondback and now a Cyborg R.A.T. 5 mouse). Both work fine on Windows XP, Vista, and 7. Both are USB and wired. And both work fine in Ubuntu up to the point where this issue appears.

I sometimes have another pointing device attached (USB Wacom tablet) but I made sure that was disconnected today and still the problem appears.

Revision history for this message
Simon Ruggier (simon80) wrote :

It's not obvious to me why this was also filed against logitech-applet, and since it seems to be unrelated, I'm marking the logitech-applet part as invalid.

affects: logitech-applet (Ubuntu) → ubuntu
Changed in ubuntu:
status: New → Invalid
Revision history for this message
meist3r (meist3r) wrote :

I'm experiencing the same erratic behavior on a fresh install of Precise 12.04 with a Logitech MX518 wired USB mouse. Replugging the mouse to another USB port temporarily solves the issue. I can go almost a day without it happening but it always occurs if I have used Suspend on my system.

Revision history for this message
Jean-Paul (jeanpaulmaley) wrote :

Same problem on a i7 desktop ubuntu 12.04
I got a rat7 mouse wired usb
hope they get this fixed soon

Revision history for this message
Dennis Mathews (mathews-dennis) wrote :

I can confirm this bug exists on 11.10 ( upgraded from Natty ). Had the same problem on Natty, was hoping it would get fixed with the upgrade but it didn't. On a Thinkpad T410 with only the built-in trackpad. No external mouse/trackpad. This is an extremely frustrating bug that requires me to reboot everytime it happens. Mouse and keyboard have different focus and they are locked in. This has happened in Terminal and Firefox mainly. This is an extremely frustrating bug where only a reboot seems to be the way out. These are the last few lines in Xorg.0.log :

[ 77544.628] (II) intel(0): Printing DDC gathered Modelines:
[ 77544.628] (II) intel(0): Modeline "1440x900"x0.0 101.30 1440 1488 1520 1834 900 903 909 920 -hsync -vsync (55.2 kHz)
[ 77544.628] (II) intel(0): Modeline "1440x900"x0.0 101.29 1440 1488 1520 1904 900 903 909 1064 -hsync -vsync (53.2 kHz)
[ 77545.479] (--) SynPS/2 Synaptics TouchPad: touchpad found
[ 77560.007] (II) XKB: reuse xkmfile /var/lib/xkb/server-9A8405F3FE0A780485714A4B6DD41909C2CF9F83.xkm
[ 77571.436] (WW) SynPS/2 Synaptics TouchPad: Ignoring new tracking ID for existing touch.
[ 78550.305] [mi] EQ overflowing. The server is probably stuck in an infinite loop.
[ 78550.322]

Revision history for this message
Kim Laroux (withered-angel) wrote :

I have been using different version of Kubuntu for the past 3 years without issues. Last week I formatted my drive and installed Kubuntu 12.10. Since then I have been having the exact same issues as described in the bug description.

KDE 4.9.3
Xorg 11.0
synaptiks 0.8.1

Dell Vostro 1500 laptop (with what I believe is a synaptics touchpad)
Logitech G5 USB mouse
Kensington Expert Mouse

The problem is totally random. I have been unable to find a trigger to replicate it. Likewise, I have tried many methods to regain correct focus, but with different success. Sometimes the focus is freed simply by clicking somewhere else, sometimes I can free it by switching to console and then back, while sometimes I have to relog. The problem often happen right after boot, and locks to Thunderbird, which is the first window to open. Relogging will make the problem go away, but can come back at any moment. It can be hours or seconds before the focus gets stuck again.

I looked at the logs, but nothing gets printed when the bug appears or go away.

I can give more information if asked.

The bug has been reported at many level, but since the source cause seems not known even after all these years, I will simply copy/paste this message everywhere.

Changed in ubuntu:
status: Invalid → Confirmed
Revision history for this message
Benjamin Harris (benjaminrharris) wrote :

I've been having this problem recently. Pressing CTRL+ALT+FX (i.e. opening a different console) and then going back with CTRL+ALT+F7 temporarily got rid of the problem for me.

Revision history for this message
Christopher Dokkeberg (chrdok) wrote :

I've been able to reproduce this by opening a terminal, then opening mouse settings. By removing my G930 headset USB dongle however, the problem doesn't' happen.

Each time I open mouse settings with the dongle, the problem happens, and each time I open the settings without the dongle everything is fine.

Revision history for this message
Hasan Yavuz Özderya (hyozd) wrote :

I'm having this problem with Linux Mint, under cinnamon. At the moment I can't reproduce the issue but I want to add that I also have a G930 headset USB dongle attached my computer. This headset has a couple media control buttons and a volume control wheel on it. But from time to time, it starts to act strange. Pressing headset buttons triggers mouse button events such as right click. I never investigated it thoroughly since it's not consistent.

Revision history for this message
John LaRocque (jwlarocque) wrote :

This occurs with my Lenovo T460 with Ubuntu 16.04. It happens quite frequently, especially when using the trackpoint buttons (normal mouse function can be restored temporarily by switching to the console (Alt + F1) and back). The problem can be prevented by disabling the Trackpoint and its buttons in the BIOS. This may be somewhat hardware related, because while all parts of the Trackpoint and Trackpad usually function normally and the symptoms seem to be a software/window focus problem, there are also similar window focus issues with Windows 10.

To post a comment you must log in.
This report contains Public information  
Everyone can see this information.

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.