attempting to mount burned disc via GUI causes drive to stop responding

Bug #374561 reported by Gary D. Huffman, II on 2009-05-10
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Using Ubuntu 9.04 (with all 4 classes of updates) I am unable to mount any burned disc I've tried via the GUI (whether burned with that drive or not). The discs show up under Places (but not on the desktop), however when I click on it I get a pop-up error:

Unable to mount <disc volume label> DBus error org.gtk.Private.RemoteVolumeMonitor.Failed: An operation is already pending

If I ssh in I can mount and read the discs just fine. All pressed discs I've tested mount fine via the GUI. Once the GUI attempts to mount a burned disc, the drive completely stops responding even after the kernel makes attempts to reset it (not even the eject button will work). I've tested with kernel 2.6.28-11 and 2.6.28-12.

I've attached dmesg output from 2.6.18-12 after successfully mounting 3 different pressed discs via the GUI, followed by a failed attempt to mount a burned disc. This is using the Philips DVD8421 burner with the latest firmware (9H10).

Gary D. Huffman, II (gdhuffman) wrote :

Oops... That 2.6.18-12 should be 2.6.28-12.

Gary D. Huffman, II (gdhuffman) wrote :

Given the lack of response, I'm assuming this problem is very hardware specific.

FWIW, the system is a HP Pavilion a730n (desktop, stock hardware with all firmware updates). The system id is 7cb3dd11aee4db9554a5a15bbc6c847b in the launchpad hardware database (there are 2 with that id now, but it's the one named hp-a730n).

I'd be happy to look into this more if anyone has any ideas where to start. The only thing that immediately comes to mind is to try the latest vanilla kernel and see if it behaves any differently. I will keep you apprised if I find any leads.

Gary D. Huffman, II (gdhuffman) wrote :

Used KernelCheck v1.1.4 to build the latest kernel (using the default settings, minus some drivers that weren't needed). The problem persists.

Attached dmesg from new kernel. I waited for it to boot to the GUI login screen, logged in via ssh, mounted the disc (and was able to view/copy files from it fine), unmounted the disc, logged in locally via the GUI and the drive stopped responding shortly thereafter.

Apparently the problem occurs without even trying to mount the disc via the GUI. Steps required to reproduce the problem:
 a) Insert any burned disc into the burner drive.
 b) Login via the GUI.
 c) Wait a little bit for the kernel to realize there's a problem.

Any ideas where to go from here will be greatly appreciated.

Gary D. Huffman, II (gdhuffman) wrote :

Oddly enough, I've since burned a DVD-Video disc with it and it has no trouble mounting/using those in the GUI environment. I don't know if anyone is working on or looking at this issue, but I figure it can't hurt to include as much information as possible. :)

Gary D. Huffman, II (gdhuffman) wrote :

This is still occurring after updating the system to Karmic. Tested stock kernel as well as the latest kernel-ppa/mainline (2.6.33-999-generic #201001061156 SMP Wed Jan 6 12:51:45 UTC 2010).

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid or Maverick packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Gary D. Huffman, II (gdhuffman) wrote :

Fabio,

Sorry it has taken me so long to reply! I've been real busy with business stuff lately and it slipped my mind. I was able to test Ubuntu 10.04.1 LTS on the same hardware today, and am unable to reproduce this problem anymore! :)

dmesg output looks as expected (and no locking up of the drive), after inserting and browsing 2 different burned CD-Rs normally:

[snip a bunch before the discs are inserted]
[104408.683202] UDF-fs: No VRS found
[104408.683207] UDF-fs: No partition found (1)
[104408.899461] ISO 9660 Extensions: RRIP_1991A
[snip some buffer I/O error noise]
[104753.150346] UDF-fs: No VRS found
[104753.150352] UDF-fs: No partition found (1)
[104753.223992] ISO 9660 Extensions: Microsoft Joliet Level 3
[104753.328054] ISO 9660 Extensions: RRIP_1991A

PS - The reason I didn't associate it with a package is because it's unknown what's responsible or what was even going on exactly. That's why I tried to give as much information as possible. It seemed like that the default Ubuntu GUI (GNOME) was somehow confusing the kernel and causing the drive to completely stop responding until a warm/cold boot of the system. Thanks for the follow-up though!

Fabio Marconi (fabiomarconi) wrote :

No problem Gary and thanks for the reply.
Good notice are ever welcome.
This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers