hardy cannot install to existing partitions

Bug #374202 reported by teledyn on 2009-05-09
10
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

when is a partition not a partition? When it is a Dell Inspiron 1521 with a 120GB ata Fujitsu MhW2120B

I am using the install process from booting the 8.04-alt CD

when I change to alt-F2 and use fdisk, I see the partition table; in the installer log there is a line which correctly reports the sda: sda1 sda2 < sda5 sda6 sda7 >

but the Ubuntu installer does not see any partitions, it only offers to edit the full disk and even when the auto-partition option is taken, it divides the disk incompatibly with the existing partitions. There does not appear to be any way to prevent a re-partitioning of the drive that would destroy all data.

I was running 8.04, very happily, since it was released. I had started with the earlier 7.x and upgraded using the Update Manager. In those days sda1 was windows (2GB) and the remainder split between a 7GB root and the remainder as a small swap and the /home -- this is a normal partition policy, the idea being that I can completely reformat and reinstall the root partition without risk to the precious personal data on the /home partition.

I then upgraded to 8.10 using the Update Manager; this created many quirky problems, emacs was ugly (more than usual) and gnome would spontaneously exit all apps and panels leaving only the background screen, the keybd would lock up -- I thought I might solve those issues with Jaunty and when I encountered the warning about the fglrx support, I did a google check and found the report of the ATI driver "not for 'older' cards" and thought "well a 2 year old card CAN'T be 'old'" and stupidly went ahead. The ATI driver didn't work of course, and the radeon driver performance unusable even in 2D (Radeon X1200).

So I _must_ downgrade back to 8.04, but I also MUST preserve sda7. Normally I would just run the install program and the partition section would show the list of existing partitions and I would set the mount-point for root and ignore sda7, install the system, then fixup the home mount by hand later.

Is this no longer possible with Ubuntu? How could fdisk AND the install logs show the partitions yet the Installer/Partitions section not see ANY partitions? Fwiw, I see the same behaviour with the Jaunty 9.04-alt installer, there is no recognition of prior partitions, it only offers to re-do the entire disk.

delance (olivier-delance) wrote :

When I installed Jaunty on my PC, I used not an automatic partition, but the "handly" option.

teledyn (garym-teledyn) wrote :

I don't know what the 'handly' option is, but I expect it is an on off translation of 'manual' which is where I was when I selected the drive. Once in 'manual' you can select only one line, the full ATI drive, which drops down a list of just one item, the full disk, given as "pri" which is the full size of the drive. There is no hint anywhere that the drive is already partitioned.

now here's a really good clue: If I boot the live-CD for 8.04 or 9.04, there are no desktop icons for the existing partitions ... but there ARE listings in the Nautilus browsers, correctly labelled, one as "ubuntu" the other as "95.1GB Media" and if I click on THOSE, the partitions are mounted; sadly the home partition is not useable since the live-CD marks them (correctly) as having no read-permissions; I can open the media folder, which is the old /home partition, but any of the home dirs inside there are of course chmod 700 and thus live-CD can't open them.

another interesting feature: the Live-CD runs very nicely, very fast, full featured, nice cliear resolution, even with fancy animated effects, yet the INSTALLED 9.04 is too sluggish to use.

a third interesting discovery: the Mandriva 2009 live-CD is also very peppy on this hardware, only when I select the Install option on their live-CD desktop the existing partitions ARE seen and ARE offered for the installation targets! There is one other interesting bit: Mandriva does complain that the partitions "overlap", complaining first that sda2 overlaps with sda5 and then again that sda5 overlaps with sda2 -- I never did understand why (or how) Ubuntu 7.04 created that sda2 and then split it into three virtual partitions instead of just creating 4 partitions, I just assumed Ubuntu knew what it was doing and let it go.

The important discovery is that Mandriva CAN see these partitions and offers to use them for the install target. That means this is a peculiarly Ubuntu effect, and I have now tried alt and desktop disks going back to 7.04 and they ALL fail to recognize this partitioning.

Does this mean I have to go back to Mandriva?

teledyn (garym-teledyn) wrote :

just tried mounting the two existing partitions and THEN running the install from the desktop icon of the live-cd; the installer gets to Keyboard layout and then "Prepare Disk Space" where it says "This computer has no operating systems on it" and offers to use the entire disk, or to alteratively select to specify partitions manually where the diagram shows only one partition.

the previously shown partition icons vanish from the desktop although the /media/disk and /media/ubuntu paths are still mounted and still readable.

teledyn (garym-teledyn) wrote :

Disk /dev/sda: 120.0 GB, 120034123776 bytes
255 heads, 63 sectors/track, 14593 cylinders
Units = cylinders of 16065 * 512 = 8225280 bytes
Disk identifier: 0xa0000000

   Device Boot Start End Blocks Id System
/dev/sda1 * 14267 14594 2620416 83 Linux
/dev/sda2 1500 14593 105177555 5 Extended
/dev/sda5 * 1500 2518 8185086 83 Linux
/dev/sda6 2519 3027 4088511 82 Linux swap / Solaris
/dev/sda7 3028 14593 92903863+ 83 Linux

teledyn (garym-teledyn) wrote :

I do hope someone can find a work-around for this issue, because I'm totally stuck without it -- unless I can revert to Hardy, I cannot run the accelerated 3d graphics on my ATI X1200 Radeon chipset, and that means I cannot edit or watch videos, cannot use youTube and cannot use GoogleEarth, and because the RT kernels are not supported by Jaunty I am also unable to use the laptop for audio recording or jackd-based music composition tools of the Ubuntu-Studio. Because AMD has stranded all X1200 users by dropping support in the xorg-fglrx, the situation is not likely to improve and the ONLY solution is to revert to the last known-good Ubuntu-Studio for this hardware, 8.04.

But to do so requires a complete re-install and I do not have the resources to backup my 60GB of work files :( so I can wipe the entire disk, and besides, given that Mandriva is able to read the partition table just fine, there should be no NEED to re-partition the entire drive to install Ubuntu, we SHOULD be permitted to simply install into the root/boot partitions leaving the user-space /home partition untouched. That is the whole point of having partitions, isn't it? ;)

Anyway, I don't mean to nag, but for my particular case this is an urgent issue, a complete showstopper.

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid or Maverick packages ?
Tanks in advance.

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Fabio Marconi (fabiomarconi) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers