nam (ns2) does not work after partial upgrade of ubuntu 9.04 on 9th May 2009

Bug #374039 reported by alca on 2009-05-09
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Today (9th May 2009) a partial version uprgrade for the O.S. was ready for ubuntu 9.04.
I accepted it. After the process of upgrading i restarted my notebook.
The result was negative. nam application (a part of ns-2 simulator) does not work anymore!
The error reported by nam is the following:

nam:
[code omitted because of length]
: no event type or button # or keysym
    while executing
"bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D / 120) * 4}] units
}"
    invoked from within
"if {[tk windowingsystem] eq "classic" || [tk windowingsystem] eq "aqua"} {
bind Listbox <MouseWheel> {
%W yview scroll [expr {- (%D)}] units
}
bind Li..."

Before the upgrading, nam worked well: 'nam' command in the shell opens a new nam window with a wellcome message.
Now I can't use it because i do not understand what is the real problem at the base!
I tried to run ./install script of ns-2 again but the problem is still present.

I use jaunty-proposed, jaunty-backports, jaunty-updates and jaunty-security upgrades.
I hope there will be a fix for some packets in a short time!

Can anybody understand more?

Other info:
Description: Ubuntu 9.04
Release: 9.04

ns-2 version: 2.31
nam version: 1.13
tk8.4 installed: tk8.4-dev
libxmu-dev installed

alca (alcaweb) wrote :

My friend Manuel posted me a fix: i tried with ns v.2.29 and he tried with version 2.31 and this fic resolved the problem.
Here is the description:

- open the file called tkBind.c in folder ns-allinone-x.xx/tk8.4.xx/generic where instead of 'x'es insert your installed version of ns and tk (note thath ns-allinone-x.xx folder is where you installed ns, if different change it).
- go at line 586 of this file and add the following 3 line at line 589:

   #ifdef GenericEvent
   /* GenericEvent */ 0,
   #endif

after this, you will be ablle to read in tkBind.c file lines like the following:

   /* ColormapNotify */ COLORMAP,
   /* ClientMessage */ 0,
   /* MappingNotify */ 0,
   #ifdef GenericEvent
   /* GenericEvent */ 0,
   #endif
   /* VirtualEvent */ VIRTUAL,
   /* Activate */ ACTIVATE,
   /* Deactivate */ ACTIVATE,
   /* MouseWheel */ KEY
};

after these steps run in terminal ./install to rebuild all ns.

Changed in ubuntu:
status: New → Fix Released
Zagger (sagar23jan) wrote :

yup working...

FicoJF (ficojf) wrote :

For me it at least shows the nam window but when I try to run the simulation it won't do nothing! A little help please!

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers