Distorted display of MSEgui applications

Bug #373781 reported by mse on 2009-05-08
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Ubuntu 9.04, X86-32, default settings:
Reported by several users, MSEgui applications
http://sourceforge.net/projects/mseide-msegui/
are displayed distorted on Ubuntu 9.04, see screenshots. I was not able to reproduce the problem with simple xlib calls so attached a test binary. Click on the window title to see the distorted image. It seems it happens if xcopyarea() and possibly a xfillrectangle() with a stipple bitmap and xsetcliprectangles() calls are followed by a xdrawlines() call. Additionally it depends on timing. Sometimes it helps to place a 20ms sleep instruction before the xdrawlines() call.

mse (fpmse) wrote :
mse (fpmse) wrote :
mse (fpmse) wrote :
Graeme Geldenhuys (graemeg) wrote :

I believe this bug is related to bug #353137

Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Fabio Marconi (fabiomarconi) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

mse (fpmse) wrote :

@Fabio Marconi
You are a robot, aren't you? I don't use Ubuntu so I don't know what Lucid is. We didn't get Ubuntu complaints from our users recently, maybe the problem has gone. You could check yourself, there is a testcase in bug report. There was absolutely no response from Ubuntu team after reporting the problem...

Fabio Marconi (fabiomarconi) wrote :

You are a robot, aren't you?
Sorry for you, but i'm not a robot.
I one month i've readed something like 1000 (of 2500) bug report without package assigned (thanks)
I'm not payed to do this.
I'm not a native english speaker and sometime for me understand what you want to refer require much attention, this is not the
 case, but fatigue is payed on first with attention.

There was absolutely no response from Ubuntu team after reporting the problem...
This report was one of that 2500, and i'm running with one year of delay.
So don't call me robot, sometimes i do something wrong.

Changed in ubuntu:
status: Incomplete → Invalid
Fabio Marconi (fabiomarconi) wrote :

This bug report is being closed due to your last comment regarding this being fixed with an update. For future reference you can manage the status of your own bugs by clicking on the current status in the yellow line and then choosing a new status in the revealed drop down box. You can learn more about bug statuses at https://wiki.ubuntu.com/Bugs/Status. Thank you again for taking the time to report this bug and helping to make Ubuntu better. Please submit any future bugs you may find.

To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers