asus m51sn LCD Brightness

Reported by Paolo4500 on 2009-05-08
This bug report is a duplicate of:  Bug #376668: ASUS M51SN dim. Edit Remove
6
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

I have a laptop (asus m51sn with Nvidia GeForce 9500M GS)in dual boot system Vista / Ubuntu. When i get off Vista and restart system in Ubuntu 9.04, after 3-4 seconds from the start, the LCD brightness go down (dim), it's almost invisible. I can go up by Fn-F6, but the system doesn't remember this brightness, and the problem is the same the next time... I tried all the workarounds in Internet, but nothing works for this problem.
for example i tried this workaround (it didn't solve the problem):
 -------------------------------------------------------------------------------------------------------------------------------------------------------------
"1. Screen Brightness

The ambient light sensor is the cause of the dim screen, we’ll have to turn it off. To fix this we will have to create a shell script that will be run on boot up that will turn of the ambient light sensor.

A) Open Terminal (Menu->Accessories), and type the following:
sudo nano brightness

B) Now paste the following in the Terminal window:
#!/bin/sh
echo 0 > /sys/devices/platform/asus-laptop/ls_switch

C) Hit Ctrl-O to save and then Ctrl-X to exit.

D) Now we will copy our new shell script to the appropriate directory, make it executable and add the following links by typing the following in Terminal:
sudo mv brightness /etc/init.d
and then
sudo chmod 755 /etc/init.d/brightness
and then
sudo update-rc.d brightness defaults 90

E) Reboot, and you will have regained control of your brightness level."

-------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

p.s.: Today (13 may 2009) i updated my Ubuntu 8.10 (it updated also kernel) and now i have the same problem now also in Ubuntu 8.10.

i don't know if it's important, but this is the result of gnome-power-bugreport.sh

-------------------------------------------------------------------------------------------------------------------------------------------------------------------

gnome-power-bugreport.sh
Distro version: DISTRIB_ID=Ubuntu
DISTRIB_RELEASE=8.10
DISTRIB_CODENAME=intrepid
DISTRIB_DESCRIPTION="Ubuntu 8.10"
Kernel version: 2.6.27-14-generic
g-p-m version: 2.24.0
HAL version: 0.5.11
System manufacturer: missing
System version: missing
System product: missing
AC adapter present: yes
Battery present: yes
Laptop panel present: yes
CPU scaling present: yes
Battery Information:
  battery.charge_level.current = 46167 (0xb457) (int)
  battery.charge_level.design = 51260 (0xc83c) (int)
  battery.charge_level.last_full = 48136 (0xbc08) (int)
  battery.charge_level.percentage = 95 (0x5f) (int)
  battery.charge_level.rate = 0 (0x0) (int)
  battery.is_rechargeable = true (bool)
  battery.model = 'F3---24' (string)
  battery.present = true (bool)
  battery.rechargeable.is_charging = false (bool)
  battery.rechargeable.is_discharging = false (bool)
  battery.reporting.current = 46167 (0xb457) (int)
  battery.reporting.design = 51260 (0xc83c) (int)
  battery.reporting.last_full = 48136 (0xbc08) (int)
  battery.reporting.rate = 0 (0x0) (int)
  battery.reporting.technology = 'Li-ion' (string)
  battery.reporting.unit = 'mWh' (string)
  battery.serial = '' (string)
  battery.technology = 'lithium-ion' (string)
  battery.type = 'primary' (string)
  battery.vendor = 'ASUSTEK' (string)
  battery.voltage.current = 12321 (0x3021) (int)
  battery.voltage.design = 11100 (0x2b5c) (int)
  battery.voltage.unit = 'mV' (string)
GNOME Power Manager Process Information:
pippo 6823 0.0 0.3 24524 11288 ? S 18:39 0:00 /usr/lib/gnome-power-manager/gnome-brightness-applet --oaf-activate-iid=OAFIID:GNOME_BrightnessApplet_Factory --oaf-ior-fd=20
giovanni 6900 0.0 0.4 27328 12616 ? Ss 18:39 0:00 gnome-power-manager
HAL Process Information:
111 6190 0.0 0.1 6584 4516 ? Ss 18:38 0:01 /usr/sbin/hald
root 6191 0.0 0.0 3364 1124 ? S 18:38 0:00 \_ hald-runner
root 6210 0.0 0.0 3436 1052 ? S 18:38 0:00 \_ hald-addon-input: Listening on /dev/input/event2 /dev/input/event5 /dev/input/event4 /dev/input/event3 /dev/input/event6 /dev/input/event1
root 6228 0.0 0.0 3448 1040 ? S 18:38 0:00 \_ /usr/lib/hal/hald-addon-cpufreq
111 6229 0.0 0.0 2296 940 ? S 18:38 0:00 \_ hald-addon-acpi: listening on acpid socket /var/run/acpid.socket
root 6242 0.0 0.0 3440 1060 ? S 18:38 0:00 \_ hald-addon-storage: polling /dev/scd0 (every 2 sec)

---------------------------------------------------------------------------------------------------------------------------------------------------------------------------------------

also, trying to solve the problem, i "unceck" the options "enable" in gconf-editor --> apps --> gnome-power-manager --> ambient e backlight --> enable , but it doesn't solve the problem
-------------------------------------------------------------------------------------------------------------------------------------------------------------
updates 15/5/09

i understood that maybe it could be the light sensor of my laptop to cause this problem. I tryed to give max permission rights to ls_level and ls_switch (sudo chmod 777......), and then in the terminal i made so:

 echo 15 > /sys/devices/platform/asus-laptop/ls_level
bash: echo: errore di scrittura: Errore di I/O
 echo 0 > /sys/devices/platform/asus-laptop/ls_switch
bash: echo: errore di scrittura: Errore di I/O

U can see that those comands don't work (bash echo: write error: I/O error).
How can i solve???

in kernel.log i found it (i don't know if it's useful):

pippo-laptop kernel: [ 13.969654] ACPI: Lid Switch [LID]
pippo-laptop kernel: [ 13.992247] asus-laptop: Asus Laptop Support version 0.42
pippo-laptop kernel: [ 13.996203] asus-laptop: M51Sn model detected
pippo-laptop kernel: [ 13.999070] Registered led device: asus::mail
pippo-laptop kernel: [ 14.057525] ACPI: AC Adapter [AC0] (on-line)
pippo-laptop kernel: [ 14.140346] ACPI: Battery Slot [BAT0] (battery present)
pippo-laptop kernel: [ 14.336753] acpi device:20: registered as cooling_device2
pippo-laptop kernel: [ 14.336898] input: Video Bus as /devices/LNXSYSTM:00/device:00/PNP0A08:00/device:1b/device:1c/input/input6
pippo-laptop kernel: [ 14.357014] ACPI: Video Device [VGA] (multi-head: yes rom: no post: no)
pippo-laptop kernel: [ 14.381070] Linux agpgart interface v0.103

Paolo4500 (pingopallo-2) on 2009-05-13
description: updated
Paolo4500 (pingopallo-2) on 2009-05-13
description: updated
Paolo4500 (pingopallo-2) on 2009-05-13
description: updated
Paolo4500 (pingopallo-2) on 2009-05-14
description: updated
Paolo4500 (pingopallo-2) on 2009-05-14
description: updated
Paolo4500 (pingopallo-2) on 2009-05-14
description: updated
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers