Authentication hangs for 30 sec on upgraded Ubuntu 9.04 due to krb5 placed in auth stack

Bug #373435 reported by Mikhail Belov on 2009-05-07
8
This bug affects 1 person
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

Hardware: Samsung NC-10 netbook, 2GB memory upgrade

OS: Dual boot
OS-1: Ubuntu 9.04 upgraded from 8.10 via update manager (via internet)
OS-2: Windows XP Pro SP3 in a separate partition.

Symptoms:
After upgrade any action that required authentication of my account (uid=1000) takes approximately 30 sec to complete.
The problem appeared after upgrading from 8.10 to 9.04.

Cause:
After research it appeared that the problem is related to the pam_krb5.so module placed on top of the auth stack in /etc/pam.d/common-auth for users with uid>=1000 (i.e. regular interactive users). Commenting the line fixed the problem instantly.

Question:
Now, the question is why did updater placed that line in there? This machine had libpam-krb5 package installed at one time(apparently before the upgrade but I do not remember installing it). This for some reason did not cause problems before the upgrade but revealed right after it.

Warning:
Once I determined the cause and was playing with solution (like uninstalling libpam-krb5) I found one scary thing. If the pam_krb5.so line is left in the /etc/pam.d/common-auth after removal of the libpam-krb5 package, the authentication fails. I noticed this while trying to issue some 'sudo' commands in the terminal window. Since I had Synaptic package manager still open I immediately reinstalled the libpam-krb5 which fixed the authentication. I then was able to remove the krb5 line from the /etc/pam.d/common-auth (for which I needed the sudo) and then uninstalled libpam-krb5 for good. I have a feeling that if not for already open package manager, I could have rendered the system unusable - all too easy, just because there was krb5 line and there was no krb5 installed (!).

collinp (collinp) wrote :

Are you sure its not just your hardware lagging? Seeing that you are doing this on a netbook, that might be the case.

description: updated
tags: added: delay hanging krb5 login ubuntu-9.04 upgrade
summary: - Login from screen saver lock hangs for 30 sec on upgraded Ubuntu 9.04
+ Authentication hangs for 30 sec on upgraded Ubuntu 9.04 due to krb5
+ placed in auth stack
description: updated
Fabio Marconi (fabiomarconi) wrote :

Thank you for taking the time to report this bug and helping to make Ubuntu better.
Is this bug reproducible with the latest Lucid packages ?
Thanks in advance.

Changed in ubuntu:
status: New → Incomplete
Fabio Marconi (fabiomarconi) wrote :

 Thank you for taking the time to report this bug and helping to make Ubuntu better. This bug did not have a package associated with it, which is important for ensuring that it gets looked at by the proper developers. You can learn more about finding the right package at https://wiki.ubuntu.com/Bugs/FindRightPackage .

When reporting bugs in the future please use apport by using 'ubuntu-bug' and the name of the package affected. You can learn more about this functionality at https://help.ubuntu.com/community/ReportingBugs.

Fabio Marconi (fabiomarconi) wrote :

We'd like to figure out what's causing this bug for you, but we haven't heard back from you in a while. Could you please provide the requested information? Thanks!

Fabio Marconi (fabiomarconi) wrote :

We are closing this bug report because it lacks the information we need to investigate the problem, as described in the previous comments. Please reopen it if you can give us the missing information, and don't hesitate to submit bug reports in the future. To reopen the bug report you can click on the current status, under the Status column, and change the Status back to "New". Thanks again!

Changed in ubuntu:
status: Incomplete → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers