Netbook Remix should be available as .iso file

Bug #372461 reported by Joe Feinstein on 2009-05-05
22
This bug affects 2 people
Affects Status Importance Assigned to Milestone
Ubuntu CD Images
Undecided
Unassigned
Ubuntu Netbook Remix
Undecided
Unassigned
Ubuntu
Wishlist
Unassigned

Bug Description

Jaunty Remix should be available as .iso file, not just an .img file.

José Cabo (folcwine) wrote :

yes!!

Why the "cd image" is .img against .iso? The other versions are in .iso

Jerone Young (jerone) wrote :

This is because Netbook Remix is mainly for Netbooks. These do not have cdroms. The main method for installation is via USB. So the .img files are meant to be DDed onto a USB stick.

Xan (dxpublica) wrote :

Jerone, yes this is the cause, but it has disavantages. If you have a USB stick with two partitions (ext3 and vfat in my case) and I DDed one partition, then I can't use this partition until I dded another time this partition (the partition become read-only).

If .iso is provided, then we could use unetbootin (that does not have this behaviour; we could add files to the partition).

For the other hand .iso could be useful for people who have external cd drive that could be attached to netbooks.

So +1 for this.

Xan.

Joe Feinstein (jaf6) wrote :

Using dd command to generate the image on the usb stick isn't for everyone. So I suggest to post an iso file on our website. Installing OS shouldn't produce nasty surprises for unsuspected users.

Paul Larson (pwlars) wrote :

This bug has been moved to Ubuntu distribution.

Changed in netbook-remix:
status: New → Won't Fix
Paul Larson (pwlars) wrote :

Confirming, and this was also discussed at UDS recently. Could someone from bug-control please mark this wishlist?

Changed in ubuntu:
status: New → Confirmed
Changed in ubuntu:
importance: Undecided → Wishlist
Paul Larson (pwlars) wrote :

Talked to StevenK on irc who claims this is fixed, would appreciate if someone on the CD Image team could confirm that and close it out if that's the case.

Changed in ubuntu-cdimage:
status: New → Confirmed
Steve Kowalik (stevenk) wrote :

*puts his ubuntu-cdimage hat on*

Well, it will be an ISO for Karmic, but I don't think we want to spin and publish an ISO for Jaunty.

Textureglitch (textureglitch) wrote :

I whole heartedly agree. Using an .img file is madness!

I realize the target for the distro is USB sticks, but why is it a problem to use an .iso file for this?

I've had to help several people figure out how to burn UNR to a CD because they couldn't figure out how to put an .img file on a USB stick and I don't blame them.

Let me summarize my recent experience in trying to get UNR on my laptop:
* The default USB writing app in Ubuntu (administration->create a USB startup disk) does NOT support .img files.
* The default CD writing app Brasero does NOT support .img files.
* The help page (https://help.ubuntu.com/community/Installation/FromImgFiles) recommends something called ImageWriter, I don't know where to find this thing and I shouldn't have to.
* More importantly, the suggested Windows app (Win32 Disk Imager) is a pre-alpha POS that fails with error 8 (no further info) on every computer I've tried. The alternative is a Windows commandline tool from Russia with no discernible connection to Ubuntu, the instructions are in Russian, and some forums warn that it'll corrupt the images.

Alternatively, I've just tested six other netbook distros (Puppy Linux, Easy Peasy, Xubuntu, Cruncheee, Debian EEE, eeebuntu) on a USB stick without any issues at all using Unetbootin (http://unetbootin.sourceforge.net/) which is cross-platform and just works.

In my experience there is no solid cross-platform GUI tool available that makes it easy to handle .img files.
And I don't mind using commandline tools like 'dd' on Linux, but forcing me to use them on Windows is just evil.

Michael Nagel (nailor) on 2009-07-26
summary: - Jaunty Remix should be available as .iso file
+ Netbook Remix should be available as .iso file
Paul Larson (pwlars) on 2009-07-27
tags: added: ubuntu-unr
Loïc Minier (lool) wrote :

It's an ISO in karmic, closing the cdimage task.

Changed in ubuntu-cdimage:
status: Confirmed → Fix Released
Changed in ubuntu:
status: Confirmed → Invalid
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers