Unable to lock screen using Ctrl+Alt+l if "Show pointer when Ctrl is pressed" option enabled

Bug #371012 reported by kroy_28 on 2009-05-02
28
This bug affects 3 people
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

The keyboard shortcut for locking the screen is Ctrl+Alt+L which works perfectly fine.
However if we go to System>Preferences>Mouse and check the option "Show position of pointer when the Control key is pressed", then the lock screen shortcut stops functioning.
If we disable the option of showing the pointer position, lock screen shortcut works.

Apparent in 9.10. It seems that Mouse Preference greedily grabs Control so nothing else sees the KeyPress event. However, the keypress of the L key would have a state field that shows the Control modifier is set.

Changed in ubuntu:
status: New → Confirmed

https://bugzilla.gnome.org/show_bug.cgi?id=125618 seems to be Gnome's bug. If others agree, please link.

SiKing (mark-lehky) wrote :

I just checked this in Lucid-B1, and this is resolved there.

Javier López (javier-lopez) wrote :

This bug report is being closed due to the last comment regarding this being fixed with an update. Please submit any future bugs you may find. Thanks for taking the time to make Ubuntu better.

Changed in ubuntu:
status: Confirmed → Fix Released
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Duplicates of this bug

Other bug subscribers

Remote bug watches

Bug watches keep track of this bug in other bug trackers.