firefox does not open archive manager for tgz files

Bug #367724 reported by Peter Lonjers on 2009-04-27
6
Affects Status Importance Assigned to Milestone
Ubuntu
Undecided
Unassigned

Bug Description

When you click on a tgz file in firefox a menu pops up to save or open the archive in archive manger. If you choose to open in archive manager fails to open it. However if you save it then open it archive manger can open it. You can solve the problem by choosing to have firefox open it in file-roller. However this should either be default or archive manger should be able to handle it. Especially because this is an open format.

Craig Silk (csilk) wrote :

I tried to replicate this in the latest version of Firefox (3.0.10) but couldn't. Is this something that is only affecting a legacy version of Firefox or is it manifesting itself in the latest version on your system?

Changed in ubuntu:
status: New → Incomplete
Peter Lonjers (plonjers) wrote :

Here is an example of the error message I get. I am on firefox 3.0.10 ubuntu Jaunty.

/tmp/team-awesome-3-homework3.tgz could not be opened, because the associated helper application does not exist. Change the association in your preferences.

I was downloading the file from the open course management system moodle.

However I had trouble replicating this bug other places. When I put the same file on my website and then tried it it worked perfectly. I am not sure how to demonstrate this bug without the other person having access to moodle page.

Craig Silk (csilk) wrote :

If you tried the same file on a different server and had no problems, nor had any problems with any other files from elsewhere, I can only assume this is not a firefox 3.0.10 issue. The fact it can't be replicated other than on the specific server/moodle installation you are using backs this theory up.

If you give me the details of the moodle installation you have (version number, apache, php versions etc) I'll download and install it on my server and see if I can replicate, then we can move from there.

I'm having the same problem when trying to download certain archives from the web with firefox. It suggests using "Archive Manager", but then when I say to open the file with it it gives the same error message as Peter.
Example of a problematic file on the web can be found at:
http://www.cs.ucl.ac.uk/staff/V.Kolmogorov/software.html
and then try to open any of the .tar.gz files.
Running Firefox 3.0.11 on Ubuntu 9.04.

Tim Brody (tim-brody) wrote :

When the server-supplied content-type is set to "application/x-compressed" I encountered this bug, changing the content-type to "application/x-gzip" resolved it (Ubuntu 9.10).

David Kaplan (dmkaplan) wrote :

I am having an identical problem trying to open the following archive:

http://pgfoundry.org/frs/download.php/1461/Access2PostgresqlConverter.zip

but this one is listed as a "ZIP archive" which could correspond to one of several content types (how can you determine exactly which one it is?).

I would like to at least see what the default "Archive Manager" is. How can I get my hands on that information and potentially change the value?

I think this bug should be marked as confirmed as several people are noting the same thing.

Thanks, David

Launchpad Janitor (janitor) wrote :

[Expired for Ubuntu because there has been no activity for 60 days.]

Changed in ubuntu:
status: Incomplete → Expired
To post a comment you must log in.
This report contains Public information  Edit
Everyone can see this information.

Other bug subscribers